Can't increase Yast fonts (KDE, qtconfig?)


As the title says. A long time ago it was possible to do this running qtconfig as root. Now it seem to have changed but after Save & Exit, and starting Yast, it sill use the 9 point (I think) default font.

P.S: Also tried qtconfig as user, no dice.

Is there any way I can do this?


No ideas, anyone?

Answer here:

Does that method still work?

This mailing list post indicates that it’s necessary to use “qt5ct” rather than “qtconfig”

Well, I logged as root (please don’t kill me :)) and changed fonts in qtconfig (or was systemsettings? I already forgot). Then logged back to my normal user and Yast fonts were larger. So I suppose it still does.

Actually I used su and qtconfig in a terminal, but IINM su does not use the full root environment, or something like that. So perhaps that was the problem.

Anyway, it seems to be OK now - I’ll be sure after I connect this box to the TV, were Yast fonts were incredibly tiny (old HD TV, cr*appy EDID, etc.)

Just remembered: it was.

Well Yast runs under root and all root users settings are stored in /root (not the home directory) this includes all GUI settings. You can run systemsetting5 as root to set your GUI stuff for any program that runs as root. I change the colors so any program running as root looks different

There’s still nvidia-settings, that look like a qt application but doesn’t change font size, and also firefox menus and tabs (gnome widgets maybe?) that are as small as yast’s font was.

Point is that some display settings like desktop preferences settings are user defined and root is a user, just a very privileged one. So changing settings for a normal user or even for system does not change settings for the root user. The changes must be set in /root for the root user owned windows.

Yes, that is understood. What is curious is that even changing user systemsettings, root systemsettings, qt5ct and qtconfig some applications (nvidia-settings and firefox as noted above) still show small fonts.

How do you become root su - for full root environment

At various times I used:

su -
login as root

But given that there are three applications and two environments, I don’t think I tried all six possible combinations. Anyway, it’s working reasonably well now.

One less: Firefox menu and tabs font can be set at systemsettings5 GTK style (duh…)

Now I’m left with nvidia-settings and knemo’s traffic graphic vertical axis font, small to the point of illegibility.