Can't "Hide menu on boot" or reduce "Timeout in seconds" to zero on openSUSE 12.2

I have a laptop running openSUSE 12.2 x64 in server mode (console).

openSUSE is the only OS on this PC so I thought it would be OK to turn off the grub menu because there are no other OS’s to choose from.

I tried to use

yast bootloader

but it won’t save my changes, they keep reverting to their previous settings.

The two options I am trying to change are Hide menu on boot (enabled/checked) and Timeout in Seconds (set to zero).
When I F10 to OK everything, those changes aren’t saved. I restart the PC and boot uses the old settings of 3 seconds for the **Timeout **and Hide menu is actually not hidden.

I can see the old settings re-applied if I go back into yast bootloader immediately after making new changes - it’s like my changes are not taking effect whatsoever but only for those two settings because I can see changes I made to the Optional Kernal Command Line Parameter are being saved (like changing default runlevel)…

Is there somewhere else I can go to manually input these two changes? Like a config file?

I just gave this a try using my bash script grub2cmd you can get here: GNU Grub2 Command Listing Helper with --help & Input - Blogs - openSUSE Forums and it did work for me. After downloading the file take two more steps, using grub2cmd, one was to manually set the timeout to zero in the file /etc/default/grub by making this line say: “GRUB_TIMEOUT=0” and then I used my “4) Change the Default Grub 2 Menu Selection” selecting the default menu option I want to use and running the grub2 menu update. Setting the default is based on the kernel version and if it is gone due to an update, I am not sure what would happen with the default grub menu option, but you can just use the default instead, which is always the highest kernel version installed.

Thank You,

Please, upload /etc/default/grub before you call YaST2 bootloader and after you saved changes to SUSE Paste and post links here. Also upload /boot/grub2/grub.cfg after you finished changes in YaST2 bootloader module.

I was able to fix this by manually editing the /etc/default/grub file with the needed values:


then ran

grub2-mkconfig -o /boot/grub2/grub.cfg

to apply those changes.

I plan on migrating this machines config to a live/production one soon, so I’ll see if it persists on the new PC when trying to make changes through the YaST bootloader.

You should take a look at my updated (since the last post here) grub2cmd bash script. You can make the changes you suggest and much more: GNU Grub2 Command Listing Helper with --help & Input - Blogs - openSUSE Forums

Thank You,

Good job, that’s a handy script =)