can't hear sound / defaults to dummy audio device

When I use YaST2 to configure my sound card, I can hear sound when I play a test sound; However, neither kmixer (kde) or mixer (gnome) see the device that is installed so I’m not hearing any sound. Only the dummy audio device is listed in the mixer. How can I fix this?

IMHO you do not provide enough information to help you here, and I would like to try help.

What is this ‘dummy sound device’ in the mixer ? Nominally ‘dummy sound devices’ are NOT setup by openSUSE GNU/Linux. Have you done something to create a ‘dummy audio device’ and if so, why ?

I have never heard of the application ‘mixer’. Does not gnome give it a different name ? (I’m not a gnome user)

What desktop are you using ? What openSUSE version are you using ? What can you tell us about your sound hardware and audio configuration ?

Reference the last question, please run the following diagnostic script (when PC is connected to Internet) and select the UPLOAD/SHARE option. That will upload your audio software/hardware configuration to the internet and give you a URL/webaddress where it is located. Please post here that web/address URL. Do NOT post the content of that script output here as it will unduly clutter the thread.


Here is the output of that command:

Here are a couple of screenshots:
Error partag

Volume Mixer (when using Xfce4) partag

Gmixer (when using Gnome) partag

and here is a screen shot of the YaST2 audio configuration page:
alsasound - Setup ALSA sound system partag

82801G (ICH7 Family) High Definition Audio Controller partag

Sound Card Advanced Options partag

And to answer your other questions: I have Gnome, KDE, XFCE4, and LXDE installed on my system but mainly stick with KDE. I have no idea why any of the mixers shown only show the dummy audio device (nor do I know how to create such a device though learning how to might prove useful later) but no matter which mixer I use (as you can tell), only Dummy Audio Device is enabled and is the only one selected. I’m current with OpenSuSE 11.4

OK, I note 32-bit openSUSE-11.4 with the kernel, and version 1.0.23 of the alsa driver, of the alsa library. and alsa utilities. The hardware audio codec is an ALC883 and I note the snd_hda_intel sound module should be loaded.

I also note this in the dmesg:

    7.887370] ALSA patch_realtek.c:1522: SKU: Nid=0x1d sku_cfg=0x4005c603
    7.887379] ALSA patch_realtek.c:1524: SKU: port_connectivity=0x1
    7.887384] ALSA patch_realtek.c:1525: SKU: enable_pcbeep=0x0
    7.887389] ALSA patch_realtek.c:1526: SKU: check_sum=0x00000005
    7.887394] ALSA patch_realtek.c:1527: SKU: customization=0x000000c6
    7.887398] ALSA patch_realtek.c:1528: SKU: external_amp=0x0
    7.887403] ALSA patch_realtek.c:1529: SKU: platform_type=0x0
    7.887408] ALSA patch_realtek.c:1530: SKU: swap=0x1
    7.887412] ALSA patch_realtek.c:1531: SKU: override=0x1

and as I noted before, if you attempted some sort of realtek driver install , then I’m wasting my time (and yours) as none of the suggestions I will provide will be appropriate nor any good. So I hope thats not the case (where you note you have not attempted any sound driver install from Realtek).

I note (which is good):

!!PCI Soundcards installed in the system
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)

and also note (which is not good) :

!!Aplay/Arecord output


aplay: device_list:240: no soundcards found...


**arecord: device_list:240: no soundcards found...**

!!Amixer output

!!-------Mixer controls for card 0 [Intel]

**Invalid card number.**
Usage: amixer <options> [command]

which again is NOT good. (I assume sound IS enabled in your PC’s BIOS).

I recommend you go to YaST > Hardware > Sound and DELETE your audio device, and then again try to reconfigure your sound device.

Also, after having completed doing that configuration, also install the application pulse audio volume control ‘pavucontrol’ which you can use to both configure (only after YaST configuration) your audio and tune the audio volume levels.

If you have made ANY effort to configure/edit files for your audio, please tell me, as what you are reporting is most bizarre and really does make it look like someone was hacking at the audio configuration …

OK, I uninstalled and reinstalled the sound driver through Yast > hardware > sound and even installed pavucontrol as you suggested…still showing dummy device as default.

I can hear sound when I test sound through Yast>hardware>sound but otherwise I cannot.


pavucontrol partag

As you can see it is like the other screen shots from previous post.

Thats probably because your sound card is not configured yet. If it is not configured, then a dummy device may be created by pulse audio as a temporary measure so it won’t crash (thats speculation on my part).

Try this : Go to YaST > Security and Users > User and Group Management > select your user name > select EDIT > select DETAILS and under ‘additional groups’ select ‘audio’ to add your user to the ‘audio’ group (nominally that should not be necessary but if there is a permissions problem it will solve things). Then click on the OK, exit YaST, and restart and test.

Also note, if you have been occasionally logging in to your desktop with root permissions (which is a MAJOR NO NO) you could have messed up your permissions and could be bring this sound problem about now for regular users.

It worked worked. Thank you.

Excellent !

That’s one for me to chalk up to experience, that pulse audio creation of a Dummy Audio device may be a symptom of a permissions problem.

I had the same problem. From one reboot to another (no X root logins in the meantime, or ever) I lost my sound. In Yast the intel sound driver played the test sound but KDE would just show a dummy sound driver and blank configuration settings. Since I found this thread via a search engine, I just wanted to let the internets know that this solution (adding myself to the audio group) solved my problem as well. Thanks!
It would be great to solve the underlying permission problems, but I will leave that for another day.

For reference, here is the output from on my system: openSUSE 13.1, 3.11.10-7-desktop.

That’s interesting to read. I note your PC has an ALC1150, where the ALC1150 has given some users of openSUSE-13.1 some problems.

Just chiming in; I have a ASRock Fatal1ty H97 Killer motherboard, with Realtek ALC1150 onboard audio. With the included 3.13 kernel on Ubuntu 14.04, I had messed up audio output (static, repeating audio; basically it was a mess).

Updated to kernel 3.15.1, and audio works fine now. Not sure how kernels in-between work though.