Can't Get Wireless Working

Please help. I can’t get wireless working. I’m using openSUSE 12.1, on a Dell Inspiron 1546. I read the sticky post about getting wireless working, and matched the bus number from the first page to the second. The firstpage is:
0b:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
Second page:
0b:00.0 0280: 14e4:4315 (rev 01)
I wrote dmesg | less and after 904 lines, I found this:
42.022800] b43-phy0: Broadcom 4312 WLAN found (core revision 15)
But when wrote " sudo /usr/sbin/iwlist scan " it said
lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

wlan0 Interface doesn’t support scanning: Network is down

Please help!

Whoops! Forgot something very important. The router model is Cisco Linksys E1200. Sorry about that!

On 12/12/2011 05:36 PM, contian2001 wrote:
>
> Whoops! Forgot something very important. The router model is Cisco
> Linksys E1200. Sorry about that!

As your system has created wlan0, you have a driver loaded with the appropriate
firmware available. That is good.

The “network is down” message could come from the wireless switch being off. Run


/usr/sbin/rfkill list

Report any output. You may have to install the rfkill package first.

The other reason for the message is that an “ifup” has never been executed. If
you are using NetworkManager, that step is done by it. If you are controlling
networking with ifup, then it needs to be done by you.

When you come back, please say if you are using KDE or Gnome.

Oh sorry. I’m using KDE. I installed rfkill ( I wrote " sudo zypper install rfkill " is that right? ) and then wrote " /usr/sbin/rfkill list " and this is what appeared:

0: dell-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

Sorry, I’m new, but how do I check if I’m using NetworkManager, and if I’m not, how do I execute ifup?

On 12/12/2011 06:26 PM, contian2001 wrote:
>
> Oh sorry. I’m using KDE. I installed rfkill ( I wrote " sudo zypper
> install rfkill " is that right? ) and then wrote " /usr/sbin/rfkill list
> " and this is what appeared:
>
> 0: dell-wifi: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> 1: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: no
>
> Sorry, I’m new, but how do I check if I’m using NetworkManager, and if
> I’m not, how do I execute ifup?

You did it right. That output says that there are no blocks.

As a new user, I recommend that NetworkManager be used. It takes care of a lot
of details that are difficult for an inexperienced user.

From the kickoff (Start), open the Computer tab, and start YaST. (After this,
I’ll just say YaST.) After you enter the root password, select Network Devices
=> Network Settings. Under the Global Settings tab, select “User controlled with
NetworkManager”.

Next, check if the NM applet is running - it will show as the network device in
the lower right-hand cornere of the screen. If it is not running, right-click in
the corner, and unlock the widgets. Then choose “Panel Options” and “Add
widgets”. Scroll across the screen to Network Management, and drag the icon to
the panel. Then right-click, select panel options again, and lock the widgets.

Now left-click on the network widget, and make sure that “Enable network” and
“Enable wireless” are both checked.

At this point, the command “sudo /usr/sbin/iwlist scan” should work. If your AP
is seen in the scan, then click the applet again, and choose “Manage
Connections” and create the connection.

The Enable networking and Enable wireless boxes were already checked, and I ran sudo " /usr/sbin/iwlist scan " again. But I got the same results.

We can assume you ran the firmware install?

sudo /usr/sbin/install_bcm43xx_firmware

caf4926, I just did ran the firmware install, and my wireless works!! Thanks so much!

Lucky guess eh!