Can't get videos to play using Flash

Try copying the flashplayer file here also


There may also be a plugin folder in the firefox profile. If you drill on down, have a look and copy the flashplayer there too.

The above are in hidden user section

Sorry, don’t know what you mean by hidden user section.

In /home/username/.mozilla there is no plugins folder. :frowning:

Similarly, if I drill-down into the /home/username/.mozilla/firefox folder there is no plugins folder. :frowning:

So I don’t know where to copy the file.

I am using Firefox 3.5.2 for OpenSuSE 11.0

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20090730 SUSE/3.5.2-1.1 Firefox/3.5.2


create the folders
so it’s like this



your firefox profile will be different

I should add, whilst I have the folders, flash is not in them. But I’m 32 bit.

Just give it a go, it can’t hurt
su is not needed here BTW

Frustrating to report, but still not working in either Firefox or Konqui despite copying into both folders I created per your suggestion. :\


Is there something so incredibly basic to running Flash in SuSE 11.0, something so incredibly “noob” that I may have overlooked, or set-up wrong?

I hate to think that despite all your great suggestions the cause of my problem may be something I’ve done that nobody’s thought to ask me about because it is so basic. As we say here in the States: “dooh!” (Apologies to Homer Simpson)


But you say it’s listed in the


And it shows ‘enabled’ there?

Yes, let me resummarize everything in one post:

Here is what shows in about:plugins

File name:
Shockwave Flash 10.0 r32

MIME Type Description Suffixes Enabled
application/x-shockwave-flash Shockwave Flash swf Yes
application/futuresplash FutureSplash Player spl Yes

Here is what shows with: rpm -qa | grep flash

gil@phred:~> rpm -qa | grep flash

When in Firefox I try to play a flash video from the website I referenced in the opening post I get a still picture (like a screenshot) of the video superimposed with the words: “video available soon.” Clicking on the screen does nothing.

When in Konqui I try to play the same flash video I get a still picture (like a screen shot) superimposed with the words: “you need Adobe Flash Player version 9.0.115.” Clicking on the screen shot here (it’s a link) takes me to the Adobe site where I’m offered the chance to download and install the version that’s already installed (at least according to Firefox and the YaST package manager)!

However, while still in Konqui if I go to the Adobe site and check the Flashplayer version I get the following: LNX 9,0,246,0.

So Konqui viewing the Adobe website apparently reports a different version than Firefox, YaST package manager, and Opera when it views the Adobe website. Very strange.

When in Opera (which I do not use except in trying to figure out this problem) I try to play the same flash video from the website reference in the opening post it works!

So, Opera plays the flash videos but Firefox and Konqui do not.

In Firefox I can play flash videos from other websites such as However, those same flash videos do not play in Konqui or Opera. Again, very strange.

I did not use the videolan repository except for the libdvdcss file.

I do have Packman enabled and regularly check for updates from there and also OSS, non-OSS, and Update. The other repositories are disabled per suggestions on this OpenSuSE Forum.

I am using 64 bit SuSE 11.0.

Firefox is: Firefox 3.5.2 for OpenSuSE 11.0

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20090730 SUSE/3.5.2-1.1 Firefox/3.5.2

Konqui is: 3.5.9 (using KDE 3.5.9 “release 49.1” OpenSuSE 11.0)

I have copied into:


Is there anything else I can report to you?

Is this from the suse repo’s? It should have been removed.

The instruction here: Flash Player 10 on 11.1 - Page 3 - openSUSE Forums


  1. Remove all installed flash related packages in YaST software management.

Did you do that?

Yes, on August 25th. I removed everything “flash” – flash-player, libflashsupport, and flash-plugin. But, as I posted that day, the instructions are not clear as what to do next.

After deleting the files I still could not play the videos in Firefox or Konqui. And having removed the three files Opera no longer played the videos. So I assumed (?) that I had to reinstall some version of flash-player and the flashplayer plug-in. I installed again using YaST on the assumption (?) that I’d get the latest versions. Doing that did get back Opera, but not Firefox or Konqui.

I tried with and without libflashsupport. Made no difference.

All three files are now removed once again, and still I cannot play the videos on the referenced website. That holds true for all three browsers.

Interestingly, with those three files removed via YaST, the videos on do play in Firefox but not Konqui or Opera.

How they’re playing in Firefox with everything “flash” supposedly removed via YaST is another mystery. :open_mouth:

And I rechecked on the Adobe site and using Firefox it tells me that v of flash player is installed. Where did that come from if I’ve supposedly removed everything “flash” using YaST?

My brain hurts!! :?

Whenever manually removing libraries it pays to run ldconfig (normally
done via the rpm install/remove routine)

sudo /sbin/ldconfig

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 6 days 21:55, 2 users, load average: 0.09, 0.04, 0.04
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

Oh! I assumed (again, that word) that when YaST did its “clean-up” at the end of a package installation or removal all of those mentions of various “configs” displayed on the screen meant YaST was finishing the job.

So you’re saying to run ldconfig after any YaST install or uninstall?

OK, I just ran it per the code you supplied. Thanks!

Now, if only I could get Flash to work in Firefox and Konqui! rotfl!


open Yast software management
search: flash

give us a screenshot of it

This has to be the “noob-iest” question ever. I don’t see anywhere to click to include an attachment such as the screenshot. How do I attach something to my reply?

Is there a button right in front of my nose?


Lately I have been using: ImageBam - Fast, Free Image Hosting and Photo Sharing and then I post the URL here.

OK, here it is.

ImageBam - Fast, Free Image Hosting and Photo Sharing


So what are you getting from this again:

rpm -qa | grep flash

With everything “flash” now removed from the YaST package manager I get:

gil@phred:~> rpm -qa | grep flash


Now check you have done this
Flash Player 10 on 11.1 - Page 3 - openSUSE Forums

And that the plugin has not been removed. You may need to re-do steps 3 and 4

The file was in:

/home/gil/firefox/<my profile>/plugins

It was NOT in:


As super-user I copied it into /usr/lib/browser-plugins.

Made no difference. Still can’t play videos in either Firefox or Konqui.

Note: in step 4 of the instructions you point me to it talks about checking “add ons” in Firefox to see if the plugin is there. I assume this is a typo and the author really meant about:plugins.

If he really meant look in “add ons” then I have nothing there referencing flash. But that would only affect Firefox in any case, not Konqui.