Can't get videos to play using Flash

Hello. I’m using SuSE 11.0 and would greatly appreciate if anyone can help with a solution to why I can no longer play the videos on this website.

2009 Referee Week in Review - Week 20 - U.S. Soccer

The site was recently redesigned. Previously I was able to scroll down the page and play the videos using Flash.

But now Flash won’t work in either Firefox or Konqui to play the videos. (Note, however, that videos on other websites such as do play in Flash, so it’s a mystery beyond my level of understanding.)

On this website with Firefox I get a message superimposed over the screenshots that says “video available soon.” Clicking on the video does nothing.

With Konqui I get a message that says “you need Adobe Flash Player version 9.0.115.” Again, clicking on the screenshots does nothing.

So I looked in the package manager to see what versions of Flash and Flash Player I have installed.

It shows for Flash Player v. (installed)
and for Flash Plug-In v. (installed)
and for libflashsupport v. 000-67.1-i586.

I have refreshed the repositories and tried to update everything Flash – all without making any difference.

I also looked in about: plugins in Firefox and found:

File name:
Shockwave Flash 10.0 r22

I also went to the Adobe website:
Adobe - Adobe Flash Player

and found Flash Player v. I selected the rpm version for Linux, downloaded it, and installed (or so I thought).

None of this made any difference. The new v. that I downloaded and supposedly installed from the rpm doesn’t show up in the package manager. It still shows as v

Note also that disabling Adblock Plus makes no difference (and it was always enabled in the past).

Despite everything I’ve tried I can’t play the videos in either Firefox or Konqui.

Any ideas? I REALLY need to be able to view the videos from this website.


I can play the videos with firefox and flash-player and the depreciated mplayerplug-in. What happens if you remove libflashsupport?

That doesn’t make sence to me. How are have you installed these flash-player versions in the past? Always by rpm command? or did you install any via tarballs?

What is the output of:
rpm -qa | grep flash

Except for the one rpm I referenced in the original post I have installed everything via the package manager. The only reason I tried installing the rpm is that the rpm version is newer than anything I can get using the package manager.

Here’s the output you requested:

gil@phred:~> rpm -qa | grep flash


You probably need version 10
Have you read this Install the latest Adobe flash player, the rpm way - openSUSE Forums

It may help

For _64
Flash Player 10 on 11.1 - Page 3 - openSUSE Forums

Makes no difference.

I followed the instructions from the first link you provided. I already had the version of flash-player referenced. On completion of the instructions it made no difference.

The second link is for SuSE 11.1, but I’m using 11.0. So I’m assuming (?) those instructions don’t apply to my situation.

Thanks for the suggestions, but still not able to play in either Firefox or Konqui. :expressionless:


This is really interesting.

Just for the heck of it I tried Opera (which I never use). The videos do play in Opera. But still they won’t play in Firefox or Konqui.

So, gurus, what is it that allows Flash/flashplayer to connect with Opera but not with Firefox or Konqui?

Very mysterious, no? :\

Also, I forgot to mention previously that I’m using the 64 bit version of SuSE 11.0.

Thx for your suggestions.

This shows to me that you have the wrong version of flash-player installed. You should be able to install flash-player 10 via an rpm command.

If you can not install flash to version 10 via zypper, then possibly your repositories are messed up.

To check your repositories, what is the output of:
zypper lr -d
Once you have the rpm version 10 of flash-player installed, you may need to remove libflashsupport to get firefox playing flash videos. You likely will also need either mplayerplug-in or gecko-mediaplayer in addition to flash-player.

I have not been able to find v 10 of flash-player. Only v 10 of the flashplug-in. I have looked all over the Adobe site. Can you point me to v 10 of flash-player?

I am not familiar with zypper, or installing via zypper. I have only used the package manager or rpms for installation.

Here is the output. I do not know how to interpret this.

gil@phred:~> zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI

1 | openSUSE-retail 11.0 | openSUSE-retail 11.0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0
2 | openSUSE-11.0-Updates | Updates for 11.0 | Yes | Yes | 20 | rpm-md | Index of /update/11.0
3 | repo-oss | openSUSE-11.0-Oss | Yes | No | 120 | yast2 | Index of /distribution/11.0/repo/oss
4 | repo-non-oss | openSUSE-11.0-Non-Oss | Yes | No | 120 | yast2 | Index of /distribution/11.0/repo/non-oss
5 | repo-debug | openSUSE-11.0-Debug | No | No | 120 | NONE | Index of /distribution/11.0/repo/debug
6 | | NVIDIA Repository | Yes | No | 99 | rpm-md |
7 | Index of /repositories/GNOME:/Community/openSUSE_11.0 | openSUSE BuildService - GNOME:Community | Yes | Yes | 99 | rpm-md | Index of /repositories/GNOME:/Community/openSUSE_11.0
8 | Index of /repositories/GNOME:/STABLE/openSUSE_11.0 | openSUSE BuildService - GNOME:STABLE | Yes | Yes | 99 | rpm-md | Index of /repositories/GNOME:/STABLE/openSUSE_11.0
9 | Index of /repositories/KDE:/Backports/openSUSE_11.0 | openSUSE BuildService - KDE:Backports | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Backports/openSUSE_11.0
10 | Index of /repositories/KDE:/Community/openSUSE_11.0 | openSUSE BuildService - KDE:Community | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Community/openSUSE_11.0
11 | Index of /repositories/ | openSUSE BuildService - | Yes | Yes | 99 | rpm-md | Index of /repositories/
12 | Index of /repositories/mozilla/openSUSE_11.0 | openSUSE BuildService - Mozilla | Yes | Yes | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.0
13 | Index of /repositories/server:/php/openSUSE_11.0 | openSUSE BuildService - PHP | Yes | Yes | 99 | rpm-md | Index of /repositories/server:/php/openSUSE_11.0
14 | Index of /pub/videolan/vlc/SuSE/11.0/ | VideoLan Repository | No | No | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.0/
15 | Index of /pub/packman/suse/11.0 | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.0
16 | MMPx64v1 | MMPx64v1 | No | No | 99 | plaindir | dir:///home/gil/downloads/MMPx64v1/

I already have mplayerplug-in v installed.
Thanks for your assistance finding v 10 of flash player and also understanding how to use zypper to install (unless I can install it using the package manager or rpm).


Ahh … I see I missed openSUSE-11.0 in your post. There is an rpm for openSUSE-11.1, but not for openSUSE-11.0.

Sorry, that is my mistake.

What that shows me is you have 16 repositories setup !! IMHO that is too many. Only advanced users (or very solid average users) can get away with that and not have lots of breakage.

I typically recommend only 4. OSS, Non-OSS, Update and Packman. Having more can cause problems for the user who does not have the expertise to diagnosis and solve such problems. Whether that has anything to do with your flash-player problems, I don’t know. But having so many repositories, is something IMHO users who are not advanced (or very strong average) should avoid at all costs.

I recommend you disable all of them except for OSS, Non-OSS, Update and Packman. ie disable #1, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 16.

Then determine which apps you installed from videolan, and with the exception of libdvdcss, replace all the videolan packaged apps with Packman packaged apps.

I appreciate your caution re: too many repositories. Of those sixteen three are disabled: videolan, openSuSE11.0 debug, and

Regarding videolan… When I set up the pooter I followed the very detailed set up instructions posted elsewhere here on the OpenSuSE forums. I did not get anything from videolan except the libdvdcss.

Does the fact that the videos do play with Opera but not with Firefox or Konqui give you any ideas?

Thx :slight_smile:

11.0 11.1 no matter
Many find this works:

Follow the instructions: Flash Player 10 on 11.1 - Page 3 - openSUSE Forums

You have to remove current flash

Hopefully caf4926 has the solution.

Reference the large number of repositories, I have expounded on this many times on this forum. Let me explain.

Lets say you are a person who is packaging applications for a repository. But you know that your applications will depend on packages packaged and included in the basic openSUSE version in order to run. You also know that there are many many many other repositories, which package all sorts of versions of those applications that you will need, with no notice of updates, and not much for testing.

So against what will you build your packages against? You will build them against the basic OSS, non-OSS, Update and just those. No others. Which means if some were to replace an application from the OSS, non-OSS, or Update, with a different version, there is a chance it will not work with the application you have packaged for your repository.

Ergo, its a BAD idea to add many repositories to one’s software package manager, because those who package for those repositories assume a basic OSS, Non-OSS, Update setup. By having so many repositories, you break that assumption and ask for breakage in your applications.

Now advanced users can do this (many repositories) and get away with it, because they have the knowledge/skills to work around this. Many (not all) average users can also get away with it. … But IMHO its asking for nothing but trouble.

Well I could not tell for certain which instructions you pointed me to as there are several different suggestions on that page. I followed the instructions as best I could understand them (NOT clear). One set of instructions said to copy to /usr/lib/browser-plugins and the other said to copy the same thing to /usr/lib64/browser-plugins.

I did both. Neither alone nor both together fixed the problem and, in fact, now Opera no longer plays the videos.

So maybe I did something wrong(?), but I have no idea where if that’s the case. As instructed I deleted all copies of no matter where they appeared. I also deleted anything “flash” in the package manager, but then I have no idea what I am supposed to put back in after copying (again, the instructions are not clear).

But I am definitely in worse shape than before. >:(

Sorry to keep coming back to you, but I need to be able to play these videos in flash.

By the way, the videos on still do play, and those are flash.

What now, coach?

I have done as you suggested. Thx

Extract the plugin, and place a copy of it in /usr/lib64/browser-plugins

To do that you need to be su in a terminal and cd to the location of the newly extracted plugin, then do:

cp /usr/lib64/browser-plugins

I did just that. But I did it as “superuser” by copying (drag and drop) from my home directory (where was extracted from the tar download) to /usr/lib64/browser-plugins. I also copied the same file to /usr/lib/browser-plugins.

Still doesn’t work. :\

Does copying using the terminal as you described do anything different than what I did?


type this in your browser:


does flash show there?

Yes, it’s first on the list.,This is what’s displayed:

Shockwave Flash

File name:
Shockwave Flash 10.0 r32

MIME Type Description Suffixes Enabled
application/x-shockwave-flash Shockwave Flash swf Yes
application/futuresplash FutureSplash Player spl Yes