Can't get to X using liveCD

I am having similar problems as this poster:

Problem installing openSUSE - openSUSE Forums

I have a working image (liveCD 11.1 KDE). I am able to boot to Linux on my desktop computer with it, but when using an older laptop (dell inspiron 1100), I cannot get to the X desktop.

Responses say to use runlevel 3 as the boot option, but when I do, I get the same behavior. I see that runlevel 3 is in effect in the boot log, but then it still hangs right after the “configuring X application” message. The responses say I should land at a command line instead of attempting to enter X.

It’s definitely a problem with recognizing my laptop’s video card (screen flashes and garbage eventually fills most of it).

I have gotten a little further…

By changing to runlevel 1 (not 3), I was able to get to the command line and run
/sbin/yast2 live-installer.

This processed worked (except I could not format the recommended partitioning to host /home - I will address that later). Basically I sucessfully completed these steps - Installation/11.1 Live CD - openSUSE

Now I can get past GRUB and start Linux for the first time from the HDD. Things progress in the GUI until it says “probing your video card”. At this point the screen flashes a few times, garbage results, and finally nothing - no HDD activity. At this point I tried CNTL+ALT+F4 but nothing. Instead I power off.

I tried various sax2 commands (from the command line) but without a change in behavior.

sax2 -a
sax2 --fullscreen
sax2 -r -m 0=vesa

Have referred to SaX2 - openSUSE

How do I configure sax2 to run using my video card in any mode whatsoever?

Do you meet these
Sysreqs - openSUSE

I believe so…

-Processor: Yes, I have a 2.4 GHz Intel Celeron
-Main memory: Yes, 256 MB.
-Hard disk: Yes, Partitioning successful.
-Sound and graphics cards: not sure what modern means. Computer’s manual is (c) 2003.
-Booting from CD/DVD drive - installation is more or less complete.

At this point X is running, but in a lower resolution (800x600) than I expect it should (1024x768). The screen’s not “full”.

I tried a boot option (vga=0x792) which matches my LCD’s maximum resolution per VGA Boot modes to set screen resolution | USB Pen Drive Linux

But I get an error saying:
Undefined video mode number: 792
and I list of low-res modes (up to 800x600)

I checked my BIOS and it labels the video card as:
Intel 845GL


Seems to have been incorrect values for VIRTUAL in the Screen section of xorg.conf

details at
Change screen resolution in SUSE Linux to 1024*768

From the boot screen do the following:

Pause the boot by moving the down arrow, then back up to the default boot. But now press backspace, it should delete any text where you can see: vga=0x…
Remove all text and now type just the number:
and hit enter

at the login type your user name and then password
now type:
then the root password

now type this:
sax2 -r -m 0=vesa
(N.B. the 0 is a zero not a letter)

now reboot: type: reboot

if you don’t get a gui login
login as user at cli and try this at the cli