Cant get /tmp into tmpfs

I’m running OpenSuse 13.1 bottle (all current updates installed) on x86_64 system with 32Gig of ram.
I have been trying to get /tmp into tmpfs but cant seem to get it there, there are other dirs allocated in tmpfs but just not /tmp
Is there a checklist of some kind I can walk through to determine whats wrong?
e.g



# df -h
Filesystem      Size  Used Avail Use% Mounted on
devtmpfs       16G   68K   16G   1% /dev
tmpfs            16G  127M   16G   1% /dev/shm
tmpfs            16G  723M   15G   5% /run
/dev/sda2      25G   9.7G   14G  42% /
tmpfs            16G         0   16G   0% /sys/fs/cgroup
tmpfs            16G  723M   15G   5% /var/run
tmpfs            16G  723M   15G   5% /var/lock
/dev/sda7      2.0G   48M  1.8G   3% /tmp

# ls -l /run/systemd/generator/local-fs.target.requires/ (in part)
lrwxrwxrwx 1 root root 32 Aug 30 18:25 tmp.mount -> /run/systemd/generator/tmp.mount

# cat /run/systemd/generator/tmp.mount
# Automatically generated by systemd-fstab-generator

[Unit]
SourcePath=/etc/fstab
Before=local-fs.target
RequiresOverridable=systemd-fsck@dev-disk-by\x2did-ata\x2dSamsung_SSD_850_EVO_250GB_S2R5NX0H800455R\x2dpart7.service
After=systemd-fsck@dev-disk-by\x2did-ata\x2dSamsung_SSD_850_EVO_250GB_S2R5NX0H800455R\x2dpart7.service

[Mount]
What=/dev/disk/by-id/ata-Samsung_SSD_850_EVO_250GB_S2R5NX0H800455R-part7
Where=/tmp
Type=ext4
Options=acl,user_xattr,noatime

In fstab I have this:
/dev/disk/by-id/ata-Samsung_SSD_850_EVO_250GB_S2R5NX0H800455R-part7 /tmp      ext4  acl,user_xattr,noatime 0 2

# tmpfs /tmp  tmpfs bind,rw,strictatime,mode=1777,nosuid,nodev 0 0


Commenting out the /dev entry for /tmp in fstab and uncommenting the tmpfs line cause a boot hang due to snd_hda_intel (I’m wondering if thats due to a lack of /tmp )

tmpfs    /tmp    tmpfs    size=25%,uid=root,gid=root,mode=1777 0 0

The above is What I have in a 13.1 system. Works.

There is some difference with what you have. I do not understand e.g. what the bind parameter is for.

Also I do not understand what you do with all those systemd files.

Thanks, that worked.