Can't get suse to use my wireless network adapter

I’ve got a problem with openSuse 11.0.
I just installed it after being dissatisfied with Ubuntu. Now, I connect to the internet via a Linksys Wireless-G USB network adapter. On Ubuntu, I was able to use Ndiswrapper to install the driver for my card, and got the internet working fine. So when I now just installed Suse, I found (as expected) the same network problem. So, my question is: how do I get the wireless network working? Do I use Ndiswrapper again? If so, where do I download the proper .rpm files? Are there other alternatives to Ndiswrapper? Linksys is one of the few companies that still refuses to offer Linux native driver support, so there is no Linux driver. Also, the way I am accessing the internet is dualbooting on the same PC into windows. I have no ethernet cable or any other means of direct connection. Thus, I only get network on Linux once I get this adapter working, so telling me some command line code to put into Linux to download the necessary files from some repository will not work.
I appreciate any help!

Is it on your install disk? Ndiswrapper is on the install DVD

Open Yast - Software Repositories and make sure openSUSE-DVD 11.0 is enabled. Then you can open Yast - Software Manager and search for ndiswrapper and install it. If you have other repositories enabled it will give you an error for each repo, just hit skip until the package manager front end appears.
Alternatively you can download the package from the OSS repository Index of /distribution/11.0/repo/oss

OK, thanks, ndiswrapper was on my install dvd, I installed it. But what do I do now? There is no ndisgtk on the dvd, and I’m kinda stuck with out that. I know there’s a way to install the windows driver via command line. Could someone tell me how to go about doing that, or is there a ndisgtk.rpm file that I can download for openSuse?
Thanks for your speedy help!

PackMan :: Package details for ndisgtk

I’m going to point you to the how-to on It should answer all of your questions.

Ndiswrapper - openSUSE

Hello again, thanks for all your help, I was not able to get the ndisgtk.rpm working, but, using the link cbroyles gave me, I was able to configure the whole thing in minutes! I’ve now got fast internet on suse! Thanks! I’ve got one more question though. It automaticly connected to one of three routers that I use, how do I change it to connect to a different router later on? Thanks!

KDE and GNOME both have systray applets (both control NetworkManager) that will allow you to switch between access points. By default, it will automatically attempt to connect to the network with the strongest signal.

By the way, what’s the model of your card? I have a Lynksys Wireless G USB card (that I no longer use) that is supported in openSUSE 10.3+ (actually, it’s supported by the kernel, not openSUSE, but I don’t remember what kernel version the driver was added). openSUSE autloaded the rt2500 driver and the card worked almost perfectly (I think I had previously damaged the card while trying to figure out what chipset it used).

Glad it’s working for you!

Thanks for your reply. I found the solution to my problem, here it is for after comers with the same problem. From Computer in the lower left corner of my screen, I went to Network which is in the lower right portion of the window that pops up, it is under the Status header. Once in Network, I went to the tab labeled Global Options and under Network Setup Method I enabled User controlled with NetworkManager.
After hitting Finish, the network manager icon appeared on my toolbar, and I was able to select which network to connect to!
Thanks for your help.
About my network card, the model number is WUSB54Gv2. It’s a very fast one, and since it’s linksys and not some other noname brand, many systems already have the driver for it. But openSuse 11.0 doesn’t…

euera wrote:
> About my network card, the model number is -WUSB54Gv2-. It’s a very
> fast one, and since it’s linksys and not some other noname brand, many
> systems already have the driver for it. But openSuse 11.0 doesn’t…

Do you understand what the “open” in openSUSE means?

No, I don’t think so. My guess is that it’s open source?

euera wrote:
> No, I don’t think so. My guess is that it’s open source?

Exactly. There are no packages distributed with openSUSE that are not open
source. Other distros may include a Windows driver so that ndiswrapper will
work, but not openSUSE. There are other repositories that have such programs,
but not the official ones.


Ok, that explains it! So, it’s a good thing that I had the driver for my card then!

I think you may also be able to do a iwlist -scan to find the available networks, I do this as su, get MAC addressaf the access point you want to connect to. Then, use the iwconfig wlan0, of course change wlan0 to your adapter, ap the MAC address. Example,

iwconfig wlan0 ap 24:gh:i9:n9:6u

I prefer to use command line, because I have much better luck with it. I only have one Access Point, so I have had no reason to set a default access point using iwconfig, but I seen a spot to put it in the advanced tab in yast in the configure section of the individual device. I use 10.3 so I hope this helps.

Yes, I knew about that, I was just looking for the GUI to do it as I install linux on other people’s systems, and I try and make it so that they can use linux without the command line as much as possible, since that seems to scare a lot of people off.

Thanks for your help!

This thread has been useful to me, a complete non technical newcomer (think I must have ordered the wrong version in getting open suse but will try it) - thanks.

Using the info on here I have managed to get it to find my router - a BT voyager 2091 - it then asks for the key but when I try to enter the key, no letters are accepted, only numbers; the key consists of letters and numbers so I don’t know what to do next. Advice much appreciated.

Sometimes changing the channel helps, also,what type of encryption are you using ? WEP/WPA/WPA-PSK/WPA-TKIP/WPA-AES ?


Thanks Andy - it looks like WEP. Suse defaults to WEP hexadecimal when asking for the input of the key. I don’t know what you mean by changing the channel:(

change the channel on the wireless router/modem. Most wireless router/modem’s have this facility,except the cheap & cheerful ones :wink:


Thanks Andy. I have a BT router (voyager 2091) but there seems to be nothing on it that will let me physically change channels. Even if I was able to, wouldn’t that affect the other PCs I have running from that router?