Can't get sound working again after install opensuse 11.2

Help! please?

Sound worked great under opensuse 11.1 but I upgraded to Opensuse 11.2 and now can not get it working. The information the sticky says to provide is below. I have Checked all of the volumn controls all are set to approx. 75%. Running the sound test in “Yast/hardware/sound/options/play test sound” works…plays the sound
speaker-test -Dplug:front -c2 -l5 -twav doesn’t work - no sound
speaker-test -c2 -l5 -twav doesn’t work - no sound

rpm -q alsa alsa-utils alsa-firmware returns…

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.20.

cat /proc/asound/modules
0 snd_hda_intel

cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xfe020000 irq 17
URl from the

Any help getting this to work would be greatly appreciated I’d rather stay with the newer version.

ok, then you have sound working.

These tests are not all 100% work every time. Some tests work on some hardware, some work on other.

Looking at the diagnostic script, I note:

Simple mixer control ‘Master’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 39
Mono: Playback 19 [49%] -30.00dB] [on]That volume control is so low, I an not surprised you can not hear anything. Note that these volume controls often are NOT linear.

Don’t forget to read and follow the multimedia how to: Multi-media and Restricted Format Installation Guide - openSUSE Forums

Then will you be surprised that the sound is still not working after setting all sound levels to 100% that I can find. I was able to get the sound system working in two programs Gnome Mplayer and Mplayer Multimedia. I should be able to listen to audio no matter what the source of that sound is. I could in 11.1 and even 11.0 using Videolan or even through the browser. I like to listen to and watch movies online in fact I have no choice since the TV is so lame where I have to work that I have little choice.

I reran the shell and the output can be found at

When I ran this I had my headphones and webcam, both of which used to work connected as I was at home versus at work. It shoud not matter though since both device did work “out of the box” on the older version of the OS. I do not use a docking station so I didn’t turn those up.

Really I need help with something I don’t have time to spend hours and hours to try and learn. If there is someplace besides the yast|hardware|sound|other|volume… and alsamixer (also pulse volume control) I’d love to know where it is.


i had to install the alsa-pulse plugin and set in yast-sound-other-disable
look also at systemsettings

OK, if you have sound working in Gnome MPlayer then sound is working in your system. Since you mention Gnome MPlayer, I assume you are a gnome user. One reason (currently the main reason) I refuse to use Gnome is I dislike its audio configuration and how much its pulse audio implementation makes Gnome much harder to use than KDE (which is unfortunate as I like the look/feel of Gnome).

Reference videolan, I can only speak from my experience, which is its a bad idea to mix videolan and packman packaged applications. That is because the two packaging groups put their codecs in different locations and can not find each others. Again, in my experience, the Packman packaged applications work better.

I recommend you keep your software repositories limited to ONLY 4. ie the 3 official OSS, Non-OSS, and Update, and the one 3rd party, which is Packman. No others. None. None. IF you need an application from another repository then add the repository, install the needed application, and then remove the repository. This will prevent MANY problems from occuring.

wrt videolan, I recommend you REMOVE that repository, and then replace ALL videolan packaged applications with packman equivalent packaged versions.

wrt your browser playing videos, ensure your PCM volume control is UP (as it can dynamically change to zero) and ifa KDE user (and I think you are gnome) ensure the settings for device priority under YaST > Hardware > Sound are consistent with those KDE > Configure Desktop > Multimedia. In the case of Gnome there is likely some gnome/pulse audio control panel.

… and finally, IN ADDITION to the above, if firefox is still giving audio problems, go to Firefox > Edit > Preferences > Applications > Shockwave Flash file and change its selection. Try “Use Flash Player (default)”

Also note that Linux sound does not share the sound device well between applications. If using pulse audio, take a look at this URL: SystemWideInstance - PulseAudio

Good luck.