Can't get Rosegarden to work

Hi everybody!

When I start Rosegarden, my computer freezes. No faillure reports, nothing.
Tyan-Tiger K8W, two Opterons 250, 4 GB memory, OpenSUSE 11.3, Linux 2.6.34.4-0.1-desktop x86_64, KDE 4.4.4 “release 2”.

Who has an idea?

Greetings, Wim

wimlouwerse wrote:
> When I start Rosegarden, my computer freezes. No faillure reports,
> nothing.

what version of Rosegarden did you install?

did you install it using YaST?

did YaST complain/give any errors about anything/mention it couldn’t

solve all dependencies and give you an option?

did you install it from the standard (oss) repo? or some other?

do you have just four repos enabled (oss, non-oss, update and
packman)? if you have more show us the output of:


zypper lr -d

what happens if you open a terminal, type in and enter:


rosegarden

do you get any error messages in the terminal? if so, copy paste them
back to here, please…


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

Hi DenverD!

Thank you for your answer!

> what version of Rosegarden did you install?

10.04-2.11-x86_64 from openSUSE

> did you install it using YaST?

Yes

> did YaST complain/give any errors about anything/mention it couldn’t
> solve all dependencies and give you an option?

No

> did you install it from the standard (oss) repo? or some other?

I don’t know, I just installed it. I have tried it several times.

> do you have just four repos enabled (oss, non-oss, update and
> packman)? if you have more show us the output of:
> zypper lr -d

| Alias | Naam | Ingeschakeld | Vernieuwen | Prioriteit | Type | URI | Service

–±------------------------------±----------------------------------------±-------------±-----------±-----------±-------±----------------------------------------------------------------±-------
1 | download.nvidia.com-opensuse | NVIDIA Repository | Ja | Ja | 99 | rpm-md | ftp://download.nvidia.com/opensuse/11.3/ |
2 | download.opensuse.org-non-oss | Hoofd-installatiebron (niet-opensource) | Ja | Ja | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
3 | packman.inode.at-suse | Packman Repository | Ja | Ja | 99 | rpm-md | Index of /suse/11.3/ |
4 | repo-debug | openSUSE-11.3-Debug | Nee | Ja | 99 | NONE | Index of /debug/distribution/11.3/repo/oss |
5 | repo-non-oss | openSUSE-11.3-Non-Oss | Ja | Ja | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
6 | repo-oss | openSUSE-11.3-Oss | Ja | Ja | 99 | yast2 | Index of /distribution/11.3/repo/oss |
7 | repo-source | openSUSE-11.3-Source | Nee | Ja | 99 | NONE | Index of /source/distribution/11.3/repo/oss |
8 | repo-update | openSUSE-11.3-Update | Ja | Ja | 99 | rpm-md | Index of /update/11.3 |

> what happens if you open a terminal, type in and enter:
> rosegarden
> do you get any error messages in the terminal? if so, copy paste them
> back to here, please…

There comes indeed a lot of text in the terminal; I can not read it all - the Rosegarden splash-image covers it.
Because the computer freezes, I can not copy-paste the text.
I tried also ‘rosegarden > error.txt’ but the result was a file of 0 bytes. Do you know the right way to catch that text?

Greetings, Wim

Hi DenverD!

Maybe this works:
I did ‘rosegarden --nosplash’ and made this picture from the screen:
file:///media/disk/DCIM/100DSCIM/BILD0168.JPG

Greetings, Wim

Hi DenverD!

Maybe this works:
I did ‘rosegarden --nosplash’ and made a picture of the screen:
http://www.concerto-news.nl/BILD0168.JPG

Greetings, Wim

wimlouwerse wrote:
> Hi DenverD!
>
> Thank you for your answer!
>
>> what version of Rosegarden did you install?
>
> 10.04-2.11-x86_64 from openSUSE
>
>> did you install it using YaST?
>
> Yes
>
>> did YaST complain/give any errors about anything/mention it couldn’t
>> solve all dependencies and give you an option?
>
> No
>
>> did you install it from the standard (oss) repo? or some other?
>
> I don’t know, I just installed it. I have tried it several times.
>
>> do you have just four repos enabled (oss, non-oss, update and
>> packman)? if you have more show us the output of:
>> zypper lr -d
>
> # | Alias | Naam
> | Ingeschakeld | Vernieuwen | Prioriteit | Type | URI
> | Service
> --±------------------------------±----------------------------------------±-------------±-----------±-----------±-------±----------------------------------------------------------------±-------
> 1 | download.nvidia.com-opensuse | NVIDIA Repository
> | Ja | Ja | 99 | rpm-md |
> ftp://download.nvidia.com/opensuse/11.3/ |
>
> 2 | download.opensuse.org-non-oss | Hoofd-installatiebron
> (niet-opensource) | Ja | Ja | 99 | yast2 |
> ‘Index of /distribution/11.3/repo/non-oss’
> (http://download.opensuse.org/distribution/11.3/repo/non-oss/) |
>
> 3 | packman.inode.at-suse | Packman Repository
> | Ja | Ja | 99 | rpm-md | ‘Index of
> /suse/11.3/’ (http://packman.inode.at/suse/11.3/)
> |
> 4 | repo-debug | openSUSE-11.3-Debug
> | Nee | Ja | 99 | NONE | ‘Index of
> /debug/distribution/11.3/repo/oss’
> (http://download.opensuse.org/debug/distribution/11.3/repo/oss/) |
>
> 5 | repo-non-oss | openSUSE-11.3-Non-Oss
> | Ja | Ja | 99 | yast2 | ‘Index of
> /distribution/11.3/repo/non-oss’
> (http://download.opensuse.org/distribution/11.3/repo/non-oss/) |
>
> 6 | repo-oss | openSUSE-11.3-Oss
> | Ja | Ja | 99 | yast2 | ‘Index of
> /distribution/11.3/repo/oss’
> (http://download.opensuse.org/distribution/11.3/repo/oss/) |
>
> 7 | repo-source | openSUSE-11.3-Source
> | Nee | Ja | 99 | NONE | ‘Index of
> /source/distribution/11.3/repo/oss’
> (http://download.opensuse.org/source/distribution/11.3/repo/oss/) |
>
> 8 | repo-update | openSUSE-11.3-Update
> | Ja | Ja | 99 | rpm-md | ‘Index of
> /update/11.3’ (http://download.opensuse.org/update/11.3/)
> |
>
>> what happens if you open a terminal, type in and enter:
>> rosegarden
>> do you get any error messages in the terminal? if so, copy paste them
>> back to here, please…
>
> There comes indeed a lot of text in the terminal; I can not read it all
> - the Rosegarden splash-image covers it.
> Because the computer freezes, I can not copy-paste the text.
> I tried also ‘rosegarden > error.txt’ but the result was a file of 0
> bytes. Do you know the right way to catch that text?
>
> Greetings, Wim

shucks! your answers are dis-heartening because they mostly rule out
the easy fixes (clashes between software from too many [conflicting]
ropos, or install errors, or !!)

so, lets try that open with a terminal again…i don’t have
rosegarden installed so i can’t check, but a lot of programs if you
type/enter:


rosegarden --help   <*or* maybe "rosegarden -help"

it will give a list of command switches which might be useful, i’m
hoping there is one like “-nosplash” which will kill that splash screen…

also try the manual [man rosegarden] and info [info rosegarden] or
just the normal documentation for how to kill the splash screen…

then try launching it again and use your camera to take a photo of the
terminal so we can have a look (upload the image to
http://www.imagebam.com/ and paste the link here)

WAIT!!! as always we should check with The Guru of All Gurus to see
his/her knowledge, like here: http://tinyurl.com/3xwr9qt

and, if you drop off the request for “suse” info you will see that
Ubuntu (and others?) have freeze problems with rosegarden also…so,
i bet if you search bugzilla you will find it is a known
problem…and, there may (or may NOT) be a known work around for it…


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

wimlouwerse wrote:
> [image: http://www.concerto-news.nl/BILD0168.JPG]

HEH! you have to find someone a lot younger to read that out loud to me…

BUT first, check around the web as this is not your problem only…

and, as far as i can tell it is not an openSUSE problem at all…

so . . .


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

I have same version of rosegarden on 11.3 64bit and same kernel update, but different audio chip. Mine is working ok.

Noticed one difference to you, I have:

JackDriver::initialiseAudio - JACK sample rate = 44100Hz, buffer size = 1024

whereas you have 48000Hz.

Also, I have no error messages between these lines:

ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 2 periods for playback

and these lines:

JackDriver::initialiseAudio - JACK sample rate = 44100Hz, buffer size = 1024
JackDriver::initialiseAudio - creating disk thread
JackDriver::initialiseAudio - found 4 JACK physical outputs
JackDriver::initialiseAudio - connecting from "rosegarden:master out L" to "system:playback_1"

whereas you have intervening six lines beginning “Cannot use real-time scheduling”… and ending with “AcquireRealTime error”.

Hi DenverD!

> [image: http://www.concerto-news.nl/BILD0168.JPG]
> HEH! you have to find someone a lot younger to read that out loud to me…

You can save the image and look at it with a viewer like Gwenview and zoom-in… :slight_smile:
In my browser, Seamonkey, I can click on the image and zoom in.

> BUT first, check around the web as this is not your problem only…
> and, as far as i can tell it is not an openSUSE problem at all…

Where can I find what I must have? I have been looking on the Rosegarden site, but did not find any help there.

Greetings, Wim

BTW, I had to change the settings in JACK Control (QjackCtl)>Setup, to avoid xruns (overruns) e.g. 44100Hz (CD quality), but your sound card may prefer 48000Hz. I seem to be running ok with Latency of 46.4 msec.

Assuming that Realtime is ticked in your Settings (JACK). You could try ticking Soft Mode to start with, in order to avoid JACK quiting if you are getting xruns, but you would untick Soft Mode when/if recording.

That is all I can think of for now.

Did you add your user account to the “audio” group?

You also need to configure pam, for real-time priorities, by adding lines to /etc/security/limits.conf, for example:

@audio   -  rtprio     99
@audio   -  memlock    unlimited

That should address those error messages I referred to in my earlier post.

consused wrote:
> whereas you have intervening six lines beginning “Cannot use real-time
> scheduling”… and ending with “AcquireRealTime error”.

@wimlouwerse: are you using a real time kernel?

i ask because i remember a guy (gal?) in the last four or five months
talking about he had to use an RT kernel for his audio stuff…

oh, and you asked “Where can I find what I must have? I have been
looking on the Rosegarden site, but did not find any help there.” and
i have to respond: i gave you http://tinyurl.com/3xwr9qt

and now this: http://tinyurl.com/235ol7w

Have a lot of fun, and good luck.


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

It’s not absolutely necessary these days with openSUSE and Rosegarden/Jack, as the default “desktop” kernel now seems to be adequate I and others here use that). Before that kernel was available, you had to have a real-time kernel, and that may still be needed for heavy professional work. Either way, for Jack you need the pam configuration I posted.

Hei,

How does your other Jack audio apps work?

This is a nice page to assist you in configuring the system: http://wiki.linuxmusicians.com/doku.php

That’s a useful link which I hadn’t seen. Thanks for posting it.

Cheers!
Yes, I like it too. Have a look at their main site as well, if you haven’t done so already: LinuxMusicians • Index page

Hi all!

I am back again, after a birthday party of my son in law and the opening of the new year themes in our church, with almost to many good words of our pastor to fill our hearts and a good barbeque to fill our stomachs :wink:

Thank you all for the discussion: I made a bookmark for the LinuxMusicians Wiki - a lot of information!

> Did you add your user account to the “audio” group?

Now I have done it…

> You also need to configure pam, for real-time priorities, by adding lines to
> /etc/security/limits.conf, for example:
> @audio - rtprio 99
> @audio - memlock unlimited

Done also…

And now I have less error messages, but when I start JackCtl, then QSynth (gives a beautifull reverb and a lot more settings than Timidity) and then Rosegarden, my computer freezes again.
I made this picture of the screen:

http://www.concerto-news.nl/BILD0169.JPG

I read there something about a BUG, is that the problem? And do you know a workaround?

Greetings, Wim

Wim, these screensots are really hard to read… could you shoot them a little closer, please?

Edit: Or just put a link to the image here, then we’ll be able to view it in full size.

Just for the record: that is because the desktop-kernel is a realtime-kernel. And yes, it does work quite well with JACK and other applications requiring rt-capabilities, although I personally use jengelhs rt-kernel, as it does seem to handle several audio-sources better than the desktop-kernel. But I suppose for most DAW-users the desktop-kernel will be okay.

Make sure the following Jack packages are sourced from the 11.3 distribution repo and not from “packman”. If packman, remove using YaST and then install the versions from vendor openSUSE (oss repo) by selecting via the Versions tab in the bottom pane. These are my versions:

jack-1.9.5-2.8.x86_64
libjack0-1.9.5-2.8.x86_64
qjackctl-0.3.6-1.25.x86_64

IIRC, one of those packman packages caused a serious bug, and I posted this solution elsewhere in the forum a while ago.

When you have done that, start Jack Control (QjackCtl) on its own i.e. do not start Rosegarden or Qsynth. Having pressed the Start button, check via the Messages button for problems, in particular any “xrun” messages.

Post back with your result(s) or queries. :wink:

No problem here with zoom on SeaMonkey.

Just for the record: that is because the desktop-kernel is a realtime-kernel.
Yes, I should have been more precise.