Can't get openSUSE installed on a system with an INTEL DN2800 ITX motherboard

Has someone been able to get openSUSE installed on a system with an INTEL DN2800 motherboard?

I’ve a big issue with the board and I’m not able to pass the initial boot after the installation. At that point there is no information sent to the display anymore.

I already opened a bug report (#756275]( for it with openSUSE, providing all the nitty-gritty details of the problem.

If someone has an idea how I can install openSUSE on this system / board succesfully, please let me know. It will be highly appreciated!

Just a few questions for you?

  1. What openSUSE version are you trying to install and is it a LiveCD (KDE or GNOME) or a DVD?
  2. Have you tried switching the Video to Vesa or **VGA **during the installation?
  3. Have you tried using the kernel load option called: nomodeset?
  4. If you get it to install have you tried the Failsafe openSUSE startup?

Thank You,

Just a few questions for you?

Several. I started with a liveCD (11.4, 12.1 and 12.2build…), always KDE.


I don’t think so. I tried the failsafe option, but that one does not seem to contain the nomodeset argument.

Yes, but the display goes to standby too.

Most frustrating is that with the openSUSE install iso’s the opening screen (the very first screen where you choose the linux to use, or to boot from disk, and which sometimes provides a memory test option) freezes, while other distro’s (CentOS, Mageia and Fedora) are able to provide a working openingscreen. This makes it also possible to easily install those distributions, although I still need to figure out whether Fedora and CentOS are able to provide a working system after the installation.

Do the live cds boot into the graphical environment?

No. The liveCDs have the same problem as the install iso’s, the opening screen becomes frozen.

BTW: it is a small system, that does not have a build CD / DVD player. For now I use an external DVD player.

That would be my suggestion. I am not an expert user so don’t have any new pieces of advice for you, sorry.

I do not reach the point in installation process where this (video type (VESA / VGA selection)) is set.

I think that I run into 3 problems! The first being a USB driver problem. This is because I can not start with an openSUSE installation from USB stick or external USB DVD drive. I can start with a network installation though.

  1. When the first part of the (network) installation finishes; thus graphical user interface is selected, partitions are defined, package selection has been performed, packages have been installed and the bootloader is written the system boots. But during this boot, the system can not find a bootloader!

With some trickery I was able to boot the earlier installed CentOS and restore the mbr that was created by CentOS. At this point I added menu entries in grub/menu.lst for openSUSE (standard boot and failsafe boot), these were copied from the openSUSE installation. After rebooting the system and making the choice to run the failsafe openSUSE, I run into the 3rd problem, that I’ll explain later.

I think that the boot loader is not written correctly, because fdisk says:
WARNING: GPT (GUID Partition Table) detected on ‘/dev/sda’! The util fdisk
doesn’t support GPT. Use GNU Parted.

/me wondering if openSUSE supports GPT?

  1. problem 3; is that display information is not sent to the external monitor port, but to the internal LVDS port. This makes the monitor completely black and useless. Adding the kernel argument video=LVDS-1:d does not help.

The 3rd problem is showstopper for me, as I’ve been able to cope with the 1ste and 2nd problem using workarounds. However I’ve no alternative for problem #3 :frowning:

I’m disappointed that it is not possible to install openSUSE on this system. Other linux distributions, like CentOS, Fedora, Mageia can all be installed on this system. :\

Ha Richard, :slight_smile:

The gave the bug report a quick read and it looks a lot like my experiences with three ASUS EEEpc X101CH. I was able to install, but then at first boot, a hang, freeze. Is this a board with a ATOM Cedar on it? Read my blog on the forums here, and see if adding the kernel:/stable/standard repo during install may help.
BTW, if it is the GMA500 that’s stopping you, prepare !! Lots and lots to read out there, haven’t found the solution yet. What I want is to compile the emgd driver, but so far I can’t get it to compile, let alone install. With kernel 3.3 the machines do work, using fbdev.

I just tried, but I did not find the option to add a repository during installation. Can you elaborate at which point or how additional repositories such as the kernel:/stable/standard is added during installation?

Thanks in advance!

Elaborating right now: In the first part of the install, you will arrive at the “Installation Mode” page. You’ll see a checkbox for “Inclujde add-on Products from Separate Media”. Check it, the screen will refresh and on the left you’ll see one step added: “Add-on Products”. My habit is to uncheck “Automatic configuration” but that’s up to you. Click next and you will be presented with the repo manager. I added , called it “Kernel 3.3”, told the repo manager I trusted the key, and went on with the install. At the “Installation Summary” screen I checked the Software to find out that the 3.3 kernel was selected for install.
Hope this gets you through the install.

BTW Nederland dankt je ook dit jaar weer voor de belastingaangifte pakketten. Ik doe 't niet zelf, maar heb al heel wat openSUSE gebruikers erop gewezen.

Knurpht, this was magic! With this kernel the system is now running openSUSE!
Thanks a lot for your comments, as those made my Cedar based INTEL DN2800 board work!

Dat is heel erg top om te horen! Ik heb geen idee hoeveel mensen van die pakketten gebruik maakt!