Can't get into KDE

Hi folks,

I re-installed Leap on my system and everything works, bar the GUIs. (reinstall was required as i killed too many packages in some moment of madness)

<CTRL> + <ALT> + <F1> brings me to a console from where I was able to use zypper and yast. I added several repositories and even the NVIDA one, from which I downloaded and installed the recommended drivers. (So WiFi works).
However, even with the NVIDA drivers I can’t access KDE. Only the boot screen comes up and stays in the progress movement (the green diamond with the dots)

After pressing <Esc> I get the details screen (see screen 2) that states “Reached target Graphical Interface.”

I can see that “Frozen-Bubble Server Daemon” failed, but that was (to the best of my very limited knowledge) was one of the games I tried to get rid off.

When I hit <ESC> as soon as the screen1 comes up I see some other red lines (FAILED), but I can’t identify what else fails.

To the environment (before I get blamed that I left that vital piece of information out as all newbies do):

  • Hardware: Dell Latitude D830
  • Bios: V15
    (never had the urge to upgrade to this years V17, and wouldn’t know how to do in a pure OpenSUSE environment anyhow)
  • OS is Leap 42.1 64 bit
  • Graphic: NVIDIA Quatro NVS 135M
  • RAM: 2 GB
  • File system: ext4
  • Kernel: Linux 4.1.31-30-default x86_64
    no package kernel installed

Well, this has likely one of two reasons:

  • the display-manager.service isn’t being started (maybe because some requirement fails to start, you did mention some other “FAILED” lines)
  • Xorg fails to start, maybe because it cannot load the graphics driver.

So, what does “systemctl status display-manager.service” say?
Does “systemctl restart display-manager.service” help?
Does “startx” (as root) work and give you a graphical display?
If not, the output may be helpful.

Hi wolfi323,

Thanks for the quick response.
The command: systemctl status display-manager.service
No such file
active:inactive (dead)
Loaded: not-found (reason: no such file or directory)

Is xdm installed?
Probably not, which would explain why the graphical interface doesn’t start.

Installing it will hopefully fix your problem then:

zypper in -f xdm

Though other things may be missing as well in that case.

Maybe below commands give more info

sudo journalctl -u display-manager.service


paste /var/log/Xorg.0.log | grep -ie EE -ie WW

Also, as we speak about KDE I thought sddm is the proposed display manager. Maybe I have things confused here.

I did teh zypper and the package was installed and updated, but systemctl status display-manager.service still doesn’t find a file

If you have installed xdm properly, maybe you should enable the service manually.

Look my results

ls -ld /etc/systemd/system/xdm.service
/etc/systemd/system/xdm.service -> /usr/lib/systemd/system/display-manager.service


sudo systemctl enable xdm.service

and reboot the system.

Well, if there is no display-manager.service, Xorg won’t get started at all so there will not be anything found in the Xorg.0.log either…

Also, as we speak about KDE I thought sddm is the proposed display manager. Maybe I have things confused here.

Yes, sddm is the default display manager in a standard KDE installation.

But in openSUSE, the display manager is started by the generic display-manager.service (which reads /etc/sysconfig/displaymanager to determine which one it should start), and that is included in the xdm package.

Please don’t.
xdm.service is just a symlink to display-manager.service for compatibility with older versions.

Did you reboot afterwards?
systemd probably won’t notice the new files automatically.
Running “systemctl daemon-reload” should make it rescan the units as well.

Big Thank You to all,
reboot was somehow successful, I am not in KDE, but in IceWM, Yeah!

The output of journalctl as asked above is:
/etc/vconsole.conf available
keymap: uk
Command: localctl set-keymap uk
I: Using systemd /usr/share/systemd/sdb-model-map mapping
Starting service xdm…done
Started X Display Manager
then some info about error looking up user information (typos caused me to re-enter login details)
and finally: pam_unix(xdm:session): session opened for user NAME by (uid=0)

So now that I have a GUI I will figure out how to get my loved KDE back.

As I said, there may be other packages missing (otherwise xdm should have been pulled in too).

Do you have auto-login working, or do you get the simple xdm as login screen?
If the former, you do have a “proper” displaymanager installed, if the latter, set DISPLAYMANAGER in /etc/sysconfig/displaymanager appropriately, e.g. to “sddm” (the default one in a KDE installation) or “kdm” (the one used in previous KDE4 based versions), and make sure the corresponding package is installed (sddm or kdm).

Check that DEFAULT_WM in /etc/sysconfig/windowmanager is set to “plasma5”, and that the package plasma5-session is installed.

This should give you a functional KDE/Plasma5 desktop.