Can't Get Interfaces to Come Up without IPs

I’m trying to configure OpenSuSE 11.2 with Open vSwitch, and I’m having trouble getting various interfaces to come up automatically when I have bootmode set to “none.” startmode is set to auto (or on - tried both), and bootmode set to none, with no IP address assigned in the file. At boot time, I get the message that it’s bringing up eth0, for example, but when I log in and check, the interface is not up. Also, if I try “ifup eth0”, I get the following output:

xen-users:~ # ifup eth0
eth0 device: Intel Corporation 82566DM-2 Gigabit Network Connection (rev 02)

but the interface is not brought up. Can someone point me in the direction of why SuSE is saying that it’s bringing up the interface successfully, but is actually not bringing it up?


After a little investigation, I’ve answered by own question. In the /sbin/ifup script, there’s a section that case section that checks the value of BOOTPROTO and behaves differently based on those values. On OpenSUSE 11.2, I find the following in that case statement:


On systems where BOOTPROTO=none behaves as expected (e.g. SLES10), this is not present in the /sbin/ifup script. I was able to work around this problem by setting BOOTPROTO=noaddr, which forces the ifup script into the *) section, which brings the interface up correctly. Anyone have any clue why there’s a blank none) section for the ifup script??