can't get HDMI sound to work

trying to get sound to work on my LCD tv, plugged into my video card by a HDMI cable.
My X-FI Xtreme Gamer Fatality Pro sound card makes sound work fine.
I’ve gotten sound on my LCD TV to work using Mageia, but not suse.

When you do not even tell what version of opnSUSE you use, not many people will be able to help you adequatly.

And I may be a noob on this subject, but mentioning a video card and not adding it’s make and type seems also an ommision IMHO.

You may contemplate yourself about adding more important information spontaneously.

very sorry, it’s a new video card and my first time using SUSE.

ok, OS: Linux 3.1.0-1.2-desktop i686
System: openSUSE 12.1 (i586)
KDE: 4.7.2 (4.7.2) "release 5

and video card is the ASUS GTX560 Ti Direct CU II

To start with, do you have the proprietary nVidia graphic driver installed? Support for HDMI with the default open source nouveau graphic driver is not really there yet.

In case you have that driver already installed, and are in a hurry to get this running, take a look at post#6 in this thread: http://forums.opensuse.org/forums/english/get-technical-help-here/multimedia/476503-suse-12-1-no-sound-through-hdmi-need-links-good-guide.html

I followed the instructions in this link

Installing the NVIDIA binary drivers on openSUSE | silviumc

And things are worse, before my open suse could detect my TV and play video but not sound through my HDMI, but now it can’t detect my TV at all.

I never install the driver using the method you quote, so I have no idea if that could be a factor in your most recent problem. Others who like that repository method (which I do not like) need to answer you there.

Are the nvidia proprietary drivers working properly ? Typically after installing the proprietary drivers one’s PC’s nominal performance in X windows improves. In your case ?

Have you tried installing ‘nvidia-settings - Packman’ from the Packman repository to tune the proprietary driver (and using that to tune your driver) ?

Finally, if you read the thread that I referenced, you will note that the user on that thread, gave me information so I could help - and I was clear on that thread as to the information that would be most useful so I could help a bit. Can you do the same ?

Please provide the following information


rpm -qa '*nvidia*'
glxinfo | grep -i opengl

paste the results of that commands in code tags as I did.
This will show the version of the nvidia rpm’s you have installed and
from that we can conclude if they fit your card and it will show what
driver is active as OpenGL driver.

Given your info about your kernel (Linux 3.1.0-1.2-desktop i686) it
seems you did not apply a single update to your machine - any reason for
this?
I am not sure if it helps, but if you run


zypper patch

as root and update your system you will at least have a system with all
bug fixes since 12.1 was released. If that makes your situation better
is of course unknown to me.
If you do it you have to reboot (there were kernel updates since 12.1
was released).


PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

well dadkind](http://forums.opensuse.org/members/dadkind.html) seems much more technologically knowledgeable then me, for example took me a while to get Gedit to accept that I have permission to edit /etc/pulse/default.pa.

When I did figure that out, it wasn’t clear where

load-module module-alsa-sink device=hw:1,7

was ment to slot into

#!/usr/bin/pulseaudio -nF
#
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, write to the Free Software Foundation,
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.

# This startup script is used only if PulseAudio is started per-user
# (i.e. not in system mode)

.nofail

### Load something into the sample cache
#load-sample-lazy x11-bell /usr/share/sounds/gtk-events/activate.wav
#load-sample-lazy pulse-hotplug /usr/share/sounds/startup3.wav
#load-sample-lazy pulse-coldplug /usr/share/sounds/startup3.wav
#load-sample-lazy pulse-access /usr/share/sounds/generic.wav

.fail

### Automatically restore the volume of streams and devices
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore

### Automatically augment property information from .desktop files
### stored in /usr/share/application
load-module module-augment-properties
load-module module-alsa-sink device=hw:1,7

### Load audio drivers statically
### (it's probably better to not load these drivers manually, but instead
### use module-udev-detect -- see below -- for doing this automatically)
#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
#load-module module-null-sink
#load-module module-pipe-sink

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect
.else
### Use the static hardware detection module (for systems that lack udev/hal support)
load-module module-detect
.endif

### Automatically connect sink and source if JACK server is present
.ifexists module-jackdbus-detect.so
.nofail
load-module module-jackdbus-detect
.fail
.endif

### Automatically load driver modules for Bluetooth hardware
.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
.endif

### Load several protocols
.ifexists module-esound-protocol-unix.so
load-module module-esound-protocol-unix
.endif
load-module module-native-protocol-unix

### Network access (may be configured with paprefs, so leave this commented
### here if you plan to use paprefs)
#load-module module-esound-protocol-tcp
#load-module module-native-protocol-tcp
#load-module module-zeroconf-publish

### Load the RTP receiver module (also configured via paprefs, see above)
#load-module module-rtp-recv

### Load the RTP sender module (also configured via paprefs, see above)
#load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'"
#load-module module-rtp-send source=rtp.monitor

### Load additional modules from GConf settings. This can be configured with the paprefs tool.
### Please keep in mind that the modules configured by paprefs might conflict with manually
### loaded modules.
.ifexists module-gconf.so
.nofail
load-module module-gconf
.fail
.endif

### Automatically restore the default sink/source when changed by the user
### during runtime
### NOTE: This should be loaded as early as possible so that subsequent modules
### that look up the default sink/source get the right value
load-module module-default-device-restore

### Automatically move streams to the default sink if the sink they are
### connected to dies, similar for sources
load-module module-rescue-streams

### Make sure we always have a sink around, even if it is a null sink.
load-module module-always-sink

### Honour intended role device property
load-module module-intended-roles

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

### If autoexit on idle is enabled we want to make sure we only quit
### when no local session needs us anymore.
.ifexists module-console-kit.so
load-module module-console-kit
.endif

### Enable positioned event sounds
load-module module-position-event-sounds

### Cork music streams when a phone stream is active
load-module module-cork-music-on-phone

### Modules to allow autoloading of filters (such as echo cancellation)
### on demand. module-filter-heuristics tries to determine what filters
### make sense, and module-filter-apply does the heavy-lifting of
### loading modules and rerouting streams.
load-module module-filter-heuristics
load-module module-filter-apply

### Load DBus protocol
.ifexists module-dbus-protocol.so
load-module module-dbus-protocol
.endif

# X11 modules should not be started from default.pa so that one daemon
# can be shared by multiple sessions.

### Load X11 bell module
#load-module module-x11-bell sample=bell-windowing-system

### Register ourselves in the X11 session manager
#load-module module-x11-xsmp

### Publish connection data in the X11 root window
#.ifexists module-x11-publish.so
#.nofail
#load-module module-x11-publish
#.fail
#.endif

### Make some devices default
#set-default-sink output
#set-default-source input

I googled around for the “12.9.1 of the troubleshooting guide” and couldn’t find that, so when I found what looked like an easier solution I went with it.

I seem to have succesfully installed “'nvidia-settings - Packman” but it won’t load when I click on it.

Am 13.07.2012 14:06, schrieb arminius75:
>
> I seem to have succesfully installed “’‘nvidia-settings - Packman’
> (http://packman.links2linux.org/package/nvidia-settings)” but it won’t
> load when I click on it.
>
>

What about the info I asked you for (post #7)? It would tell what is
installed and if the proprietary nvidia driver is active at all.


PC: oS 12.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

Me@linux-b6u7:~> rpm -qa '*nvidia*'
nvidia-computeG02-295.49-17.1.i586
x11-video-nvidiaG02-295.49-17.1.i586
nvidia-settings-270.41.06-1.78.i586
nvidia-gfxG02-kmp-desktop-295.49_k3.1.0_1.2-16.1.i586
Me@linux-b6u7:~> glxinfo | grep -i opengl
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 560 Ti/PCIe/SSE2
OpenGL version string: 4.2.0 NVIDIA 295.49
OpenGL extensions:

and I did every update that was available, but I typed in “zypper patch” as root, that downloaded a few things, I’ll let u know if that solves anything.

this might be relevant, but youtube is working now where it wasn’t before.
Well kind of working, Yellow is Cyan, blue is red, and red is blue.
But not in the preview thumbnail, that’s the correct coloring.
If it’s not relevant then I’ll make a separate thread.

The youtube blueish colors (blue people) is a known Flash bug. You can either use html5 in youtube or disable hardware acceleration for Flash
Installing Adobe Flash Player 11.2 on openSUSE 11.4 and 12.1 x86_64 | silviumc

For HDMI sound, look here:
Setting up sound through HDMI in KDE on openSUSE 12.2 | silviumc

Another fix for the blue tint in flash (from the nV News Forums):

                 Originally Posted by **Plagman**                     http://www.nvnews.net/vbulletin/images/buttons/viewpost.gif](http://www.nvnews.net/vbulletin/showthread.php?p=2518770#post2518770)                 
             *For people running into either the  "leaking overlay" or the "blue people" problems, I wrote a patch to  libvdpau_trace.so designed to suppress them.

Please clone libvdpau from git and apply this:

http://plagman.net/stuff/0001-vdpau_…h-quirks.patch

This will cause the resulting trace library to change the VDPAU behavior of any clients that have tracing enabled, so make sure you only enable tracing for the web browser that loads the Flash plugin (eg. for Firefox in Ubuntu, you’d add an “export VDPAU_TRACE=1” line to /usr/lib/firefox-n.n/firefox.sh). Trying to use tracing on any other VDAU client after this has been installed won’t work right as it suppresses all the tracing messages and swaps color channels for some operations. Please make sure to restore a vanilla build of libvdpau_trace.so on your system before filing a VDPAU bug against something else.*

This worked for me. Change the command in the Firefox launcher from “firefox %u” to “export VDPAU_TRACE=1 && firefox %u”.