Can't get generic USB Gamepad to work on OpenSuSE 11.3/GNOME

I have bought a generic gamepad from China quite a while ago, which worked well on Windows XP (it’s HID-compliant). However, after finally being able to switch back to OpenSuSE, I now find that I can’t get it to work.

I am currently running OpenSuSE 11.3, with GNOME. I’ve used the “modprobe joydev” command, and if I run lsusb, I get the following:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID eb1a:2571 eMPIA Technology, Inc. 
Bus 001 Device 005: ID 058f:6362 Alcor Micro Corp. Hi-Speed 21-in-1 Flash Card Reader/Writer (Internal/External)
Bus 001 Device 006: ID 0c0b:b136 Dura Micro, Inc. (Acomdata) 
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID e0ff:0002  
Bus 002 Device 003: ID 06a3:8021 Saitek PLC Eclipse II Keyboard
Bus 002 Device 004: ID 0079:0006 DragonRise Inc. Generic USB Joystick

The last one is my gamepad, and it’s apparently pretty well-known. I have also tried the “cat /dev/input/js1” trick, and it does indeed show garbage when I press buttons or move the analog sticks, so in fact it should be functioning properly. However, I can’t get it work. In Tux Racer it simply doesn’t recognize any joystick/gamepad, and Racer (the simulator) tells me that 0 joysticks have been found.

I have been searching for a solution for quite a while now, but all topics seem to be outdated (older OpenSuSE versions, listing commands that don’t exist and are nowhere to be found…)

Does anyone have any clue how to get this gamepad to work? Even if it means without the analog sticks, if it at least works a bit (I’ll just do without the vibration, which is apparently very hard to get to work under Linux).

I got an old game pad to function by using joy2key

joy2key | Download joy2key software for free at

It translates button and axis inputs into key presses.

% joy2key -X -rcfile ~/.joy2keyrc -config myApplication1

The rc file should contain something like:

Axis thresholds - crossing beyond the value activates a key press

-thresh -16383 16383 -16383 16383 -16383 16383

Application specific config

Either ordinary keys or named keys from /usr/include/X11/keysymdef.h

START myApplication1
-axis a d w s 1 2
-buttons Control_L 2 r c Control_L space 7 f g Shift_L k

START myApplication2