Can't get fglrx to work on openSUSE 12.1 M5 [incl. log]

I have an iMac which is able to run openSUSE whith some manual adjustments. However, fglrx is a naughty piece of driver that keeps stalling my normal boot. I have tried many different things already, with and without xorg.conf, with and without aticonfig --initial, nomodeset (as always), reinstall, etc etc but I can’t figure it out. Could someone give me some help?

I am able to boot to runlevel 3, but init 5 gives me 2 black screens (Mac still responsive)

Thanks for any effort

  • iMac 27"
  • Beamer connected
  • using EFI/Elilo

Xorg.0.log end of file

602.538] (II) fglrx(1): EDID for output CRT2
   602.538] (II) fglrx(1): Output LVDS disconnected
   602.538] (II) fglrx(1): Output DFP1 connected
   602.538] (II) fglrx(1): Output CRT2 disconnected
   602.538] (II) fglrx(1): Using exact sizes for initial modes
   602.538] (II) fglrx(1): Output DFP1 using initial mode 800x600
   602.538] (II) fglrx(1): DPI set to (96, 96)
   602.538] (II) fglrx(1): Adapter ATI Mobility Radeon HD 4670 has 2 configurable heads and 2 displays connected.
   602.538] (==) fglrx(1):  PseudoColor visuals disabled
   602.538] (==) fglrx(1): bNoDRI = NO (copy from primary screen)
   602.538] (==) fglrx(1): UseFastTLS=0
   602.538] (==) fglrx(1): BlockSignalsOnLock=1
   602.552] (II) fglrx(0): Interrupt handler Shutdown.
   602.552] (II) UnloadModule: "fglrx"
   602.552] (II) UnloadModule: "fb"
   602.552] (II) UnloadModule: "fglrxdrm"
   602.552] (II) UnloadModule: "vgahw"
   602.552] (II) Unloading /usr/lib64/xorg/modules/libvgahw.so
   602.552] (II) UnloadModule: "fglrxdrm"
   602.552] (--) Depth 24 pixmap format is 32 bpp
   602.552] 
Backtrace:
   602.553] 0: X (xorg_backtrace+0x26) [0x4a4a56]
   602.553] 1: X (0x400000+0x65a79) [0x465a79]
   602.553] 2: /lib64/libc.so.6 (0x7f7399333000+0x34d80) [0x7f7399367d80]
   602.553] 3: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_x760_atiddxScreenInit+0x60) [0x7f7396ef4aa0]
   602.553] 4: X (AddScreen+0x171) [0x4332b1]
   602.553] 5: X (InitOutput+0x2a4) [0x474d54]
   602.553] 6: X (0x400000+0x27043) [0x427043]
   602.553] 7: /lib64/libc.so.6 (__libc_start_main+0xed) [0x7f739935421d]
   602.553] 8: X (0x400000+0x274f1) [0x4274f1]
   602.553] Bus error at address (nil)
   602.553] 
Fatal server error:
   602.553] Caught signal 7 (Bus error). Server aborting
   602.553] 

Whole log xorg.0.log - Pastebin.com

Thank you for your interest in helping to test openSUSE.

software testers with problems running milestone releases can learn more
about testing pre-release openSUSE by visiting the wiki’s Testing page
<http://en.opensuse.org/openSUSE:Testing>, where is
found info on the openSUSE testing and development process as well as
pointers on logging bugs…

if uncertain an encountered problem is a bug: discuss that with other
testers in the forum set aside specificially for that purpose
<http://tinyurl.com/2du7r4s>, or by subscribing to the
openSUSE-Factory mailing list or joining the #openSUSE-Factory channel
on Freenode, info on those two means here
<http://en.opensuse.org/openSUSE:Communication_channels>

but, in no case is it correct for milestone/beta problems to be
discussed in this forum…


DD
openSUSE®, the “German Automobiles” of operating systems

This should have gone in the Pre-Release/Beta subforum. !2.1 is NOT a supported openSUSE level!

I doubt it is a beta-bug…Getting the drivers to work is hard on any version. However, I cannot exclude that it is a version related problem so I just put it on top.

I use atiupgrade](http://forums.opensuse.org/content/46-ati-driver-atiupgrade.html) regularly to install the latest fglrx on my iMac and check if a newer version is available.

uhura:~ # **lsb_release -rd**
Description:    openSUSE 11.4 (x86_64)
Release:        11.4

uhura:~ # **hwinfo --gfxcard | grep -i -e driver -e device -e subvendor**
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  Device: pci 0x94c8 "Mobility Radeon HD 2400 XT"
  SubVendor: pci 0x106b "Apple Computer Inc."
  SubDevice: pci 0x0084 
  Driver: "fglrx_pci"
  Driver Modules: "fglrx"
  Driver Info #0:

uhura:~ # **atiupgrade**
 (1) - analyzing system... 
 (2) - get latest Catalyst version number...
Latest Catalyst version (11.8) already installed. Do you want to continue? [yn]n

I’m not using 12.1. I doubt 12.1 is supported yet by the ati installer, but atiupgrade can work it around by creating a rpm package for 11.4 and install it on 12.1. You might give it a try and tell us if it works. But it looks like you already have fglrx installed. Does it work without the beamer?

 602.538] (II) fglrx(1): Adapter ATI Mobility Radeon HD 4670 has 2 configurable heads and 2 displays connected.

Will try as soon as I can boot openSUSE again. Mac killed Elilo somehow…but a reinstall is not the solution (tried it). I guess an iMac is never build to be ruled by Linux :wink:

I dualboot openSUSE and OS X for years on My old iMac (actually single boot since I don’t use OS X) and never had problem with rEFIt. I also updated both Linux (several times) and OS X and it didn’t affect the bootmanager. I would say that my iMac is the most stable of all my Linux machines. It never crashes. Others occasionnally do.

Using the drivers/methods from here Sebastian Siebert | Linux, openSUSE, Software und was noch interessant ist (official openSUSE maintainer) never gave me any problem. I don’t see why getting ATi drivers to work is “hard in any version”?!?!?

Seems to be available in German only, however. Basic installation rule:
Get his scrip makerpm.sh http://www.sebastian-siebert.de/2011/08/19/opensuse-proprietaeren-grafik-treiber-amd-catalyst-11-8-als-rpm-installieren/#download.
Run it as root with parameter -i (makerpmati.sh -i). Will download and install the fglrx driver as rpm, recompiling it with every kernel update. Also available on this page: XvBA video acceleration for ATi.