Can't get crontab to execute

Hey everybody!!

I’m trying to get the crontab to execute the following command, but it just won’t, maybe it doesn’t like me or something.

01 12 * * 1-5 /root/.mozilla/firefox/gkmzkjr4.default/extensions/VMwareVMRC@vmware.com/plugins/vmware-vmrc -h “localhost:8333” -M “144” -u root -p root123 &

I’ve tested crontab for other simpler commands and it works for them.

I’m stuck, please help.

Gaurav

Hi
Why are you attempting to run as root? I thought the vmware interface
runs as a service, then you can login via https://your-server:8333/

Just set a crontab to start and stop that service?

You are better off to create a script with things you want to do and
then call that script with cron.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 1 day 3:46, 2 users, load average: 0.15, 0.22, 0.18
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

@malcolm

That crontab entry that I posted is actually used to launch my vmware guest OS console.

It works fine if I run it form shell. I wanted to automate the powering ON of my Windows guest OS through crontab, but it just won’t execute.

Which ceontab? An end-users one or root’s?

How did you create it? Show us a

crontab -l

.

And I am with malcolmlewis in several aspects.

. When you want to run something that is more then onne line or more then ±20 chars long, make a script (do not forget the shebang and to make it executable). and call that from crontab. Much easier to maintain the script then doing

crontab -e

all the time.

.There should not be a .Mozilla file in root’s home directory /root/. That can only be there when you loged in as root and used FF from there which are two major sins.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Agreed… show the crontab and how you created it and everything else in
the crontab setup for that user. For example did you setup environment
variables? Cron, by default, does not setup all of the environment
variables for your user so unless you create some on your own your
application will not have everything it expects to run and will fail.
Search the man cron 5 page for information on ‘environment variables’.

Did you check /var/log/messages for output or the mail subsystem on your
box (for the root user) to see any errors that may have resulted from your
attempt? If this is editing via the crontab -e command it is correct
but if you are using any of the /etc/crontab* files then you are missing a
field that indicates which user to run this as.

Good luck.

hcvv wrote:
> Which ceontab? An end-users one or root’s?
>
> How did you create it? Show us a
> Code:
> --------------------
> crontab -l
> --------------------
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJK+WE3AAoJEF+XTK08PnB5B5MP/00gnMgGC5lCJS35iiB/hL+n
qOiX5QT/EA72yq8WKM1IitlkE8GLFlI2DS0LpnMrL26WC2rZMGaxpG7oLoWWSsYa
Odk8Bta1DPXlfTpFO9OdSjiW53UTd+FONqfS0wD9CR8U280JwLRS322HqhbqytUL
7LEJ2DKFdMTInJpebbNylhTUzaM642ib1oE6h/E3Ks0mKrRaca2QtYUb/waAFkQ6
IBvepHyG83TkmO4Q5zLRpnnK+2rCNPww6gKpj/VxgOn0REHCGgcrFtt3Hffe+jyC
5EpQpnEm26ySPU5Nqs5JdOj9Qq4TCP12SQepcGOVdcZ8oHfzN84Am47DDGZ7fB8K
99KCjbPMCfHzsvC/Ll3lSj3Gv5dM1tLSXbGLiRsU7bEz9R16BTymF+LgoLg7d0SL
VM4ZTrsJp5VVRBG8RDmOOz7AtpQtCXGVbTpJm+TrZJwpDEYA7AKGoLHEuIPHlZ2y
Fz6tVzVv5jsqIPBB06/L+VnCjOr4cVGHiXJlQ6XE9/3hzJUFvMVTKHEo33O0riL7
VvLBfKghWEI4dIHJ5pFUH/N6URO4wQQxz2mwPtp3J4IgtVLv+nvuxe9Lu3Se0nNi
JdWPt9fRFcQZxLw//PjVxQRc8pOBQxpVSYCiljsYYQJRfMJZCek4Mfsg72i4iG1K
o7934Th3PuvApUkOkpgG
=+vUP
-----END PGP SIGNATURE-----

don’t overlook the chance to read these wise words again, and follow
them [as written by malcolmlewis earlier in this thread]:

“You are better off to create a script with things you want to do and
then call that script with cron.”


palladium
Have a lot of fun…

On Tue, 10 Nov 2009 09:26:01 +0000, satanlair911 wrote:

> I wanted to automate the powering
> ON of my Windows guest OS through crontab, but it just won’t execute.

Have a look at the vmrun command, that’s what I use to start VMs remotely
if I need to.

Otherwise I know there’s an option in the poweron settings in the VM that
can start the VM when it’s started up automatically.

Jim


Jim Henderson
openSUSE Forums Moderator

thanks guys for all your help…will get back shortly after trying out all the stuff you’ve suggested.

satanlair911 wrote:

> just won’t, maybe it doesn’t like me or something.

No display. But anyway, …

…do not run X clients as root


Ruurd

Hi,

The problem was with vmware-vmrc, it didn’t have absolute paths.

Found vmrun to be a much better option (thanx hendersj for that).

Thank you all for your help.