Can't get bootchart to work. Help!


I installed bootchart just for fun, and maybe find out what the biggest contributor to the boot time was.

Anyways, I installed it through Zen and it doesn’t seem to work. I’m looking in /var/log after anything related to bootchart but I can’t find anything. When I run bootchart in terminal it says:

torswin@Muninn:~> bootchart
/var/log/bootchart.tgz not found

and I get the same message when I run it as root.

So what do I do wrong?

Did you view the README and INSTALL files?

*"Add a new boot loader entry and modify the kernel command line to
include “init=/sbin/bootchartd”. Example for GRUB (/boot/grub/menu.lst):

title Bootchart logging
root (hd0,1)
kernel /vmlinuz-2.6.10 ro root=/dev/hda1 init=/sbin/bootchartd
initrd /initrd-2.6.10.img

Once the boot process completes (denoted by the existence of
specific processes), the log files are packaged to /var/log/bootchart.tgz."*

aaaaaaaaaaaaaaaaaaaaaaaaaaah (you should get a smiley of someone hammering his/her head into a brick wall or something)

Note to self: RTFM

Thanks :smiley:

Heh…let it be noted that I’ve never said that. :slight_smile: