can't format an ext4 partition in a 4TiB disk


I have recently upgraded my Leap 15.0 to 15.1 without any problem. My system has 3 disks: one for Leap 15.1 (ext4), another disk for win10 (NTFS) and a backup disk (ext4), all of them are 1TiB and gpt.

As I want to backup some important external disks, I changed the backup disk for a 4TiB disk. Since then I could not format it succesfully. I tried first to format it with a single ext4 partition, but when I open the disk I can see only a directory “/run/media/berredo/f61b761e-f7c3-41fe-9b1f-dc4dc156ff3f” with just a folder named “lost+found” with a size of only 20KiB.

    |_ lost+found 

My mother board is not a brand new one, so I supposed that the file system could not handle files greater than 2TiB and tried to split the backup disk into two partitions, one for win10 and the other for the Leap 15.1. Now I can write files to the NTSF partition, but I’m receiving the above mentioned message when accessing the ext4 partition.

My backup disk is described bellow:

Model: ATA WDC WD40PURZ-85T (scsi)
Disk /dev/sda: 4001GB
Sector size (lógic/fisic): 512B/4096B
Partition table: gpt
Disk flags: 

Number  Start   End     Size     File system    Nome                  Options
 1      1049kB  2000GB  2000GB   ext4           Basic data partition
 2      2000GB  4001GB  2000GB   ntfs           Basic data partition  msftdata

Hard drive: /dev/sda

    Device: /dev/sda
    Size: 3.64 TiB
    Encrypted: Não
    Device path: pci-0000:00:1f.2-ata-1
    Device 1 ID: ata-WDC_WD40PURZ-85TTDY0_WD-WCC7K7RZU7XU
    Device 2 ID: scsi-0ATA_WDC_WD40PURZ-85T_WD-WCC7K7RZU7XU
    Device 3 ID: scsi-1ATA_WDC_WD40PURZ-85TTDY0_WD-WCC7K7RZU7XU
    Device 4 ID: scsi-350014ee2bc0e8789
    Device 5 ID: scsi-SATA_WDC_WD40PURZ-85T_WD-WCC7K7RZU7XU
    Device 6 ID: wwn-0x50014ee2bc0e8789
Hard disk:
    Maker: WDC
    Model: WDC WD40PURZ-8ST
    Bus: IDE
    Sectors Number: 7814037168
    Sector size: 0.50 kiB
    Partition table: GPT

Partition: /dev/sda1

    Device: /dev/sda1
    Size: 1.82 TiB
    Encrypted: Não
    Device path: pci-0000:00:1f.2-ata-1-part1
    Device 1 ID: ata-WDC_WD40PURZ-85TTDY0_WD-WCC7K7RZU7XU-part1
    Device 2 ID: scsi-0ATA_WDC_WD40PURZ-85T_WD-WCC7K7RZU7XU-part1
    Device 3 ID: scsi-1ATA_WDC_WD40PURZ-85TTDY0_WD-WCC7K7RZU7XU-part1
    Device 4 ID: scsi-350014ee2bc0e8789-part1
    Device 5 ID: scsi-SATA_WDC_WD40PURZ-85T_WD-WCC7K7RZU7XU-part1
    Device 6 ID: wwn-0x50014ee2bc0e8789-part1
    Partition ID: Linux Native
File system:
    File system: Ext4
    Mount point: /run/media/berredo/f61b761e-f7c3-41fe-9b1f-dc4dc156ff3f
    Label: backup_lin
Partition: /dev/sda2

    Device: /dev/sda2
    Size: 1.82 TiB
    Encrypted: Não
    Device path: pci-0000:00:1f.2-ata-1-part2
    Device 1 ID: ata-WDC_WD40PURZ-85TTDY0_WD-WCC7K7RZU7XU-part2
    Device 2 ID: scsi-0ATA_WDC_WD40PURZ-85T_WD-WCC7K7RZU7XU-part2
    Device 3 ID: scsi-1ATA_WDC_WD40PURZ-85TTDY0_WD-WCC7K7RZU7XU-part2
    Device 4 ID: scsi-350014ee2bc0e8789-part2
    Device 5 ID: scsi-SATA_WDC_WD40PURZ-85T_WD-WCC7K7RZU7XU-part2
    Device 6 ID: wwn-0x50014ee2bc0e8789-part2
    Partition ID: Windows data
File system:
    File system: NTFS
    Mount point: 

Which means that there is file system there (and the lost+found directory is the only thing in there, which is quite normal for a just created file system and before you write anthing to it). It also means you have mounted it using the desktop (whatever desktop it may be).

And when that output is about the “backup disk” (why do you not show the command that created that output???), it seems to be /dev/sda. About 4TB large. Have two partitions, a 2TB one with ext4 and a 2TB one with ntfs.

These observations are rather different from what you tell???

Maybe, you could provide



fdisk -l


df -h

as root, and please post with the prompt/command line at the beginning and the new prompt line at the end.