Can't for the life of me get Totem Player to run.

I have installed all the proper gstreamer codecs from pacman. All my other movie players work (e.g Kaffiene and Vlc), but Totem player always asks for the codecs. When I choose search iit comes back " could not find plugin in any configured source".

I’m running 12.3 KDE

Regards!

I not sure I cannot help directly with your problem, but in order to
make it easier to understand what may be missing can you at least post
the output from


rpm -qa '*gstreamer*' | sort

to see what is really installed on your system.


PC: oS 12.3 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.2 | GTX 650 Ti
ThinkPad E320: oS 12.3 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.2 | HD 3000
HannsBook: oS 12.3 x86_64 | SU4100@1.3GHz | 2GB | KDE 4.10.2 | GMA4500

wallace@linux-u28y:~$ rpm -qa ‘gstreamer’ | sort
gstreamer-0_10-0.10.36-11.6.x86_64
gstreamer-0_10-fluendo-mp3-18-9.7.1.x86_64
gstreamer-0_10-plugin-gnomevfs-0.10.36-9.22.x86_64
gstreamer-0_10-plugins-bad-0.10.23-19.26.x86_64
gstreamer-0_10-plugins-bad-lang-0.10.23-19.26.noarch
gstreamer-0_10-plugins-base-0.10.36-9.22.x86_64
gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.2.x86_64
gstreamer-0_10-plugins-good-0.10.31-11.24.x86_64
gstreamer-0_10-plugins-qt-0.10.2-3.1.1.x86_64
gstreamer-0_10-plugins-ugly-0.10.19-10.21.x86_64
gstreamer-0_10-plugins-ugly-orig-addon-0.10.19-10.21.x86_64
gstreamer-1.0.6-3.1.x86_64
gstreamer-lang-1.0.6-3.1.noarch
gstreamer-plugin-gstclutter-2.0.0-1.1.2.x86_64
gstreamer-plugins-bad-1.0.6-4.2.x86_64
gstreamer-plugins-base-1.0.6-2.6.x86_64
gstreamer-plugins-good-1.0.6-2.8.x86_64
libgstreamer-0_10-0-0.10.36-11.6.x86_64
libgstreamer-1_0-0-1.0.6-3.1.x86_64
PackageKit-gstreamer-plugin-0.8.7-4.5.1.x86_64
phonon-backend-gstreamer-0_10-4.6.2-3.1.1.x86_64

What kind of files do not play for you? I tried now totem with mp3, mp4
and a mkv with x264 codec and all plays.
The difference I see to your list is that I have


gstreamer-plugins-good-extra-1.0.6-2.8.x86_64
gstreamer-plugins-libav-1.0.1-1.1.x86_64
gstreamer-plugins-ugly-1.0.6-2.9.x86_64
gstreamer-plugins-ugly-orig-addon-1.0.6-2.9.x86_64

in addition to what you have (I am no gstreamer expert so I am unsure
which contains support for what media types).


PC: oS 12.3 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.2 | GTX 650 Ti
ThinkPad E320: oS 12.3 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.2 | HD 3000
HannsBook: oS 12.3 x86_64 | SU4100@1.3GHz | 2GB | KDE 4.10.2 | GMA4500

Here is the list of files from my setup:

rpm -qa '*gstreamer*' | sort

gstreamer-0_10-0.10.36-11.6.x86_64
gstreamer-0_10-devel-0.10.36-11.6.x86_64
gstreamer-0_10-libnice-0.1.3-2.1.1.x86_64
gstreamer-0_10-plugin-esd-0.10.31-11.23.x86_64
gstreamer-0_10-plugin-gnomevfs-0.10.36-9.22.x86_64
gstreamer-0_10-plugin-gnonlin-0.10.17-15.1.1.x86_64
gstreamer-0_10-plugins-bad-0.10.23-19.25.x86_64
gstreamer-0_10-plugins-bad-lang-0.10.23-19.25.noarch
gstreamer-0_10-plugins-bad-orig-addon-0.10.23-19.25.x86_64
gstreamer-0_10-plugins-base-0.10.36-9.22.x86_64
gstreamer-0_10-plugins-buzztard-0.6.0-7.20.x86_64
gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.2.x86_64
gstreamer-0_10-plugins-fluendo_mp3-0.10.18-3.2.x86_64
gstreamer-0_10-plugins-fluendo_mpegdemux-0.10.71-2.2.x86_64
gstreamer-0_10-plugins-fluendo_mpegmux-0.10.4-46.2.x86_64
gstreamer-0_10-plugins-gl-0.10.3-5.1.1.x86_64
gstreamer-0_10-plugins-gl-lang-0.10.3-5.1.1.noarch
gstreamer-0_10-plugins-good-0.10.31-11.23.x86_64
gstreamer-0_10-plugins-good-extra-0.10.31-11.23.x86_64
gstreamer-0_10-plugins-qt-0.10.2-3.1.1.x86_64
gstreamer-0_10-plugins-ugly-0.10.19-10.20.x86_64
gstreamer-0_10-plugins-ugly-lang-0.10.19-10.20.noarch
gstreamer-0_10-plugins-ugly-orig-addon-0.10.19-10.20.x86_64
gstreamer-0_10-plugins-vaapi-0.4.0-3.1.1.x86_64
gstreamer-0_10-plugins-vaapi-devel-0.4.0-3.1.1.x86_64
gstreamer-0_10-utils-0.10.36-11.6.x86_64
gstreamer-1.0.6-3.1.x86_64
gstreamer-fluendo-mp3-18-9.7.1.x86_64
gstreamer-lang-1.0.6-3.1.noarch
gstreamer-libnice-0.1.3-2.1.1.x86_64
gstreamer-plugin-gstclutter-2.0.0-1.1.2.x86_64
gstreamer-plugins-bad-1.0.6-3.7.x86_64
gstreamer-plugins-bad-orig-addon-1.0.6-3.7.x86_64
gstreamer-plugins-base-1.0.6-2.6.x86_64
gstreamer-plugins-farstream-0.2.2-2.1.1.x86_64
gstreamer-plugins-good-1.0.6-2.7.x86_64
gstreamer-plugins-good-extra-1.0.6-2.7.x86_64
**gstreamer-plugins-libav-1.0.1-1.1.x86_64**
gstreamer-plugins-ugly-1.0.6-2.8.x86_64
gstreamer-plugins-ugly-lang-1.0.6-2.8.noarch                                                                                                                                
gstreamer-plugins-ugly-orig-addon-1.0.6-2.8.x86_64                                                                                                                          
gstreamer-utils-1.0.6-3.1.x86_64                                                                                                                                            
libgstreamer-0_10-0-0.10.36-11.6.x86_64                                                                                                                                     
libgstreamer-0_10-0-32bit-0.10.36-11.6.x86_64                                                                                                                               
libgstreamer-1_0-0-1.0.6-3.1.x86_64                                                                                                                                         
libgstreamer-1_0-0-32bit-1.0.6-3.1.x86_64                                                                                                                                   
PackageKit-gstreamer-plugin-0.8.7-4.5.1.x86_64                                                                                                                              
phonon-backend-gstreamer-0_10-4.6.2-3.1.1.x86_64                                                                                                                            
python-gstreamer-0_10-0.10.22-8.2.x86_64 

The file “gstreamer-plugins-libav-1.0.1-1.1.x86_64” is likely the problem as nothing seems to require it, but it does not work without it being installed.

Thank You,

Make sure your gstreamer packages (no matter what version) are from Packman. Also, please start totem from a terminal window, then post the output it generates here. Between CODE tags.

wallace@linux-u28y:~$ totem

** (totem:6983): WARNING **: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
NVIDIA: could not open the device file /dev/nvidiactl (Permission denied).
NVIDIA: could not open the device file /dev/nvidiactl (Permission denied).

(totem:6983): Grilo-WARNING **: [registry] grl-registry.c:330: Failed to initialize plugin: ‘/usr/lib64/grilo-0.2/libgrlflickr.so’

(totem:6983): Grilo-WARNING **: [registry] grl-registry.c:787: Failed to open module: ‘/usr/lib64/grilo-0.2/libgrlshoutcast.so’

(totem:6983): Grilo-WARNING **: [registry] grl-registry.c:330: Failed to initialize plugin: ‘/usr/lib64/grilo-0.2/libgrltmdb.so’

(totem:6983): Grilo-WARNING **: [registry] grl-registry.c:787: Failed to open module: ‘/usr/lib64/grilo-0.2/libgrlpodcasts.so’

Installed gstreamer-plugins-libav-1.0.1-1.1.x86_64 and that gave me sound But still no video.

Thanks.

Am 28.04.2013 16:26, schrieb WallaceGalloway:
> NVIDIA: could not open the device file /dev/nvidiactl (Permission
> denied).
I would first solve your video problem, before trying to proceed. I
guess you are not member of the video group, add yourself to the video
group in yast -> security and users and then log out from your graphical
session log in again and show as after that agin the totem output.


PC: oS 12.3 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.2 | GTX 650 Ti
ThinkPad E320: oS 12.3 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.2 | HD 3000
HannsBook: oS 12.3 x86_64 | SU4100@1.3GHz | 2GB | KDE 4.10.2 | GMA4500

[QUOTE=martin_helm;2551902]What kind of files do not play for you? I tried now totem with mp3, mp4
and a mkv with x264 codec and all plays.
The difference I see to your list is that I have


gstreamer-plugins-good-extra-1.0.6-2.8.x86_64
gstreamer-plugins-libav-1.0.1-1.1.x86_64
gstreamer-plugins-ugly-1.0.6-2.9.x86_64
gstreamer-plugins-ugly-orig-addon-1.0.6-2.9.x86_64

in addition to what you have (I am no gstreamer expert so I am unsure
which contains support for what media types).


Added thanks…sound but still no video.

Added myself to the video group.

wallace@linux-u28y:~$ totem

** (totem:4156): WARNING **: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files

(totem:4156): Grilo-WARNING **: [registry] grl-registry.c:330: Failed to initialize plugin: ‘/usr/lib64/grilo-0.2/libgrlflickr.so’

(totem:4156): Grilo-WARNING **: [registry] grl-registry.c:787: Failed to open module: ‘/usr/lib64/grilo-0.2/libgrlshoutcast.so’

(totem:4156): Grilo-WARNING **: [registry] grl-registry.c:330: Failed to initialize plugin: ‘/usr/lib64/grilo-0.2/libgrltmdb.so’

(totem:4156): Grilo-WARNING **: [registry] grl-registry.c:787: Failed to open module: ‘/usr/lib64/grilo-0.2/libgrlpodcasts.so’

.


Added myself to the video group and your list of gstreamer files, rebooted and I have video and sound. Thanks to all who tried to help. Anyway to mark this thread solved?

Zoot alors! That solved it for me! lol! Thanks

(Had never been able to figure out why Totem didn’t work, yet every other media player works flawlessly with anything I throw at them)

For the next posting of computer text, remind you were asked to do this between CODE tags. This is the # button in the toolbar of the post editor.

gstreamer-plugins-libav is not really required. I don’t have it and totem works fine here!
It’s just a “catch-all” codec which can play everything ffmpeg can.
But if you have the following from packman (and that’s the important part :wink: ), you should be able to play most stuff without gstreamer-plugins-libav:

gstreamer-plugins-badgstreamer-plugins-bad-orig-addon
gstreamer-plugins-base
gstreamer-plugins-good
gstreamer-plugins-good-extra
gstreamer-plugins-ugly
gstreamer-plugins-ugly-orig-addon

Especially gstreamer-plugins-bad is also contained crippled in the standard openSUSE repo without mpg support, f.e.