'can't find source media' during 11.3 install although does boot the iso dvd..?


I spent some hours trying to find info about my problem but couldn’t. Soo…here’s my problem. I’m trying to install 11.3. The iso install DVD boots up ok, says ‘welcome’ in far more languages than I understand, I select English & US English then all useful progress stops. It suddenly can’t detect my CD/DVD (although it DID when the system booted with the CD/DVD drive selected as 1st device to try to boot). I’ve tried pushing the button to eject and reload the DVD, no dice. Nothing seems to work, when I finally go for shutdown it suggests I might need to load a driver. My drive is a fairly new plextor px-b940sa. searching the plextor corp site for linux turns up zilch as does the knowledge base at novell.com. it’s all in knowing the right magics words i suppose. my chip is the intel 6 core. my mobo is asus p6x58d (actually im wondering if it’s the culprit because it does some fancy tricks). i tried my store-bought 11.1 suse install disk, it has the same difficulty. i suppose a usb-linked external dvd drive might be the obvious solution (won’t cost too much but fairly likely to have some problem). Ideas? Thanks for taking the time to read this, heh.

I did try buying a usb-linked cd/dvd drive and that solved the problem. i had to boot to windows 7 to get it to recognize the usb cd/dvd and go into the motherboard’s setup a couple times(1st time to select ‘removable media’ as boot device then 2nd time to select ‘USB blah-device-blah’). Then I was able to install from the usb CD/DVD. Hurray! the drive was a targus model adv01us

Sometimes DVD/CD fail, its a shame yours failed.

A couple more things to point out (so this thread’ll be a little more useful to others):

1)I notice that after successful 11.3 install that the plextor cd/dvd drive I mentioned isn’t recognized by the system. therefore, I assume that was really the original problem. because it’s a relatively new drive, a blue-ray capable drive, suse hasn’t caught up with being able to really use it. i attribute the fact that I could be the install process started (although not finished) to the asus mother board (IT as smart enough to boot the plextor).

2)I notice that 11.3 doesn’t let me move files from my ipod in (error is something like ‘no block device’). the same thing happens when I try to access my new usb cd/dvd device I think. hopefully the repository build service will eventually find all the drivers I need (or i’ll have to manually find’em i guess).

Doesn’t matter that a DVD/CD can read a few sectors it may still be failing. Possibly there’s messages about /dev/sr0 in /var/log/messages, or /var/log/warn. Or if you dual boot to Windows to test the Plextor’s read/write/play.

If you’ve changed bios settings then that could be your original problem. Hard to tell what could have been the problem, you didn’t write if you had checked the media, if the Plextor was reading the openSUSE DVDs under windows, etc.

when i look at the iso dvd on the plextor under win 7 that works , see a bunch of diff files. when i let it autoplay under win 7 the suse install sequence starts but fails after I selected english, then english(us), then install (at which point it complains that it cannot exec bcdedit.exe). probably not a really good idea to try though.

when I try again now to boot the iso dvd then once again the install sequence starts but things go wrong with the 1st error message that shows up being “no CD-ROM or DVD found” , then on attempt to keep going the message “Make sure that CD number 1 is in your drive”. I stop trying at that point (don’t want to reinstall! thanks goodness it’s failing now heh).

grep of “/dev/sr0” on messages yields:

“mounted /dev/sr0 on behalf of uid 1000
forcidly attempting to lazy unmount /dev/sr0 as enclosing drive was disconnected
unmounted /dev/sr0 from “media/my-uid” on behalf of uid 0”

those messages were from 31st of last month, not sure what I was doing on that day.

grep doesn’t find anything in the other file you mentioned.

i haven’t tried to check the checksum.

for the most part i’m happy now. i’m merrily trying to get my software up and going. i had to boot to windows then transfer my tar file from my ipod there then snarf the file over to 11.3 through the mount point (because as I mentioned 11.3 won’t yet let me use my ipod, or my new usb linked disc, or my plextor). i can’t backup my files to DVD using k3b either, >: but … i’m happy:P i AM going to want one of drives to start working but i’ll either figure it out myself or move over to another thread.

happy computing yall!

Sorry to say but I still think its the Plextor dying. The 11.3 DVD is readable using the new USB DVD, while the Plextor can’t read the 11.3 DVD under Win or boot. You should check the media with both the USB and Plextor DVD drives.