Cant find network folder

Where is /etc/network/interfaces located?

Or where can i find the interfaces?


If you are using network configuration with ifup control - you can find configuration of interfaces in /etc/sysconfig/network directory.

I inserted my rt2870 LKM in the kernel and I can c it now in the module list.

How do I configure now the interface? Cause I cant c the interface in sysconfig.

I know theres a repo for this driver but I like to find out myself first. :stuck_out_tongue:

You can check your network interfaces with ip(8) command from iproute2 package.

ip link list
ip address show

If you are using network setup method with ifup - use yast2 control center - network devices - network settings, or you can setup configuration with networkmanager.
You can read about networking and network setup in openSUSE 112 Documentation section 21 “basic netwoking” on

Tnx for the docs novsan. :wink:

I look at my devices and there is no sta device detected.

But the module is inserted in the kernel.

I insert it with insmod. What could gone wrong?

You can check network interfaces with wireless extentions support with iwconfig command (as root):

su -c iwconfig

Both interfaces he detected have ‘no wireless extensions’.

Do I manually add that device?

Yes, something wrong.
You need to continue the discussion in your previous topic:
Install driver Ralink RT2870 - Page 2 - openSUSE Forums

novsan. That problem is solved. I used sudo -s and then i could run insmod.

I c the LKM in module list. I only need to set the device now and then I can configure the interface. No?

Yes, look above :slight_smile:

Ok, I c now… :slight_smile:

There is a file ifcfg.template to use. So I just config a new interface based on that template…

Better way is to do it with Yast.

I find the Yast not documented well. The ifcfg.template is good documented.

OK. You’re the boss :slight_smile:

I config the if with Yast. But when I close the network manager, it dont save the config.

I config it has ‘wireless’. Is that correct?

Open Yast, click “Network devices” - “Network Settings”. Open “Global Options” tab and check Network Setup Method.
And just one question.
Did you build rt2870sta module dependencies?

Where can I find the dependencie build?

Network Setup Method -> ‘Traditional Method with ifup’.

Close Yast. In terminal (as root):
remove loaded module from memory

rmmod rt2870sta

build module dependencies

depmod -a

try to load module

modprobe rt2870sta

Dependencies build and module loaded back in kernel.

The interface dont stay in the network manager when I close it. And I dont get a .ifcfg file for my added interface.

Open Yast, in Network Devices - Network Setting choose Overview tab, select your wireless interface in frame and press Edit button. Configure static or dynamic ip address. Check which driver in use in Hardware tab. In General tab look at Device Activation option. After configuration press Next button.