Can't find my HP printer

Hello lol!

I am using Tumbleweed and I have some issues with my printer HP Photosmart 5520, I can’t find it however I can see it in my WIFI list. I was on Fedora 24 some weeks ago and it was OK.
Do you have any suggestions for me please ?

Thank you.

Hello and welcome here.

Please remember that your ideas on what is going on on your system is best accompanied by the computer evidence you base your conclusions on.

You doe not just say “I can’t find my printer” (isn’t it on the desk?), but tell what you did on your system to “find” it and what that resulted in. Best is of course command line information, because that can be copied/pasted easy into a a post here.

Same about what you call “my WIFI list”. Post it here, only then we can see what you mean with that and what is in it (and what not).

BTW, you being new here, when you post computer text, please do so between CODE tags. You get them by clicking on the # button in the tool bar of the post editor.

You need to install the hplip package, then run


su -c hp-setup

and you’ll be presented with the HP installer.

Thank you ! Your answer is a little bit paternalistic but I appreciate it. Next time I have a question I will proceed as you explain !

What I tried :

  • Gnome Settings -> Printers-> Add Printer. Any printer detected.
  • Yast -> Software -> Printers. Same result

Thank you mate. I installed it and executed this command. There is a blank window and I can see this in the terminal :

HP Linux Imaging and Printing System (ver. 3.16.8)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Qt: Session management error: None of the authentication protocols specified are supported
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: Aucun fichier ou dossier de ce type
QFileSystemWatcher: failed to add paths: /root/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address. 
IBusInputContext::createInputContext: no connection to ibus-daemon 
X Error: BadAccess (attempt to access private resource denied) 10
  Extension:    130 (MIT-SHM)
  Minor opcode: 1 (X_ShmAttach)
  Resource id:  0x143


Looks like an IBus issue that needs to be sorted first? I don’t know much about IBus. (This might require a new thread with appropriate title to help resolve.)