Can't find Leap 15.3 tells me that leap 15.3 is available but wherever I look and whichever link I follow, all I can find on offer is 15.2 or 15.3 RC. Am I missing something?

Here you go…

And I arrive there directly from the page the OP shows. In the right (Leap) half of it. But youi have to hover there with the mouse first :(.

Thanks for that. It takes me to a Leap 15.2 page which at the top has a line “Leap 15.3 RC is now available for download and testing - Learn more”

Selecting any download option takes me to a 15.2 iso file, so I’m puzzled. Is that what I should select?

Download latest net install directly from download page (as many stale links are lurking)

Here I get Leap 15.3:

But its the same side as the other mods have told…

It looks as if you are being redirected to an out-of-date mirror.

Yes, but your mileage will vary over time. When I clicked the link last Sunday it was stale. If a link doesn’t work go to and try one of the distributions or Tumbleweed. All of them work here most of time:

erlangen:~ # curl -I ****
HTTP/1.1 200 OK
Date: Thu, 03 Jun 2021 11:58:22 GMT
Server: Apache/2.4.43 (Linux/SUSE)
Last-Modified: Wed, 14 Oct 2020 11:48:02 GMT
ETag: "1000-5b1a01a9493cd"
X-Content-Type-Options: nosniff
Content-Security-Policy: default-src 'none'; img-src 'self'; style-src 'self'; script-src 'self' 'unsafe-inline'
Content-Type: text/html;charset=ISO-8859-1

erlangen:~ # 

If is out of service you may use one of the mirrors, such as:

erlangen:~ # curl -I ****
HTTP/1.1 301 Moved Permanently
Date: Thu, 03 Jun 2021 12:04:55 GMT
Server: Apache/2.4
Content-Type: text/html; charset=iso-8859-1

erlangen:~ # 
erlangen:~ # curl -I ****
HTTP/1.1 200 OK
Date: Thu, 03 Jun 2021 12:02:57 GMT
Server: Apache/2.4
Content-Type: text/html;charset=UTF-8

erlangen:~ # 

Many thanks for your help. But I found the solution. It was simply necessary for me to clear the Firefox recent history etc.
All is now welllol!.

Yes, there is a problem with the opensuse website caching. Seems like updating the site doesn’t invalidate the cached data. I had same issue.

Glad to read that you’ve resolved it.