can't find /dev/sda1 after update from Suse 11.2

Hello all,
I am very new to Linux. I used OpenSuse 11.2 and tried to update it to 11.4 from iso, choosing “update” in the installation dialogue. It went ok, but at first boot something failed and I got the following:

doing fast boot
FATAL: Module amd74xx not found
FATAL: ide_pci_generic not found
… (a lot of stuff I don’t know how relevant)

Waiting for device /dev/sda1 to appear … Couldn’t find /dev/sda1
Want me to fall back to /dev/disk/by-id/ata-STM3500418AS_9VM0879T-part1? (Y/n)


Like this. Then if I choose Y, it starts up to the login screen, but the image is blurry and unreadable. It even logs in, but the desktop is still unreadable.

When I choose to boot “failsafe” mode, it boots normally, all graphics look ok. What could I do to boot normal system? I have never experienced any problems like this with Suse 11.2. If I go to the console and type mount /dev/sda1 from failsafe boot, it returns “according to mtab, /dev/sda1 is already mounted on /”

I have AMD Athlon Dual Core 4850e and nVidia GeForce 6150SE, Suse is the only OS installed. What else information might help to fix it?

… but the image is blurry and unreadable…
I have […] nVidia GeForce 6150SE


ok, this is a little bit wild guessing. Especially I don’t know what caused missing modules. (Old stuff from 11.2 ?)
What you could try, concerning the unreadable desktop is to install the NVIDIA drivers:
[li]Start yast2
[/li][li]Choose “Software repositories”
[/li][li]Click “Add”
[/li][li]Choose “Community repositories” (second entry here)
[/li][li]Click continue [It will start to download the list)
[/li][li]Choose “NVIDIA graphics driver”
[/li][li]Click “Continue” [It starts adding the repository]
[/li][li]Allow it to install the GPG key (I wouldn’t know of any better option)
[/li][li]Exit the yast2 module
[/li][li]Start “Install SW”; you will find the drivers matching your card already selected
[/li][li]Just click “Continue”
[/li][li] Close everything and reboot; Now it should come up with the NVIDIA driver; hopefully this helps

Ahh, missed one point: First off, try to check if the resolution of KDE/X11 is matching the one of your monitor (you have a LCD - don’t you ?)
if there is a mismatch, the LCD needs to interpolate and the result can be really ugly…



You have two different problems as far as I can see, one might come from an
entry in /etc/fstab (the /dev/sda1 problem). So can you post the output from

cat /etc/fstab

It most probably has a line in it with /dev/sda1 which you should replace by
the appropriate entry /dev/disk/by-id/ata-STM3500418AS_9VM0879T-part1,
but first post the output.

The other problem seems to be graphics related. Can you check first if you
have the proprietary nvidia driver installed? Easiest way is to click on
your desktop on the Computer icon (I hope it is called so in the english
version, in germn it is “Arbeitsplatz”) it shows you which 2d and 3d driver
is in use.
If it is not nvidia you should install the nvidia driver

In addition you may have a leftover xorg.conf from 11.2 in /etc/X11.
Rename it to something else (e.g. xorg.conf.112) and check if that has an
effect that the resolution is better.

There may be more issues to be solved one after the other.

PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
9600 GT | 4GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
ION | 3GB Ram


a warning: I just discovered, that it seems like the NVIDIA drivers block the login to KDE on my system. (see here: KDE login on OpenSuse 11.4 fails (after installing patches))

So please be very careful with my advice, it might bite you.
Sorry for the confusion.


Thank you guys, I solved both problems, made a complete new installation and installed Nvidia drivers. Works perfect. I just wonder why before the driver was ok for filesafe mode but not for normal boot… Anyway it is running now :slight_smile:

Thanks again,

Failsafe does not use that driver. It uses the vesa or fbdrv. These in theory will work with any card. But they do not do any acceleration 2d or 3d so they are slow.