Can't find a way to open newly installed application

Occasionally after I have installed a new program I can’t find a way to open it.

Most recently this happened with Data Crow on opensuse 13.1. I installed it following the included directions using “java -jar installer.jar”. The installation seemed to proceed with no problems, but Data Crow does not appear in the Kickoff Application Loader nor can I find it if by searching.

What to do?

Thanks for any help.

usually when you install an application (rpm) from the opensuse or other repos then an entry will be added to kickoff.

Data Crow is not a linux application but a Java application so you probably need to launch it from a terminal window.
You can manually create a shortcut in kickoff for easy launching in the future.

Sounds promising. How do I do this?

first you need to work out what the command to launch the application is from terminal. It should be in the documentation but for Java apps it is usually something like . . .

java -jar /path_to_app/appname.jar

once you know that and can launch successfully
right click on kickoff and select edit applications
choose an appropriate category and sub category
click new item in the toolbar and give it a name
copy the launch command from the terminal window
probably should uncheck* launch feedback*
choose an appropriate icon

Once you know the command you can manually add it to the menu

Right click the menu icon and select edit applications

I typed “java -jar /usr/local/Data_Crow/datacrow.jar” as sudo in a terminal and got this message:

“Error: Unable to access jarfile /usr/local/Data_Crow/datacrow.jar”

What should I do?

In the help files I found this:

  Data Crow can be started by typing "java -Xmx256m -jar datacrow.jar"

I did this but still got the same error message.

I made sure the file is executable in its properties.

On 2013-12-19 10:46, maiqiang wrote:
> I typed “java -jar /usr/local/Data_Crow/datacrow.jar” as sudo in a
> terminal and got this message:

Why as sudo?

> “Error: Unable to access jarfile /usr/local/Data_Crow/datacrow.jar”

Then it is not there.

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Re sudo: I just assumed I had to be root.

I can see datacrow.jar in dolpin.

On 2013-12-19 11:56, maiqiang wrote:
> Re sudo: I just assumed I had to be root.

Why? Do you open libreoffice as sudo? No, you don’t, unless you have an
specific reason to do so.

> I can see datacrow.jar in dolpin.

Use ‘ls -l …’ in CLI to verify the exact file that the CLI error says
does not exists, by pasting it.

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Using ls -l in CLI as you suggest I can find the containing folder - Data Crow - although I still can’t find datacrow.jar this way. Originally I found it using search in Dolphin, and I’ve been able to open other files in Data Crow folder with no problem. I’ve copied and pasted the path from its properties.

Is it possible for a folder and/or file to appear in dolphin yet not exist?

I would download the other version (unpack and run) and extract it into my home directory and run it from there.

Anika2000’s suggestion seemed to work very well until I tried to open the program. The small crow icon did its bouncy thing for a short while and then, nothing. No program opened.

I feel I’m getting closer though.

Thanks for all the help so far.

My last post may have been misleading. I still can’t open the program, and still need help.


I downloaded the app and then unpacked it via Dolphin Menu “extract archive here, autodetect subfolders”. I then move it to my bin folder inside my home folder and in a terminal run the commands.

lee@linux-aa3c:~> cd ~/bin/datacrow
lee@linux-aa3c:~/bin/datacrow> java -jar datacrow.jar

So this just changes directory to your home/bin/datacrow and then run the java file.
You can experiment with the command line options the developer suggests but I did not need them.

It works fine here.

Thanks, Anika200!

This worked for me too.