Can't Expand /home Partition (Within Extended Partition)


I have this problem with using unallocated space to expand my /home partition. During installation OpenSUSE put it and the system partitions inside an extended partition (sdb1) which cannot be resized because it is extended.

You can expand an extended if you have space at the end. You need to do that before you change the size of the home

I do not understand it. Of course it can be resized as long as there is free space adjacent to the end of this partition. Please show output of “fdisk -l”.

Based on the info in the diagram,
You can enlarge /home in 2 steps…

  • First, you need to enlarge the extended partition into the unallocated free space. To do this rt-click on the Turquoise “Extended Partition” not inside, and select “re-size”
    Slide the right edge as far as you wish.
  • <AFTER> the above has been done, you should now see that Turquoise “Extended Partition” extended far beyond the limits of /dev/sdb7. Now, you can click on/in “/dev/sdb7” to move or re-size.

The key concept is that /home is <not> the same as the extended partition, from what is displayed your extended partition contains swap, root and home partitions, almost certainly all of your openSUSE install.

You’re starting off with all that unallocated available free space <outside> the extended partition which contains your openSUSE install. You need to enlarge the container (extended partition) into the unallocated free space so that that available free space is <inside> the extended partition and then available to the openSUSE partitions.


Hi gogalthorp, arvidjaar and tsu2,

The problem is I can’t resize the extended partition. I’m attaching a screenshot from Partitioner. In GParted this option is also greyed.

I know I’ve re-sized extended partitions, so I know that it can be done in general…

So, first…
Are you using Gparted Live?
Use the LiveCD verstion of Gparted to re-size, don’t use whatever is used within the Installer or the openSUsE OS, this avoids at least one issue described in the hits in the following Google search…

The general rule of thumb I go by is…
If you are modifying partitions on a non-system “data only” partition, then I might use a partition app installed into the running OS.
If the parttition modifications are to be made to any swap or partition containing any part of an OS, then I alwasy use a LiveCD that boots completely separately and doesn’t use anything on that disk.


It is probably squeezed between two other partitions. So you might need to move some other partitions to make this possible.

Original picture shows free space at the end. I suspect the problem is having a running OS in it. Best to use an external OS or tool and not have ay mounted partition in or around the partition to be resized. It is kind of like changes a tire while driving down the road


I’ve managed to resize the extended partition.

For this, I made two USB live sticks – one for Clonezilla, one for Gparted. Clonezilla, however, was not recognized as a bootable device despite my attempts. So I took my chances and tried to resize without a backup. It’s worked out fine. Then, after a reboot, the PC began copying or reshuffling data; the process wasn’t in the System Monitor, so I could not track it. I rebooted to a black screen. I rebooted again to a “dependencies” error. I rebooted again successfully, and without data copying. So, now it’s fine. Thanks for helping.

I am now having another problem, probably as a rusult of this failed phantom copying procedure, after resizing the extended partition and /home within it.

Opensuse would sometimes fail to start up. It says it can’t mount /home. I type a command for details, and it says that /home needs “cleaning”. What should be done here? :slight_smile:

Did you expand the home partition if so did you also expand the file system to fit?

run fsck on that partition. Best if done from an external boot

I’ve run file system check for all partitions from a Gparted Live USB, and the recurring error went away. Thanks, Gogalthorp.