can't dual boot mint13(/boot partition,grub) ater installing Suse(MBR,grub2)

After I’ve installed opensuse 12.3KDE kernel 3.7.10-1.1 I can’t boot mint13 kernel 3.2.0-4 . Suse boots from MBR(Master boot record) and uses grub2. I run grub2-mkconfig -o /boot/grub2/grub.cfg - but it won’t find mint
Mint has common boot partition on /dev/sda2 (I’ve only one harddisk).
Here’s an outuput of linx-boot prober command
# linux-boot-prober /dev/sda2
/dev/sda2:/dev/sda2::/vmlinuz-3.2.0-2-amd64:/initrd.img-3.2.0-2-amd64:root=/dev/sda2
/dev/sda2:/dev/sda2::/vmlinuz-3.2.0-3-amd64:/initrd.img-3.2.0-3-amd64:root=/dev/sda2
/dev/sda2:/dev/sda2::/vmlinuz-3.2.0-4-amd64:/initrd.img-3.2.0-4-amd64:root=/dev/sda2 **
"

cat /boot/grub2/grub.cfg** " ,it shows only suse like

### BEGIN /etc/grub.d/10_linux ###
menuentry ‘openSUSE 12.3’ --class ‘opensuse-12-3’ --class gnu-linux --class gnu --class os $menuentry_id_option ‘gnulinux-simple-xxxxxxxxxxxxxxxxxxxx’ {
load_video
set gfxpayload=keep
insmod gzio
insmod part_msdos
insmod ext2
set root=‘hd0,msdos4’
if x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos4 --hint-efi=hd0,msdos4 --hint-baremetal=ahci0,msdos4 --hint=‘hd0,msdos4’ xxxxxxxxxxx
else
search --no-floppy --fs-uuid --set=root xxxxxxxxxx
fi
echo ‘Loading Linux 3.7.10-1.1-desktop …’
linux /boot/vmlinuz-3.7.10-1.1-desktop root=UUID=xxxxxxxxxxxxxxx resume=/dev/disk/by-id/ata-WDC_WD7500BPKT-00PK4T0_WD-WXF1E32MVUC9-part3 splash=silent quiet showopts
echo ‘Loading initial ramdisk …’
initrd /boot/initrd-3.7.10-1.1-desktop

and another submenu for safe mode/memtest and advanced options
does it mean I need to add anohter menutry for mint? like :
menuentry ‘LinuxMint GNU/Linux, with Linux 3.2.0-4-amd64’ --class linuxmint --class gnu-linux --class gnu --class os {
insmod gzio
insmod part_msdos
insmod ext2
set root=’(/dev/sda,msdos2)’
search --no-floppy --fs-uuid --set=root xxxxxxxxx
echo ‘Loading Linux 3.2.0-4-amd64 …’
linux /vmlinuz-3.2.0-4-amd64 root=UUID=xxxxxxxxx ro quiet
echo ‘Loading initial ramdisk …’
initrd /initrd.img-3.2.0-4-amd64
}

Go you YaST2 bootloader module and check “Probe foreign OS” (or similar). You may need to re-run grub2-mkconfig after that.

You can expose and find all features of grub2 using my bash script grub2cmd. You might find it useful in your quest to get mint working: GNU Grub2 Command Listing Helper with --help & Input - Blogs - openSUSE Forums

Thank You,