Can't detect my scanner

Hi friends,
I have a scanner/printer combo connected to wifi, I can print things just fine but the scanner program doesn’t detect it. I tried to see if document scanner would magically already detect it, it didn’t, so I tried to detect it with yast, no luck.
I know this might sound like a handholding thread and I apologize. I dunno how friendly with this kind of things this community is but in case they’re seen poorly, I apologize. I installed without dual booting another distro to fully commit but I have to send a pdf to work and I would appreciate greatly any help.

As a printer it’s detected as an epson xp 620 series, but that machine isn’t in the list when I search for scanners.

Welcome to the openSUSE forums.

Your story is really without many facts. “a scanner/printer combo” is not explaining any make and type. “the scanner program” does not tell people here which of the several scanner programs, etc.

We are generally seen as friendly, but not as mind readers :wink:

Right, my bad sorry friend.
A bit of a panic on my end due to being worried I can’t send the darn pdf in time :slight_smile:
I installed xfce, the scanning tool that came with it is simple-scan
With scanner/printer combo I mean that the same machine functions as both a scanner and a printer, which is why I’m puzzled as to why it works out of the box as a printer but not as a scanner.
When I saw that simple-scan didn’t detect it I went on yast and clicked on hardware → scanner and let it do it’s things hoping it would detect the scanner, but alas that was not the case.

The printeris showing as epson_xp_620_series when I pick which printer I want to use, so I went on “add” in the yast section for scanners, where there’s many models but I couldn’t find the one that I have.

I’m sorry I was too vague in my OP.

Here are the drivers for printing and scanning:

Thank you for the links, I appreciate it a lot.
I went ahead and downloaded the rpm for the scanner then installed everything.
The scanner is still not being detected sadly, am I missing something?

Reading the manual from last link?

In the first link above from Sauerland
have run run this command

openSUSE: #
yast --install lsb

Look her in chapter 5.2 Opensuse commands

Also try deactivate firewall during testing
I opened up TCP 631 and added ipp-client in the home zone and activated home zone
The last might be for printer, but worth a try maybe.

Please stop the openSUSE firewall briefly (if active).

sudo systemctl stop firewalld

then run

scanimage -L

Is the network scanner detected at all?

So update.
After a reboot my keyboard didn’t work anymore and I wasted ages getting things back to normal. Ended up scanning with another device instead and I will try to get things to work again tomorrow.
Thanks for the help.
For some reason the earliest snapshot I could use was from the 21 so I have a lot of packages to reinstall since I installed this system, well, the 21.

I have also recently got problem with keyboard/mouse not working straight after reboot, takes 1-2 minutes. Must be something with last week updates. Worked prefectly a few days ago, but I guess that belongs to some other thread.

I wish I had known before going insane trying to fix it.

After the rollback my printer doesn’t work as a printer anymore either.
I went to the links provided by Sauerland
lsb is installed
I disabled the firewall and the printer has been detected again.
I installed the drivers for the scanner with the script
Now things are seemingly working.

I suspect something that might have caused issues yesterday was a combination of a vpn and a firewall which I didn’t reinstall after the rollback, yet.

After I install them back (and when I say install firewall I mean replace the one already in with ufw because I’m more familiar with it) I’ll see how things go.

depending on how far you rolled back you may be using a snapshot before you installed the drivers.
remember when you roll back you go back in time

1 Like

I did, but I also reinstalled afterwards.
Thank you for the reminder though because I’m usually pretty forgetful!