Can't delete icons?


I have a new install of openSUSE 11.1. On the desktop, there are icons such as “Online Help” and “openSUSE” which each have a little lock symbol on them. I don’t want them there, though, they are just cluttering up my desktop. But I can’t delete them because of permissions error. I logged in as root and deleted them on root’s desktop, and logged back in as me, but then Nautilus gave me an error that it could not be used right now and none of my icons showed up, so I reverted back.

Any ideas?

A search of the forum would probably have led you to something like
this :wink:

sudo rm /usr/share/dist/desktop-files/*.desktop

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 3:54, 1 user, load average: 0.17, 0.06, 0.09
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

Oops, thanks :o

nbakewell wrote:
> I logged in as root

NEVER log into GNOME (or KDE or any such) as root…you are just
ASKING for trouble to do so…

for the right/safe/ONLY way to use root powers see:

It’s very easy in the GUI. I had no icons. I went into configure desktop and switched a setting. I came back out and I had icons.

I want to get rid of them to have a clean desktop, but can’t find what I did.

It’s easy, just can’t remember what I did.