Can't delete first character typed into virtual console login prompt

When I switch into a virtual console (with CTRL-ALT-<F1 through F6>), I’m greeted with a login prompt:

sardanapalus login:

But for some reason, whatever I type in here, I can’t backspace over the first character I’ve typed. So if I make a mistake (let’s suppose I wanted ‘bar’ but typed ‘foo’ instead), then I can only delete the ‘oo’ and am stuck with the leading ‘f’. ^U and ^H don’t work, either.

sardanapalus login: f_

This only happens for login prompts. Once I’m logged in, I can delete all characters to the beginning of the prompt just fine, but if I log out and back in again, I’m greeted with the same issue.

Anyone have any clues? Came up empty-handed after a fair bout of Googling. Thanks in advance.

Would anyone happen to know if this question would be a better fit for the Install/Boot/Login sub?

Well, first try to ensure you are really dealing with a problem of “I can’t delete that character” or not just a problem of “the console display shows I can not delete the character although it does delete it”.

So go to the console, type some false user name, delete all characters, hit backspace a few more times just to be sure and then try to login with correct user name and password no matter how screwed up the user name might look like.

If that does work, then it is a problem of displaying the console correctly and not a problem of the console not being able to delete the characters.


Yep, definitely can’t delete the first character. Tried your suggestion, but also tried entering my username (rlue), deleting the whole thing (with ^U), then backspacing a bunch more times, then entering only the remaining portion of my username (lue), and was able to log in successfully.

Don’t know if this is a clue, but if I enter invalid credentials and get a ‘login failed’ response, then I can delete back to the beginning of the prompt just fine. But if I log in and then log out again, then I’m right back to where I started. :\

Clever thinking, well done.

So now you know for sure setting up virtual console is buggy on your system, however as this is some sort of black magic to me, my only hint would be to search if you find some bug reports related to items like:



from systemd. Also, IIRC you are running the system on some Hardware related to fruit, so maybe some strange behavior related to Linux on that brand of hardware might be a point to start.

But this is only just some guessing game, so YMMV and don’t rely on me having any expertise in this area.


Thanks for the pointers – looks like I’ve got my work cut out for me. (Any idea where a better place to ask for advice might be?)

I think the place is allright. I understand you hesitate between Applications and Install/Boot/login, but you have chosen Applications and I do not think it is a wrong choice. Also be aware that we do not allow double posts. Thus either you leave it where it is, or you ask the staff, using the report button (the triangle with the !) to move it, but do not post the same question in another (sub)-forum.

**Last edited by malcolmlewis; Today at 08:00. Reason: Removed filtered word **

LOL, very funny, made my day.

Even if you try to avoid the “automatic replacement filter” by writing the little “*” yourself in order to not write out a “bad” word, that’s still not good enough.

Welcome to kindergarten, here’s your little gold star.


Yes, I am seeing the same thing.

I normally wouldn’t notice this. But, now that you mention, I decided to test. I am seeing it on two different computers running Tumbleweed.

I think this needs a bug report.
Submitting Bug Reports

Unfortunately, the bugzilla seems to be down. I’m not sure if they will fix that today. You might have to wait until tomorrow.

Okay, Bug 1047880 submitted. Thanks very much for your advice!

I added a comment to your bug report.