can't debug firefox because of error

in terminal i typed firefox -g -d gdb

then typed backtrace

then i got lots of these different errors:
Missing separate debuginfo for /usr/lib/
Try: zypper install -C

Missing separate debuginfo for /usr/lib/
Try: zypper install -C

So i tried to install them like this:

zypper install -C “debuginfo(build-id)=d813b7afac2270c3ac525dd07566d693f7f558ee”

Then i got this error message:

And it says this:
Loading repository data…
Reading installed packages…
‘debuginfo(build-id)=475dde6ec351695fa4d072d4ee754fe9a635ec4a’ not found.
Resolving package dependencies…
Nothing to do.

Is that what it’s meant to say after i install each line? Is there any way to install all these things with one package rather than line by line?

I have zero experience trying to launch FF in a debug session, but dare I ask: why are you trying to debug? Is there a specific problem you’re looking for to fix? Maybe it’s less of a headache if you find the FF source code and debug from your own build?

Why are you trying to do this in the first place?
Did you try a new .mozilla folder and see how FF behaves?

The people at mozilla told me to debug because we’ve tried everything else. You can see my bug report here:

my cpu uses 100% when playing any video at this site:

Running with Chicken based on the movie Precious based on the novel Push by Sapphire from Riki Lindhome, Matt and Oz, and Antonio Scarlata - Video

and also the browser freezes for about 5 seconds and while it freezes the video still plays at a very slow FPS rate like starts,then stops,then starts, etc. the problem does NOT happen on YouTube.

problem happens with firefox and chrome BUT when i use windows xp with Internet explorer the problem does NOT happen anymore.

i have a p4 2.8ghz, 512mb ram, broadband.

I’m afraid I am out of ideas on that one. It sounds like a Flash problem, but that’s about the extend of my knowledge.