Can't control brightness after suspend


I have an HP EliteBook 8530w and recently I installed OpenSuse 11.3. I have one problem which is quite annoying. When I put the computer to suspend and wake it up later, the brightness of the screen is stuck at the lowest brightness. There’s no way I can change it after it wakes up from suspend. Adjusting the brightness using the slide bar in power management doesn’t do anything. Does anyone else have this problem or knows what to do to fix it?

Thanks in advance,

NOTE: It is generally helpful to include a little hardware information, in this case esp. your video card. It will help your forum posts in the future. :wink: That said, WELCOME!!

I looked up your model and found that it this laptop is available with either ATI FireGl or NVidia Quadro video cards.

I’m going to assume you have the nvidia card, only because this card has been reported to exhibit the problem you have described. You might try this fix someone suggested:

Add following line to NVidia Device section in xorg.conf:
Option “RegistryDwords” “EnableBrightnessControl=1”

You can give it a try, anyway. Good luck and welcome again.


Thanks for the quick reply. I’m sorry I didn’t include more information, I thought just the model type would be enough. I didn’t know this laptop also has a version with an ATI graphics card. In any case, I have the NVidia.

I tried to do what you suggest, but I can’t find xorg.conf. I read that recent versions of X don’t require this anymore, so I don’t know how I can add this parameter. There is a xorg.conf.d directory though, which contains several conf files. What to do? Also, where do you get the information for the fix?

yoran@linux-e8sg:/etc/X11/xorg.conf.d> ls -l
total 36
-rw-r--r-- 1 root root 1099 2010-08-19 17:36 10-evdev.conf
-rw-r--r-- 1 root root 2411 2010-09-16 01:18 11-mouse.conf
-rw-r--r-- 1 root root  174 2010-09-16 01:18 20-synaptics.conf
-rw-r--r-- 1 root root  566 2010-09-16 01:18 20-wacom.conf
-rw-r--r-- 1 root root  241 2010-04-22 17:48 50-device.conf
-rw-r--r-- 1 root root  237 2010-04-22 17:48 50-monitor.conf
-rw-r--r-- 1 root root  203 2010-04-22 17:48 50-screen.conf
-rw-r--r-- 1 root root  115 2010-09-16 01:18 50-vmmouse.conf
-rw-r--r-- 1 root root  107 2010-10-16 00:04 90-keytable.conf

Sorry. I’m used to a little more basic setup.

You want to edit the nvidia section of 50-device.conf, I believe.

Here is a helpful resource for messing around with these settings: SDB:Configuring graphics cards. You’ll find the suggestion to edit 50-device.conf in subpoint 4.4.


I did what you said but I still experience the same problem. My 50-device.conf now looks like this.

Section "Device"
  Identifier "Default Device"

  #Driver "radeon"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

  Option "RegistryDwords" "EnableBrightnessControl=1"


an up for this maybe?

Had the same problem, gladly fixed it with these steps of 1,2,3,4,5,6

  1. Go to YaST
  2. Choose “System” at left panel
  3. Choose “Boot Loader” at right panel
  4. At “Boot Loader Settings”, choose the openSuSe partition/label then “edit”
  5. At “Optional Kernel Command Line Parameter”,



to the end of the textbox.

mine, looks like this

resume=/dev/disk/by-id/ata-Hitachi_HTS545032B9A300_100218PBN3041THNNKHR-part6 splash=silent quiet showopts acpi_osi=Linux

  1. “OK” , then restart the computer
  2. Then, tell me if it works for you :slight_smile: or
  3. Ask me if any step above is not clear :slight_smile:

It works for me, hope will be for you too ( if y have not found a fix yet)

I used both Ubuntu & OpenSuSe, the solution works for both for my same Acer laptop :slight_smile:

source - [ubuntu] Brightness problem in Ubuntu 9.10 on Acer Extensa 5235 - Ubuntu Forums](


It’s been a while I haven’t posted back on this thread. In the meantime, I have upgraded to OpenSuse 11.4 but I still have the same problem, i.e. I can’t control the brightness after returning from suspend and the brightness is automatically set at the lowest possible value. As far as I know, the scripts of pm-utils are executed when suspending and resuming. The directory etc/pm/sleep.d has only script, at99, with the following content:


. $PM_UTILS_LIBDIR/functions

case "$1" in
                        stopservice atd
                        restartservice atd

exit 0

I have googled for this atd but I couldn’t find anything. Also, I don’t know if this is part of the problem. Maybe it has more something to do with ACPI not correctly being restarted or something?

Please help me out with this problem as it is really annoying.