Can't Connect with Windows Remote Desktop

I installed xrdp and opened the rdp port in my firewall. When I try to connect with remote desktop, I get the window into the machine but a connection log dialog pops up with the following:

connecting to sesman ip 127.0.0.1 port 3350
sesman connect ok
sending login info to sesman
login failed

I checked the warn and message logs. Warn didn’t have anything, but the message log had the following:

xrdp-sesman: pam_warn(gdm:auth): function=[pam_sm_authenticate] service=[gdm] terminal=<unknown>] user=<unknown>] ruser=<unknown>] rhost=<unknown>]

What am I doing wrong?

Hi & Welcome!

sending login info to sesman

I use tsclient which uses rdesktop. That works like a charm and also has an easy GUI.

Is there a reason you are using port 3350 and not 3389?

Other than that it could be your passing wrong credentials through a set config file or other?

Not that I know of. I opened 3389 in my firewall, I’m not sure where the 3350 came from. I just installed it about an hour ago and didn’t change any settings.

Well then I’d say give port 3389 a swing :wink: You don’t need to open the port in the Linux firewall… only on the Windows side if running one there.

Ok, I tried switching sesman to port 3389 in /etc/xrdp/sesman.ini, restarted xrdp and tried again. Remote desktop couldn’t even open the window to my machine then. Tried adding 3350 to the firewall, still no luck.

I changed the port back to 3350 in sesman.ini, now I’m back where I started. I can get a window into the machine but it’s not authenticating. I’ve tried connecting from 2 different machines and I’ve tried connecting as a normal user and as root.

Moved to Networking

Andy

I’ve just got the fact that you are using xrdp to be able to connect from Windows to your Linux system (Linux is the terminal service in this case, not Windows)…

Nomad - openSUSE states that the default 3389 port is used. It also states it’s quite a new service for openSUSE.
As beta4 states it’s been added to openSUSE 11.1 as main package. Could be an idea to see it that works better as the xrp does heavily depend on integrating with parts of X… that’s what could be missing in your configuration now?

That’s the page I was following along with to install xrdp. I’m running 11.1 b4.

I use remote desktop on the windows side every day so I know it works fine. Are there any config files for xrdp other than the ones in /etc/xrdp? Or maybe some extra log files than an error might be hiding in?

I think your best chance for this is to post your question in the factory mailing list. Again this is a new option in openSUSE so I don’t think many will have answers on this just yet. The developers might be able to guide you better.

Have a look here: Communicate - openSUSE

You can subscribe directly using this address: opensuse-factory+subscribe@opensuse.org

Cheers,
Wj

@beef623

I am also running b4 of 11.1. I am able to get this working, but only at 800x600 (even if I connect at a higher resolution, the desktop inside of the session is only 800x600). I found that I had to set my Windows client to connect at 24bit color. Any other setting produced errors. In addition, I found I had to reboot before the connection worked.

On a side note, once connected, none of my windows have title bars!

Being able to connect to my Linux box via RDP from work will be great! I can’t wait until they get the kinks ironed out…

Good luck!

the same problem as you

Hi all,

It would be of great help if you could add your 2 cents to this bug report:
https://bugzilla.novell.com/show_bug.cgi?id=442710

@shaunhey: Your added findings are good to add too!
Thanks!!
Wj

@Magic31

I noticed that this bug is written against 64bit. I am running 32bit at the moment, and this may be why I am receiving different results than the others in this thread. I’ll search through Bugzilla to see if there is a similar bug to what I’m experiencing. I’ll also see about installing 64bit to see if I can replicate what everyone here is seeing.

Edit: Looks like what I’m experiencing is bug #442292

Sounds like there are still a few bugs in Nomad. Were you guys using Gnome or KDE?

I’m using KDE and I’m pretty sure the bug I’m getting is this one: https://bugzilla.novell.com/show_bug.cgi?id=441750

Gnome here…

Good stuff guys! Hope you/we can get this fixed before the final release…
NX is a very nice way to get one more step on the way to easy integration!!

well it’s still broken in the final release

but I got it working, and I’m using 11.1 32bit kde with kdm4 as login manager

edit /ect/pam.d/xrdp-sesman
change it to

#%PAM-1.0
auth required pam_unix.so shadow nullok
account required pam_unix.so

@beef623

I am also running b4 of 11.1. I am able to get this working, but only at 800x600 (even if I connect at a higher resolution, the desktop inside of the session is only 800x600). I found that I had to set my Windows client to connect at 24bit color. Any other setting produced errors. In addition, I found I had to reboot before the connection worked.

at first I could only connect with a 800x600 display and could not change screen size. but with the rand utility I unchecked unify (in the remote connection) and every thing was fine.

Hi,

the suggestion was to change /etc/pam.d/xrdp-sesman file, but in my system (openSUSE11.1 i586), this file has exactly that content by default.

I’ve managed to overcome sesman login failed error by copying /etc/pam.d/xrdp-sesman to /etc/pam.d/sesman
I.e. /etc/pam.d/sesman file was missing.

But know I have another error about screen depth. Does anyone can give a suggestion to solve this?

========
connecting to sesman ip 127.0.0.1 port 3500
sesman connect ok
sending login info to sesman
login successful for display 10
started connecting
rdpx11 channel is not present
X11 RDP server started
Screen depth is not 24

Regards,
Mindaugas