Can't connect with static IP on wired network

Hi

Installed OS 11.2 RC2. Automatically my PC take a dinamic IP (10.0.0.102) from my router DHCP router. I want to give a static IP on my system, so I create a new wired profile thru network manager (clicking on ethernet icon near clock on bottom of my menu).

I put a static IP (10.0.0.11) that work fine on WinXXX. If I select this new profile, it works fine, however I’m not able to make this profile to be default at boot time. Network manager always take a dinamic IP and I must select my “static profile” after booting.

What am I doing wrong?

thx

For wired, static connections, I would prefer the IFUP method and skip NWM.

But the question is that it should work anyway, it’s not? :wink:

So, what is the NM problem? >:(

Thank you

No idea, it works here™ with both methods.

So, how do you get to avoid your box get a dynamic IP?

Instead of giving informations/logs/configuration files of your system, you ask me how I did my setup?

How much sense does that make, or how can you be sure my setup is any similar to yours? (It isn’t, I assure you.)

Wouldn’t it be a little more logical you start posting decent information about your setup?

Read the first sticky in the wireless subforum, post #3.

Hi again

I’m sure is NOT a hardware problem. My wired connection is OK and I can run without problems with static and dynamic IP on my wired network. My question is about how to avoid get a dynamic IP instead an static IP on a wired connection.

My config is very simple: Just installed OpenSuse and begin to work, so I’m NOT asking you about your system setup, I’m asking about what to do to avoid a dynamic IP in a standard installation of OpenSuse 11.2 RC2.

Is like if I ask you how to make backups on OpenOffice each 2 minutes. You will say me “You must change -this-. To do -that- you must access -here- and -here- in menu …”. Not so difficult, I think.

So, please, don’t talk about “logical” or “decent” info.

THANK YOU, I read post#3 as you told me and I will give you all that info if you think is usefull in this case.

Thank you again, and sorry if I didn’t make my question correctly. :X

Best regards

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

There is a lot more to the network settings than simply the IP address.
What did you enter for your hostname, netmask, gateway, and DNS servers?
Do these options match with the other machines on your network? Post the
output from the following commands:

ip addr
ip route
cat /etc/resolv.conf

Also post how you are testing your connectivity to the Internet. For
example, putting ‘www.google.com’ in Firefox would be one test, as would
going to a server of your own locally by IP address. Details are
important to troubleshoot properly.

Good luck.

finstro wrote:
> Hi
>
> Installed OS 11.2 RC2. Automatically my PC take a dinamic IP
> (10.0.0.102) from my router DHCP router. I want to give a static IP on
> my system, so I create a new wired profile thru network manager
> (clicking on ethernet icon near clock on bottom of my menu).
>
> I put a static IP (10.0.0.11) that work fine on WinXXX. If I select
> this new profile, it works fine, however I’m not able to make this
> profile to be default at boot time. Network manager always take a
> dinamic IP and I must select my “static profile” after booting.
>
> What am I doing wrong?
>
> thx
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJK8sthAAoJEF+XTK08PnB5FOEP/jZEwOLNUk9pGLBruvYqxX8O
Y+kyHuFdvGG1hBL0qDHdm7vV4WGKGAS8GGp6y/VQllha0AD/CYyaXy1A5+u7pzA3
koa8GQsdAH3Yn2REwACqWw7RlRI6njLgTBUEhE4evt8lVuQzw7lwUsX8+kDEKsU9
CbgISYsHfjsYMxTrErJUFimdh0QBrLNLZZcEhrgjh1E6uC+W9suyID5fDV2CAH4u
+3m8k4Aav+u3wTOqGXYG3v0j0SFRgqqF8hwjXTOpB4m3hwZOCja8PWAVbs6H8qRv
0M6IpMs6ZE3Cr+OefEGVKbf2yi7V7JiHl4htUbOyMqItvvOKDMWcsRcBukqaa8t3
6Uc6r9k2/jv977JDoJnbG+wWTLSpbdNeXlrnIDdolG/XvXEyZyMU2al22iAZMVBL
pcLnCb62xs7P0TgtM2JJM3MtGS+FxGyCBqHa1XqvibaxLSvi8t5xYNTgnk6hIQlG
OteTdFeC6BCOkg3kUZILPAXb6xy1TTcuHaj10U+87LO4oJxRqfDn1qXXU1bZ3PnS
wCOcQheqjgBa49m0PsQ6vZUfFh3sW3ohTFfCLZJ9KxNFm9egmSiuVpISGGw38fos
a2Uw6fVkegUKmGKCdaQCeuuCatljcPHcXJOjXrk4gQLcc0V3YLanWYlwnrnbYu/6
aLFhJFZVCyfzwOYolnXF
=+hPY
-----END PGP SIGNATURE-----

No, I only post that to generally confuse people.

Good luck, I’m out.

MY FAULT >:(

Title that I gave to this thread is confused. It should be “Can’t get to boot with static IP on wired network”.

I HAVE access to Internet, with static or dynamic IP, but I want to boot with static IP and change this situation thru KDE menus. Is it possible?

Sorry my terrible english, this must be the problem in this thread.

Best regards and THANK YOU ab

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Run:

yast lan

or

yast2 lan

Configure your networking to be static and on subsequent boots it should
stay that way.

Good luck.

finstro wrote:
> MY FAULT >:(
>
> Title that I gave to this thread is confused. It should be “Can’t get
> to boot
with static IP on wired network”.
>
> I HAVE access to Internet, with static or dynamic IP, but I want to
> boot with static IP
and change this situation thru KDE menus. Is it
> possible?
>
> Sorry my terrible english, this must be the problem in this thread.
>
> Best regards and THANK YOU ab
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJK8tWeAAoJEF+XTK08PnB5g8oP+wabIYc1LuTj6dJY0ZaG3kbu
8anemTv4fJ70dPy4QQUQOvXaEXxO2TyiWejgKhXQ2T09ULCeTXAadi5ec5ID/sQn
0+w0wWuPrjIjbg7o7Lwpt6OXsEVhZKzTAdRSFowPLLUDZPDyP1ihf6z8iwkUesqr
vAxQQVl7THd285fjNvEUy2XvTnvWCrb+F/rnM74RMDW1UulZGWuS2vT5/9v2d9Ob
uxgmGPPxyHrjDVzgn66NVMx3DQARIi6C5+ET/7condVHR7pI/QOjfRh2t3jPxLqT
KmiE3OmYOkOgXJWyKQow9Z6ZZ3XP4Kk0C6U1pUowEaV+3lbe66Q1f4p3ZCBoyK+J
8zZpTQtbm9Rnr0DKcNRbhEhzbJtRgH/HpTBj2p4EkZ7l9JAqtutfgSVleZ95X1vQ
UT6qyS0k1j3BU9JEiwoMZBAxZanAAntcYN9GjHGZ0v/luWdJ43gbU4LUMduYdZby
VTgbcDcARmkD85h1GUQGsg+77XoTDwJmDmIuoMRLaqWyx9C5fgENfUuqH/ENSzJ+
AK1uhLK29oEA2tbLkWt2C6qnHjgcbS9jxwRoYjKuvH7o1RFPk033wMECXFwWBSCD
QZQo+qqDkJkF1qVq4iI+J1Oc09TWpLCd1GtxzLuIlkZxeRXtF8mQVLItxv0w490M
9P5AEDRn/K/RkPptaAuQ
=P8Db
-----END PGP SIGNATURE-----

Why are you so hostile? You come to the forum with a problem and get
some questions from a VOLUNTEER, who asks you to supply necessary
information. You fail to do so, and get upset because you were asked.

We give a lot of leeway on this list because many people are not
comfortable with English. I don’t know if that is your problem, or not.

I know perfectly well how to configure static IPs for wired
interfaces. If I help you, are you willing to follow instructions, or
not? If I get the same kind of runaround that Akoellh got, I will drop
you as well!

Hi again

First of all, THANKS AGAIN, ab, for your last reply. I’m not right now on that computer, so I will try your guidelines tonight and I will tell you my results. That’s what I call to try to solve a user question.

In second place, lwfinger, I think you are being corporativist judging me as “hostile”. As you can read in previous post of Akoellh, he wrote an unfortunate phrase like this
“Wouldn’t it be a little more logical you start posting decent information about your setup?”
I think I was being totally “logical” and the information I posted was enough to solve “decently” my question. Is a right of a volunteer to call me “illogical” and to judge “indecent” information that I posted?. I think that is not correct, at all.

I even gave him my apoligies if I didn’t make my question correctly.

I must to thank you for your sincerity and good words. It was not my intention to despise help of anyone, of course, but I help in forums too (in english too) like MediaPortal or OpenOffice, and I NEVER question the logical way of a user on doing something, because that user is ASKING for help, not to doubt about his logical or not logical way of make things. If he thought my info were not sufficient, simply ASK ME for that info, it’s not necessary to write that is not “decent”.

Sorry if you don’t like my reasoning, but it’s sincere like yours.

I will be very gratefull to you for any help about my question, and cause I’m sure you will treat me like what I’m here: A person asking for help, not to be judged for anyone.

Best regards

You don’t know the most basic rule, don’t you?

NEVER quote people out of context, or they will hit you!

Yes, I wrote that, but you “forgot” to add what was directly in front of your quote.

In addition, you got a solution -which is more than only a workaround- in my FIRST answer and showed NO sign what so ever to cooperate by doing some work on your own even if being explicitely told what to do.

You know what?

It’s not clueless new users, who “don’t know anything about linux” which make we doubt I am doing something useful here, it’s users who behave like you and seem to expect to be fed with everything instead of doing anything requiring minimal effort of theír own.

@mods/admins

No need to “ban me for being the bad boy again”, I am out of here, openSUSE is maybe my distribution, but this is certainly no longer my type of community.

I will not talk more about rules or correct way to do things.
Sincerely, I think that if your haughty is greater than your eager to help, this community could lost a good help.

Sorry to everybody and in first place to you, Akoellh.

I read the entire thread. Your question is quite normal, nothing indecent. No apologies needed.r

To help you out:

Start Yast from the menu.
Pick Network Devices
At the right, pick Network Settings
In ‘Global Options’ select ‘Traditional method ifup’
In ‘Overview’ select your network card, click Edit
Now you can change the IP to 10.0.0.11, netmask 255.255.255.
0 hostname ‘WHATYOUWANT’, click continue.
Back in the first screen select ‘Hostname/DNS’, enter the DNS servers like done under the windu OS.
In the ‘Routering’ tab, set the gateway address (probably 10.0.0.1, you will know).

Check all settings, since you did static configuration it should look familiar to your windu settings. Confirm everything and you should be OK.

I apologize for the ‘welcome’ you had. This is not normal. Feel free to ask, there’s enough people here who don’t mind to explain again and again.

@finstro: There are two ways to solve a network config problem:

  1. You describe your problem and everybody writes down the million possible ways you may have configured your setup incorrectly … That’s very time consuming and usually you will only get questions for the most common configuration errors. That’s inefficient!

  2. You provide detailed information about your current incorrect network configuration - (that’s what akollh asked for) which helps the people trying to help you either to give you the right answer or to ask further < 5 questions instead of a million questions.

Hi again

In first place, thank you Knurpht. I was feeling bad about all this discussion, and was not my desire that anyone left this community.

To not despise ab@novell.com post, I tried first tried from command line, with “yast lan”, as he suggested. Then a window appear telling something similar to “Actually network is controlled by NetworiMaganer and is not possible to edit it’s configuration with YaST.
To edit the config, use NetworkManager connection editor. change …”. That message scares me, so I prefer not to continue in that way.

I must say I have a classroom with 20 PC’s and would like to teach my students to learn to use the basis of OpenSuse avoiding to take control from a terminal. Any ex-Windows pupil think that’s obsolete and complicated, so I prefer don’t talk about “Console” if not strictly neccesary.

After left console, I tried the Knurpht method, more friendly for users, and explained to the least detail. Both of them (ab and Knurpht) gave me the correct way to solve my problem, but lastly I prefer the “desktop way” cause I want to teach in that way to my pupils.

So thank you to both for your solution. I only have a question in my mind: Why the NM didn’t launch my profile to work at boot time if I configured it like you told me with IFUP? NM tray icon displayed a heart icon (maybe as a “prefered” option) next to “Auto eth” but I was not able to change that icon to my “static profile” (I would like to send you some captured images if you like to see what I’m talking about)

Best regards :wink:

Hey, I just found the answer about this problem.

“I can’t connect to the internet while I use a DHCP client. >:(”.

This is cause by a network configuration that change a DNS server automatcally.

First, try to see /etc/resolv.conf configuration, there written:


# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
nameserver 192.168.1.1

So… i try edit /etc/sysconfig/network/config file. And then I change:

NETCONFIG_DNS_STATIC_SEARCHLIST=""

become this >>


NETCONFIG_DNS_STATIC_SEARCHLIST="localhost"

And change


NETCONFIG_DNS_STATIC_SERVERS=""

**become this >> **

NETCONFIG_DNS_STATIC_SERVERS="127.0.0.1"

Save it. Then, edit /etc/dhclient.conf file. see at the line that contain this code:

#prepend domain-name-servers 127.0.0.1;

Remove the “#” code.

Finally, restart your connection. Those configuration tell the operating system for looking for Local DNS first, before connecting the DHCP server.

This is result on /etc/resolv.conf file, after restarting the network connection:


### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
search localhost
nameserver 127.0.0.1
nameserver 192.168.1.1

Hopefully useful ;).

Best Regard’s