Can't connect to samba shares, only sftp?

Decided to use opensuse as our dev environment. LAMP is running great, i can ssh in, phpMyAdmin works, etc.

So… I wanted to share out the /srv/www folder for our developers so they can work directly with their projects on the box. I started Samba server, added the share. I did not supply a workgroup name or setup a DC. So it should just be using the system users?

Well when I try to hit our smb shares on the dev server with my opensuse 12.3 laptop (Gnome) it will ask for Username, Domain, and password. I’ve not set a domain but it won’t let me leave it blank. Am i missing something? I know SMB is running because it shows under a network browse and I can manually type in the location smb://servername/sharedfolder. But it keeps asking for a username, domain, password. I have tried everything I could think of. I used the server name as the domain then created a workgroup and used the wrkgrp name. Nothing worked.

I’ve never had opensuse do this to me. Anyone have an ideas?

You have just got to take a look at my blog on the subject of Samba and fetch the bash script there that can setup Samba any way you want for a fast Peer-2-Peer network. Please read through the blog and give it a chance to help you. All comments and questions are welcome there as well as here.

S.A.C.T. - Samba Automated Configuration Tool - Version 1.06 - Blogs - openSUSE Forums

The following line, copied to a terminal session and run there will get the bash script and run it for the first time.

rm ~/bin/sact ; wget -nc -O ~/bin/sact ; chmod +x ~/bin/sact ; sact

The bash script does require root user access to perform same of the tasks, but Samba is a system loaded application normally and not in the user /home area. Once Samba is up and running, only normal user access is required to share files back and forth.

Thank You,

If the script is what solves it then I’ll certainly try that. I would also like to understand why it’s not sharing correctly though. Yeah, I’m being stubborn but it irks me LOL.

I’ve read through opensuse docs on samba (the wiki article didn’t explain much) and I’m confused why the yast module doesn’t set it up like you would think it would.

I just tested with Konquerer and it only asked for a username and password… but it still doesn’t take either system user (which do have access to the folder)

Everything starts with the /etc/samba/smb.conf file settings and the two service applications smb and nmb. If your config file is valid, does the two services run? What is your hostname? What is your workgroup? Are your SAMBA user name and passwords set? What are you trying to share? What are the file permissions for the files you are trying to share? There are many ways you can fail without knowing more. Most default SAMBA settings can get a valid share from another PC that is setup properly, but its got to start somewhere with an intent to share something. Instead of being stubborn, do some reading and ask specific questions. Also, I might throw in that Domains is a different subject from a Workgroup and a whole new level of access and outside the simple peer-2-peer setups for which I speak. You would have a Domain server setup to manage all users from when all of your user rights are set. This is beyond what my examples are intent on setting up for you.

Thank You,

By being stubborn im saying i dint want a script to fix it. So i am reading. Samba username and password are set. Smb and nmb are running. We currently have active directory running in native 2008 but I don’t want this attached to it. Our programmers are contractors.

The share I’ve setup is to htdocs. However every valid system account I try to authenticate with isn’t accepted but these accounts do have write permissions which work fine via FTP or local login. So I think I’m over looking something simple. Ill post my config.

The bash script is a tool that puts together all of the manual programs in one place. Except for a default smb.conf file it will put out for you, if any fixing is done, you will be doing it. It has the utils to double check your smb.conf file, can show all default settings and much more. Also, don’t forget your firewall settings which can block you cold.

It is getting late here in Austin (for those of us that get up before 5 AM) so I will be back online Wednesday to help further and good luck.

Thank You,

Found my answer…

when adding the users to the smbpasswd I was typing the wrong password on the client side. It’s working.

I don’t know if it was a must but i supplied a workgroup name as well.

for anyone that finds this thread… make sure you run smbpasswd -a on the user accounts you want to have access AND remember the password.

I appreciate you trying to assist though. I didn’t see your last response till now.