Can't connect to samba server from Mac Snow Leapord

Hi,

I have steup samba shares on my Susi pc. I get to the point where the server asks for a password for the user I have on the Susi box but when I enter the password it fails to connect.

I have tried to add the user, password and enabled the user in the samba conf file. But not sure where it should appear I give below the smb.conf file:

smb.conf is the main Samba configuration file. You find a full commented

version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the

samba-doc package is installed.

Date: 2010-07-05

[global]
workgroup = revendell
passdb backend = tdbsam
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \%L\profiles.msprofile
logon home = \%L%U.9xprofile
logon drive = P:
usershare allow guests = No
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain logons = No
domain master = No
security = domain
wins server = 192.168.2.1
wins support = No
[homes]
comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes
[profiles]
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700
[users]
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/
[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes
[printers]
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No
[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

[devsen]
comment = Dev Arragon
inherit acls = Yes
path = /home/devsen
read only = No

Share disabled by YaST

[netlogon]

Any help really appreciated - Thanks - Dev

So I have never had an opportunity to connect to a MAC computer of any kind before. Looking at your configuration I see a couple of things I would change. Under [global] change **security = domain **to **security = user **if I understand what you are trying to do. I would also add netbios name = LinuxPC for a PC share name and **preferred master = Yes **to make sure you have a browse master. Restart your PC to make these changes take effect.

See if these changes cause anything good to happen.

Thank You,

On Mon September 6 2010 03:36 pm, devsen wrote:

>
> Hi,
>
> I have steup samba shares on my Susi pc. I get to the point where the
> server asks for a password for the user I have on the Susi box but when
> I enter the password it fails to connect.
>
> I have tried to add the user, password and enabled the user in the
> samba conf file. But not sure where it should appear I give below the
> smb.conf file:
>
> # smb.conf is the main Samba configuration file. You find a full
> commented
> # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if
> the
> # samba-doc package is installed.
> # Date: 2010-07-05
> [global]
> workgroup = revendell
> passdb backend = tdbsam
> printing = cups
> printcap name = cups
> printcap cache time = 750
> cups options = raw
> map to guest = Bad User
> include = /etc/samba/dhcp.conf
> logon path = \%L\profiles.msprofile
> logon home = \%L%U.9xprofile
> logon drive = P:
> usershare allow guests = No
> add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody
> -s /bin/false %m$
> domain logons = No
> domain master = No
> security = domain
> wins server = 192.168.2.1
> wins support = No
<snip>
>
> Any help really appreciated - Thanks - Dev
>
devsen;

“security = domain” should only be used for a member server of an NT4 or Samba
domain. Unless this is a domain with a PDC running on another server remove
this and let it use the default security setting ( user). Have you created
Samba users with:


smbpasswd -a <user name>

?

I would suggest you read and follow this HowTo:
http://opensuse.swerdna.org/suselanprimer.html


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

Thank you both - yes the simple changes has made it work. BTW Mac OSX is built on BSD Unix - so underneath the front is Unix / Linux - the reason for its stability and security :slight_smile: Best Regards - Dev

Happy to hear you got it working devsen and thanks for informing us of your success. If we can be of any other service, just let us know.

Thank You,

Thanks I certainly will get in touch if I have any more issues - now that I have settled on using OpenSusi after having tried Obuntu and Mandriva - Thanks - Dev