Can't connect to repository sites using yast or zypper

I have a new installation (not an update) of opensuse 64 on my computer and a 32 bit version on my laptop. I did a memory check and a media check on both systems. I have IPv6 disabled on both machines. I’m using Qwest a DSL connection. Both computers were running opensuse 11.3 without problems.

Since the installations neither computer will allow me to add the packman or any other repository. While using yast->Software Repositories->Add and trying to add the packman repository by any of the methods available, I’ll get the screen saying it’s checking the type of the repository. That screen will stay until the process times out and I get an error message saying it cannot access the media.

SUSE Paste

http://paste.opensuse.org/99308806

I have to use the kill process keys to close that process. I’ve tried several different packman sites and several different repositories, such as nvidia, videolan and the like with the same results.

If I try to add the repository using zypper, I get an error mentioning curl that says that the files are not accessible. But, I can access the sites using firefox and can move around the sites and can download files.

I logged in as root and was able to add the repository using zypper. However, even as root, If I try to use yast to add a file the system hangs during the Load the Configured Repositories process and shows the same error message.

I used rpm to install an application from packman but it took me a long time to figure out where to find all the files and it was slow. I don’t see this working too well as a regular system for keeping up to date with security patches.

When I did the install, I modified the software section to include the Gnome desktop so as to have booth available. I wondered if this might be the problem so I installed a brand new drive in my computer and did another install , this time letting the install program do whatever it wanted to do. The problem did not change.

I have tried shutting down the firewall in my router and on the computer. No difference. I can use the repositories that were installed as part of the system without any problems. I just can’t add any or use them if I do manage to get them in.

I don’t see any other threads mentioning this problem on 12.1, so I believe it’s unique to my situation. It’s the same problem with three installs, using two different versions (32 and 64 bit), so I don’t think it’s corrupted software or installations. I just don’t know where to look any more.

Please post:

cat /etc/resolv.conf

If in this file is only the IP of your router, delete it and try an IP such as google`s 8.8.4.4

Then

rcnetwork restart

as root.

Thanks for your reply.

Here is the content of etc/resolv.conf:

search domain.actdsltmp
nameserver 192.168.0.1
nameserver 205.171.2.65

This is the address listed as Name Server 2 in yast->Network Settings->Hostname/DNS and is also the second entry in my DSL router.
I have tried changing this setting to 8.8.4.4 on my computer but have not changed the router.

For my own information, is it the address in router or in the computer that is acutally being used? And, if this is a DNS problem, wouldn’t I have had problems using rpm? I did install files using rpm and they operate properly.

It seems to me that yast and/or zypper is sending the wrong request, like for a .repo file that doesn’t exist or the like. Do you know of a utility I could use that would let me see what is actually being sent?

A partial update on my problem.

The fact that there are no other people on this forum with the problem I am having, I am fairly confident that the problem lies not with openSuse software.

I took my laptop, running 12.1 32 bit, and having the same problems as this computer, to the home of the tech who installs the cable systems here in town. It operated properly on his modem! Again reinforcing the idea that the problem is not with openSuse.

The fact that I can access the repository sites using ping or Firefox and even add apps using rpm, not to mention that no one else is having a problem, means the problem is not on their servers.

That leaves only my ISP. I’m using Century Link, which is the new name for Qwest. I spent about an hour on the phone, trying this and that, getting bumped to level two support (whatever that means!). They assured me the only port they are blocking is 25. We reset everything to defaults and set everything to whatever we could think of. I even tried waving a dead chicken over this thing, to no avail!

Next week I expect to have ISP service from the cable company installed. We’ll see then.

Something changed in the way respositories are added and/or accessed. 11.3 did, and still does, work well. I don’t see where this apper thing is any improvement. Oh, well. After cable is installed, I’ll post if it works. Wonder if I’ll ever figure out what was/is wrong.

The post by Sauerland supposes you have a DNS (name resolution) problem.
Why, and how he jumped to that possibility I have no idea, it’s just one of many possibilities.

If you do suspect you have a name resolution issue, you can always use the nslookup utility to test connectivity to that and any other DNS server, and name resolution using that particular server.

But, since you say you are able to connect to, and browse those repositories using a web browser without problem I <do not> suspect a name resolution issue (assuming you’re using the same URI/URL in the web browser).

Unless you’re very certain how to add a repo using zypper, I strongly recommend you use YAST instead to minimize mistakes (YAST will suggest partial paths, you just complete).

Also, before you go further I’d recommend you run a


$ zypper up

That should properly update both your system and all the applications running on your system using any working configured repos. You will then definitely identify which repos are working and which aren’t.

HTH,
TS

Thanks for your reply. For this week, I’m going to let things go. This weekend, I should have a new ISP. My laptop, which will not work properly here works properly when connected to the cable system.

I do wish though, that I could start yast from a command prompt or something so I could see exactly where, and what application was calling what ,when I have the problem. I am going to leave the DSL connection alive for a while, so I can switch back and forth to see if I can’t figure this out.

If I can install an application from packman, using rpm, and that application installs and runs properly, it would seem to me that my network connection is working properly. If I can use yast to update and add applications from the default suse repositories, I would think my system is set up and running properly. Something, somewhere in yast has changed from 11.3. My ISP assures me that the only port they are blocking is 25, common enough. This just bothers me.

You can launch YAST from the CLI,


// This launches the GUI YAST
$ yast2

// This launches YAST within a console
$ yast

If as you say your system connects to the repos without a problem using a different ISP, that strongly indicates the problem likely isn’t with your repo configuration.

Instead, I would start to strongly suspect network congestion issues. So, for instance I’d recommend you consider implementing a different TCP/IP Congestion Control Algorithm.

Here is a “paper” I wrote on setting your TCP/IP buffers, various settings and chanign the Congestion Control algorithm
Optimize and Fix your Network Connection - Su Networking Technical

HTH,
TS

I have fixed my problem!
It seems the problem was in the modem/router. I purchased a new modem/router and my system is working as it should. I have no idea what it was that caused my router to exhibit a problem in the manner it did, but a new one fixed it!

A big pat on the back to those who replied to my request for help, and to those who looked at it and, although they didn’t think they could help, at least took the time to think my situation over.

On 2012-03-18 09:56, montana suse user wrote:
>
> I have fixed my problem!
> It seems the problem was in the modem/router. I purchased a new
> modem/router and my system is working as it should. I have no idea what
> it was that caused my router to exhibit a problem in the manner it did,
> but a new one fixed it!

Surprise… You should perhaps post the faulty make and model, in case
someone comes in the future with a simila baffling problem.

> A big pat on the back to those who replied to my request for help, and
> to those who looked at it and, although they didn’t think they could
> help, at least took the time to think my situation over.

Thanks :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

The modem/router in question is, or more correctly was, an Actiontec GT701. It served me well for about 5 years. There may have been a firmware update but the tech support people didn’t mention one and I don’t remember seeing one available. I guess it simply got outdated.

It exists no longer. My new device is an Actiontec PK5000. Both these devices are noted as being specific to Qwest/Century Link, who is is carrier in this area.

In any event, the cable service is due to be available in the next couple of days. Speed should go from 7 to 10 Mbps. The increase in speed will be appreciated.

I’m sort of looking for answers on this.
I have a fileserver and a static ip set on it. The rest of my computers and devices are working on a DHCP. The server has an address 192.168.0.2 where as the router / DHCP gives out address from 192.168.0.100 onwards.
Now I’m able to connect to the server thru ssh & stuff, but when I try to do updates, it says…

Download (curl) error for 'http://download.opensuse.org/update/12.2/content':Error code: Connection failed
Error message: Could not resolve host: download.opensuse.org (Could not contact DNS servers)

I know the router works. Any ideas?

2 things:

  1. This is a stale thread. Not the best place to ask a question which may have completely different causes.

  2. Please don’t double-post. You’ve already asked that question here:

https://forums.opensuse.org/english/get-technical-help-here/network-internet/473319-static-ip-not-working.html