Can't connect to OUTSIDE WiFi bases!


This issue is driving BANANAS!! I am about to jump out the window, (unfortunately I live on the ground floor and it won’t make a difference!!)

I am having a connection issue with OpenSuse 11.1 KDE i64.
It connects great at home, it sees and connects to my Apple Airport and even the neighbor’s Netgear open base. HOWEVER! No matter what I install (Fedora, Kubuntu, Open SUSE, Saboyan, and whatever it will NOT connect to outside WiFi networks Like AT&T, at Starbucks, McDonalds or at any hotel or public WiFi AS LONG AS I RUN A 64 BIT VERSION.

When I install the 32 bit version we have connection, with BOTH Network Manager or Wicd.
Install a 64 bit version and we are dead in the water. (NO CONNECTION!) Can’t get IP address even after it sees the connections!!

Obviously it has to be some type of driver issue for the Intel chipset??.
(Wicd it tells me: “failed to get IP Address”)

I have been a SuSE Linux user since version 7, I want to stick with it, its GREAT! But this issue has be trying other distros, now I have to carry a MacBook and I have developed an inferiority complex.

Please help. What can I do?

I recently installed the Wicd version ( at the Open Suse Linux Build site.
I was running version before and had the same results.

About my laptop:

Panasonic Toughbook CF-52

Running Open Suse 11.1 with a PRO/Wireless 4965AG or AGN (Kendron) Network ConnectionDHCP
Linux x86_64
openSUSE 11.1 (x86_64)
KDE:4.1.3 (KDE 4.1.3) “release 4.10.4”

Processor (CPU): Intel(R) Core™2 Duo CPU T7100 @ 1.80GHzSpeed:800.00 MhzCores:2

Total memory (RAM):3.9 GB
Free memory:2.8 GB (+ 451.9 MB Caches)Free swap:3.0 GB

I don’t care what I have to install (Network Manager or Wicd) as long as it works on my x86_64 laptop.


Your input will be greatly appreciated!


Do you have ivp6 enabled? ivp6 takes longer to negotiate and can result in timeouts with busy networks.

Thanks guy!

I made the change you suggested, heading out later on and WILL TRY! once more.

Just so that I may learn from this, how does ivp6 affect all this?
What does it do? or NOT do?

Again, THANKS for your reply!


theoretically ivp6 is a protocol that is supposed to be more definative in resolving ip addressing but under a multitude of conditions, it slows connecting to networks, printers, scanners so much that timeouts occur because of all the checking done before the connection is returned as being valid. ivp4 while not as definative usually has no problem returning a valid ip using services like DNS look-up.
While I know several people that have used ivp6 with success, it is not my experience that it works well. I recommend getting everything working under ivp4 and then if you want to experiment try using ivp6.:\

Thank you for your kind reply.
I did try your suggestion, still no results. (I think this laptop is POSSESSED!)

Because I need it for work, before setting it on fire, tossing it off the roof or running it over with my truck 3 or four times.

I instead wiped the drive clean and installed Open Suse 11.2
W O W ! ! !

No, I don’t know enough to notice a big difference. And Now I can’t get K3B to burn my mp3 music CD’s, but this thing now connects to WiFi bases in the next county!!!

Yes, I will eventually figure out how to get K3B to burn my mp3 music CD’s but being able to connect to WiFi is that important to me.

Thank you so much for your reply.



And the headline reads:

OpenSUSE 11.2 Milestone 8 Released :slight_smile:

And if you look further under most annoying bugs:

Bug 537112 – Intel 4965 wireless is completely broken :frowning:

I tell you, this noe thinks “Someone is out to get us!”
The same article says “it was working fine in the previous version just a few days ago”.
I know!!! I am running that version, it is connecting better than IT EVER HAS.
(I am in Miami, South Florida USA, I think I am connecting with hot spots in the next County, heck Georgia, The Bahamas, Cuba, Cancun. !!! I think I connected with the International Space Station on its last passby!!!)
YES!!, I am that happy with it FINNALLY!!! rotfl!

Why someone wanted to mess with it is beyond me.
Like some politician once said: “for WiFi users, Its the CONNECTION stupid!"

This crazy 4965 user will keep using this beautiful, buggy, un-updatable (Milestone 7) version till the official 11.2 release has been out for months.

A big THANK YOU to the great guys working on this Open Suse release and the great bunch here for their extremely valuable support.

I respectfully hope our moderators won’t get too mad for this slightly off topic post!