can't connect to network drive (DNS-323)

I am unable to connect to my network drive (D-Link DNS-323) from linux. I’m using OpenSUSE 10.3. The network drive is set up with a static IP, and I can access it from WinXP. The network drive’s IP address is visible, but all the ports are blocked. When I run nmap I get the following message:
All 1697 scanned ports on are filtered
Nmap finished: 1 IP address (1 host up) scanned in 36.429 seconds

I’ve tried going in to YaST > Security and Users and turning off the firewall, but that doesn’t seem to have any effect.

Any ideas on what might be blocking the IP address?

Are there any services or daemons that need to be set up?


I looked at the DNS-323 product manual and it appears to have a built-in firewall; there are access rules by IP address. Have you allowed your SUSE computer access? If not that would explain no response to nmap.

I don’t think the DNS-323 has a firewall, or at least I haven’t found it. I’m dual-booting on the same machine, and the computer has the same IP address when I’m in Linux and when I’m in Windows.

As far as user accounts on the DNS-323, I’ve got it set up to allow read/write access to everyone.

I’ll try booting up on a LiveCD and see if there’s still the same problem.

Well I saw something in the manual about IP access lists for shares. Why not have a closer look?

I can access the DNS-323 fine when booting from an SUSE 11.1 LiveCD.

I’ve tried to compare the SUSE 11.1 LiveCD system to my SUSE 10.3 system, although I’m not sure what to look for. I’ve tried comparing the system services that are running, the packages that are installed, firewall settings, and iptables. The only significant differences I can find are:

  1. On SUSE 11.1, the services ‘network-remotefs’ and ‘rpcbind’ are running, but these two services are not installed on my SUSE 10.3.

  2. I noticed that there appear to be no iptables rules in SUSE 11.1, or at least I get no results when I type in “iptables -t filter -L”. In SUSE 10.3 I get a long list of chains and rules in response to “iptables -t filter -L”. (I could post the output if it would help.)

  3. On SUSE 11.1, the cifs-mount package installed is version 3.2.4-5.2, and yast2-samba-client is version 2.17.11-1.30; on SUSE 10.3, those packages are version 3.0.26a-3.7 and version 2.15.11-33. Also installed on SUSE 10.3 are pam_cifs, samba-client, kdebase3-samba, and nautilus-share.

Are any of these possible reasons that I can’t access the DNS-323? What else should I check? I suppose I could install SUSE 11.1 on my hard drive and just forget about 10.3, but I’d rather not do an upgrade right now if I don’t have to.

I’m pretty sure the problem lies with my installation of SUSE 10.3, rather than the DNS-323 itself; I can access the DNS-323 using the same computer but booting with Windows XP, SUSE 11.1 LiveCD, or PCLinuxOS 2007 LiveCD (DNS-323 gets a static IP of, and my machine gets assigned by my router’s DHCP server).