Can't connect to most websites besides Google

Hello! So I am *trying *to use openSUSE (well, technically Geckolinux) as my new Linux distro. I’m moving from Fedora because I prefer YaST’s brilliant and fast package management to anything else I’ve found thus far.

My issue is strange: I can’t connect to most websites. Examples: and both work, but and do not. I can’t find the pattern concerning what works and what doesn’t.

Here’s some basic system info:

HP laptop with 802.11n Wifi
Geckolinux Static Plasma 423.180187 (based on openSUSE Leap 42.3) – I’m running it from the live DVD until I can figure out how to solve this issue.
KDE Plasma 5 (not sure which sub-version)
Firefox 52

I already tried disabling IPv6 in Firefox’s about:config and I tried setting the MTU value on eth0 to 1492, but neither helped. I also can’t try another browser; since it’s Geckolinux I guess, Konqueror is not installed. Since my Fedora install works fine connecting to any website under pretty much the same circumstances from a networking standpoint, I can only assume that the problem has the most to do with openSUSE itself. I would love to use openSUSE as my primary OS, but I need to get this clearly problematic issue out of the way first. Any help would be appreciated; thanks!


ping -c1
ping -c1 adress which do not work

Is there a Proxy defined in Firefox or the Systemsettings?

Geckolinux Static Plasma 423.180187 (based on openSUSE Leap 42.3) – I’m running it from the live DVD until I can figure out how to solve this issue.

Maybe you ask the Maintainer of that ISO?

Hi there, that’s me.

That’s sort of a strange issue, but it definitely sounds IPv6 related. Please try disabling IPv6 in NetworkManager and in the YaST Network settings and then reboot.

What does

cat /etc/resolv.conf 


Hi sb56637! I think it is so awesome that you replied to me. I feel so special! :slight_smile: Anyway, your distro definitely gets a +1 in my book for it.
Thanks to all the rest of you for your help, too. I am really impressed with how helpful and quick this forum is!

Just one question: since it’s a live DVD, won’t rebooting erase any changes I make to the network configuration in NetworkManager or YaST? I’ll get back to you with output from the ping and cat commands as soon as I can. Given that Google is still accessible, I can probably just have Google Translate pretend to translate the page for me and send me back the results. It should allow me to copy and paste the outputs into the forum for you all. Thanks!

The DVD won’t save your settings, it’s simply not writeable, And Live DVD for 42.3? These don’t exist.

Hi there, is it actually a DVD that you burned, or did you write it to a USB drive? In the case of a live USB, it will save your settings.

The OP is referring to GeckoLinux, which has live editions based on Leap 42.3.

I stand corrected.

Yes, I am using an actual live DVD. I tried earlier to use a USB drive, but it kept having stability issues: disconnecting from the computer during use and such. Hence I switched over to using actual physical discs.

So I figured it out. Turns out that turning off IPv6 in YaST did the trick. Thanks!

Just a thought: if GeckoLinux is about removing papercuts for new users, wouldn’t disabling IPv6 by default be a good idea?

We’re openSUSE, not the Geckolinux dev. And disabling IPv6 is not a good idea, since many ISP’s do server IPv6 these days, and we soon will see non-IPv4-reachable sites, since the pool of IPv4 addresses is becoming used entirely.