Can't connect to Internets via DHCP

I am new to linux and have suse 11.2 x86_64 installed. Beyond that, i don’t know the proper commands to list my system information. Up until recently, the internet worked fine, but suddenly stopped. I opened up YaST2 and found that the network device was set up to never turn on, and i switched it to “at boot time” but it still doesn’t work. Any help would be greatly appreciated.

Post the output of these commands

/sbin/ifconfig
sudo /sbin/ethtool eth0
ps -A dhclient
ip route show
cat /etc/resolv.conf

mumbricht@linux-90dj:~> /sbin/ifconfig
eth0 Link encap:Ethernet HWaddr 6C:F0:49:50:22:8A
inet addr:192.168.1.192 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::6ef0:49ff:fe50:228a/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:111 errors:0 dropped:0 overruns:0 frame:0
TX packets:143 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:12050 (11.7 Kb) TX bytes:14370 (14.0 Kb)
Interrupt:32

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:14 errors:0 dropped:0 overruns:0 frame:0
TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:820 (820.0 b) TX bytes:820 (820.0 b)

mumbricht@linux-90dj:~> sudo /sbin/ethtool eth0
root’s password:
Settings for eth0:
Supported ports: TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Half
Port: MII
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000033 (51)
Link detected: yes
mumbricht@linux-90dj:~> ps -A dhclient
ERROR: Unsupported option (BSD syntax)
********* simple selection ********* ********* selection by list *********
-A all processes -C by command name
-N negate selection -G by real group ID (supports names)
-a all w/ tty except session leaders -U by real user ID (supports names)
-d all except session leaders -g by session OR by effective group name
-e all processes -p by process ID
T all processes on this terminal -s processes in the sessions given
a all w/ tty, including other users -t by tty
g OBSOLETE – DO NOT USE -u by effective user ID (supports names)
r only running processes U processes for specified users
x processes w/o controlling ttys t by tty
*********** output format ********** *********** long options ***********
-o,o user-defined -f full --Group --User --pid --cols --ppid
-j,j job control s signal --group --user --sid --rows --info
-O,O preloaded -o v virtual memory --cumulative --format --deselect
-l,l long u user-oriented --sort --tty --forest --version
-F extra full X registers --heading --no-heading --context
********* misc options *********
-V,V show version L list format codes f ASCII art forest
-m,m,-L,-T,H threads S children in sum -y change -l format
-M,Z security data c true command name -c scheduling class
-w,w wide output n numeric WCHAN,UID -H process hierarchy
mumbricht@linux-90dj:~> ip route show
192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.192
169.254.0.0/16 dev eth0 scope link
127.0.0.0/8 dev lo scope link
default via 192.168.1.1 dev eth0
mumbricht@linux-90dj:~> cat /etc/resolv.conf

Generated by Nortel NetDirect

The old file is backed up in /etc/resolv.conf.nd

nameserver 130.215.32.18
nameserver 130.215.39.18
domain wpi.edu
search wpi.edu

that last part seems odd; I don’t live on campus, so my domain shouldn’t be wpi.edu…

Than probably your dns info is not updated correctly, this can probably fixed with these commands:

sudo mv /etc/resolv.conf /etc/resolv.conf.bak
sudo /sbin/netconfig update -f

I heard someone say this is a bug in the networkmanager shipped with 11.2. An update to a later version of KDE this should be solved, this can be done by adding the KDE:KDE4:STABLE:Desktop repository.

sudo zypper ar http://download.opensuse.org/repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2/KDE:KDE4:STABLE:Desktop.repo
sudo zypper ref
sudo zypper up

And without markup scramlbing :\


sudo zypper ar http://download.opensuse.org/repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2/KDE:KDE4:STABLE:Desktop.repo
sudo zypper ref
sudo zypper up

I’m guessing that the KDE4 stable desktop repository won’t work with gnome…

not likely no :slight_smile:

did “sudo /sbin/netconfig update -f” solve your issue?

IT LIVES!!! so the fix was renaming resolvf.conf to resolvf.conf.bak and rewriting the file?

For some reason editing /etc/resolv.conf breaks the update mechanism of networkmanager to update this file. I don’t know why this happens, maybe someone has an idea about this and how to prevent this.

Removing /etc/resolv.conf and letting networkmanager creating a new one solves this, yes.

On 02/12/2010 02:56 AM, joostvanrooij wrote:
>
> For some reason editing /etc/resolv.conf breaks the update mechanism of
> networkmanager to update this file. I don’t know why this happens, maybe
> someone has an idea about this and how to prevent this.

That is intentional and necessary behavior. It is assumed that if resolv.conf is
changed locally, then the user knows something that DHCP does not.

> Removing /etc/resolv.conf and letting networkmanager creating a new one
> solves this, yes.

For most people, the bug was that resolv.conf was incorrectly found to be
modified when it was not.

well thank you joostvanrooij, you are a gentleman and a scholar. So why would DHCP think i had modified the file?

I would advice you to buy at least one retail version. I am not aware how openSuSE retail versions are, but I bought SuSE from 5.3 to 7.0 and all of them had a very extensive manual covering the distro and system.

I do recomend the same for everyone who has not been in contact with Linux before or people moving from another distro’s, as low level SuSE is different from distro’s like Fedora, specially with the booting scripts.

I would also recomend you to be confortable with vi improved, small things such as commands, that will be a great help and vi is present in some system utilities like visudo.

I know this demands investment, but it’s an investiment that you can capitalize at productivity level. I am not aware if openSuSE as a digital version of their paper manual (or even if it exists), but that also works as a tip for openSuSE.

On 02/12/2010 02:56 PM, macattack278 wrote:
>
> well thank you joostvanrooij, you are a gentleman and a scholar. So why
> would DHCP think i had modified the file?

It was a bug, now fixed.