Can't connect to internet with realtek wireless card

Hello, all!

I am using opensuse 42.1 and I can’t establish internet connection with realtek wireless card.

~> /sbin/lspci -nn|grep Network
01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller [10ec:8172] (rev 10)
~> lsmod |grep rtl8192se

rtl8192se              86016  0 
rtl_pci                36864  1 rtl8192se
rtlwifi                98304  2 rtl_pci,rtl8192se
mac80211              819200  3 rtl_pci,rtlwifi,rtl8192se
~> dmesg |grep rtl8192se
Loading firmware rtlwifi/rtl8192sefw.bin
~> uname -r
4.1.27-27-default
~> /usr/sbin/iwlist wlan0 scanning
wlan0     No scan results 
~> /usr/sbin/iw wlan0 info
Interface wlan0
    ifindex 2
    wdev 0x1
    addr 1c:65:9d:56:42:40
    type managed
    wiphy 0 
~> ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
    link/ether 1c:65:9d:56:42:40 brd ff:ff:ff:ff:ff:ff
3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 80:ee:73:11:6b:b6 brd ff:ff:ff:ff:ff:ff 

Itried to bring it up:

~> sudo ip link set wlan0 up

But I had no success…

~> ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
    link/ether 1c:65:9d:56:42:40 brd ff:ff:ff:ff:ff:ff
3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 80:ee:73:11:6b:b6 brd ff:ff:ff:ff:ff:ff 

I woul appreciate some help.
Thanks

Hi OpJR

First, welcome to the forums. The output you provided looks like the wireless hardware is supported and as expected, however you didn’t say whether you’re using NetworkManager or wicked. Your use of the ifup command suggests the latter. Anyway, this an be chosen via YaST > System > Network Settings > Global Options.

If using wicked, you need to configure the network card via YaST > System >Network Settings > Overview and editing the settings for the device concerned. For wireless devices, this will involve configuring the SSID and providing the relevant authentication details to allow association with an access point.

There’s the relevant part of the openSUSE guide for network configuration via YaST:
https://doc.opensuse.org/documentation/leap/reference/html/book.opensuse.reference/cha.basicnet.html#sec.basicnet.yast

I tried both NetworkManager and wicked. None worked. The last one was configured in YAST but like I said I am unable to connect to my wireless network.
Also I tried the manual method. No sucess. This driver is some years old. How can Opensuse is unable to get it to work??? On, windows is just a piece of cake. What a pitty!!!

When using wicked, what is the result of the following?

/usr/sbin/iwlist wlan0 scan

Also, show us your network device configuration

cat /etc/sysconfig/network/ifcfg-wlan0
~> sudo /usr/sbin/iwlist wlan0 scan
wlan0     No scan results
~> sudo cat /etc/sysconfig/network/ifcfg-wlan0BOOTPROTO='dhcp'
STARTMODE='auto'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR=''
MTU=''
NAME=''
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
WIRELESS_AP=''
WIRELESS_AP_SCANMODE='1'
WIRELESS_AUTH_MODE='psk'
WIRELESS_BITRATE='auto'
WIRELESS_CA_CERT=''
WIRELESS_CHANNEL=''
WIRELESS_CLIENT_CERT=''
WIRELESS_CLIENT_KEY=''
WIRELESS_CLIENT_KEY_PASSWORD=''
WIRELESS_DEFAULT_KEY='0'
WIRELESS_EAP_AUTH=''
WIRELESS_EAP_MODE=''
WIRELESS_ESSID='MY_ESSID'
WIRELESS_FREQUENCY=''
WIRELESS_KEY=''
WIRELESS_KEY_0=''
WIRELESS_KEY_1=''
WIRELESS_KEY_2=''
WIRELESS_KEY_3=''
WIRELESS_KEY_LENGTH='128'
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''
WIRELESS_PEAP_VERSION=''
WIRELESS_POWER='no'
WIRELESS_WPA_ANONID=''
WIRELESS_WPA_IDENTITY=''
WIRELESS_WPA_PASSWORD=''
WIRELESS_WPA_PSK='MY_WIRELESS_PASSWORD

Thanks, @deano

Also,

~> ip link1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
    link/ether 1c:65:9d:56:42:40 brd ff:ff:ff:ff:ff:ff
3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 80:ee:73:11:6b:b6 brd ff:ff:ff:ff:ff:ff 

And in YAST: Network Settings: Overview

It says this,

RTL8191SEvB Wireless LAN Controller (Not connected)

Even more,

~> sudo systemctl status wickedwicked.service - wicked managed network interfaces
   Loaded: loaded (/usr/lib/systemd/system/wicked.service; enabled)
   Active: active (exited) since Qua 2016-09-14 20:38:28 WEST; 1h 22min ago
 Main PID: 998 (code=exited, status=0/SUCCESS)


Set 14 20:38:28 linux-e2uc wicked[998]: eth0            up
Set 14 20:38:28 linux-e2uc systemd[1]: Started wicked managed network interfaces.
Set 14 21:43:34 linux-e2uc systemd[1]: Reloading wicked managed network interfaces.
Set 14 21:44:04 linux-e2uc wicked[2857]: wlan0           device-ready
Set 14 21:44:04 linux-e2uc wicked[2857]: wlan0           setup-in-progress
Set 14 21:44:04 linux-e2uc systemd[1]: Reloaded wicked managed network interfaces.
Set 14 21:57:08 linux-e2uc systemd[1]: Started wicked managed network interfaces.
Set 14 21:59:27 linux-e2uc systemd[1]: Reloading wicked managed network interfaces.
Set 14 21:59:28 linux-e2uc wicked[5932]: ifreload: no matching interfaces
Set 14 21:59:28 linux-e2uc systemd[1]: Reloaded wicked managed network interfaces.

“NO MATCHING INTERFACES”…