can't connect Intel 82579V

i have Intel 82579V, Gigabit LAN Controller and opensuse 12.1. i can not connect to the internet. when i go into network settings i have activate device at bootup, says firewal disabled. under address tab its say device type ethernet eth2 for name

dynamic address- DHCP DHCP both 4 and 6. under hardware it says the module name e1000e.

in hardware infor -

driver e1000e

drivers
active-yes
modprobe-yes

kernel drive e1000e

cant figure out why i can not connect to internet?

THANKS

You post the conclusion that your system can not connect to the internet. But you do not show any prove of it. How did you come to that conclusion? Please show what you did.

You do not say your network card isn’t running or that you have connection inside your LAN (e.g. to your router). But on the other hand, you also do not say your NIC is up and has an IP address and that you can connect to your LAN.

Thus please post the output of

/sbin/ifconfig -a

and

netstat -r

and

cat /etc/resolv.conf

and

ping -c1 130.57.66.6

(And all of course between CODE tags, you get them by clicking on the # button in the toolbar of the post editor.)

cant connect, firefox doesnt load page, messenger doesnt connect, it not connected

results for

/sbin/ifconfig -a

eth1      Link encap:Ethernet  HWaddr C8:60:00:CC:CA:06  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:52 

eth2      Link encap:Ethernet  HWaddr C8:60:00:CC:CD:C0  
          inet addr:192.168.1.27  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::ca60:ff:fecc:cdc0/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1                                                                                           
          RX packets:2770 errors:0 dropped:0 overruns:0 frame:0                                                                                
          TX packets:2187 errors:0 dropped:0 overruns:0 carrier:0                                                                              
          collisions:0 txqueuelen:1000                                                                                                         
          RX bytes:2445484 (2.3 Mb)  TX bytes:269865 (263.5 Kb)                                                                                
          Interrupt:20 Memory:f7c00000-f7c20000                                                                                                
                                                                                                                                               
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:168 errors:0 dropped:0 overruns:0 frame:0
          TX packets:168 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:14565 (14.2 Kb)  TX bytes:14565 (14.2 Kb)

results for

netstat -r

Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface

results for cat /etc/resolv.conf

### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
search westell.com
nameserver 192.168.1.1
suse1@linux-fjj3:~> cat /etc/resolv.conf
### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
search westell.com
nameserver 192.168.1.1

results for
ping -c1 forums.opensuse.org

ping: unknown host forums.opensuse.org

Hm, the first shows that eth2 is configured and up using IP address 192.168.1.27 (and also am IPv6 address).

The second is a bit strange in that it only has the header. Now it could be that something is missing there (after all we are searching for strange things), but not all and everything. Are you sure you copied/pasted this correct. It is allways better to copy/past everything, the prompt, the command, the output and the next prompt. That also releaves you from telling things like “results for …” because that is then in the copied/pasted data. E.g. this is from one of my systems:

henk@boven:~> netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         10.0.0.138      0.0.0.0         UG        0 0          0 eth0
10.0.0.0        0.0.0.0         255.255.255.0   U         0 0          0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U         0 0          0 lo
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 eth0
henk@boven:~>

The third seems to be posted double ??? But it shows that 192.168.1.1 is your nameserver. And that is most probably your router and thus it could be correct.

The last one shows that your DNS is not working. That could be because of the router not doing what it should, but it could also be because you cannot reach it. We will check that.

So please:

  1. confirm that your
netstat -rn

copy/paste is realy complete. Preferably by re-posting it including prompts and command.

  1. check connect to your router with
ping -c1 192.168.1.1
  1. and check the internet while skipping DNS
ping -c1 130.57.66.6

when i boot up on my other harddrive in my system with windows using the intel ethernet all works correctly but on opensuse 12.1 it isnt connecting or something not set up correclty?

netstat -rn

suse1@linux-fjj3:~> netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG        0 0          0 eth2
127.0.0.0       0.0.0.0         255.0.0.0       U         0 0          0 lo
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 eth2
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth2
suse1@linux-fjj3:~> 

ping -c1 192.168.1.1

suse1@linux-fjj3:~> ping -c1 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.

--- 192.168.1.1 ping statistics ---
1 packets transmitted, 0 received, 100% packet loss, time 0ms

suse1@linux-fjj3:~> 

ping -c1 130.57.66.6

suse1@linux-fjj3:~> ping -c1 130.57.66.6
PING 130.57.66.6 (130.57.66.6) 56(84) bytes of data.
From 192.168.1.27 icmp_seq=1 Destination Host Unreachable

--- 130.57.66.6 ping statistics ---
1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

suse1@linux-fjj3:~> 

Isn’t that what we are working on?

This looks better. So your last post was not correct wasn’t it?
This shows that your router is 192.168.1.1 and that your default rote (to the internet) is routed to it. So that is OK.

And this shows that you can not ping to your router???

And when you can not reach your router, you can not connect through it to the internet.

I think you use DHCP.
Let us see what the configuration of eth2 is:

cat /etc/sysconfig/network/ifcfg-eth2

Can you please explain how you configured it? During installation? Did it ever work (I mean 12.1 is already a bit old and I assume you have it already running for some time)?

This is eth2. I see also an unused eth1, but I do not see eth0. How many NIC’s do you have? And why do you use eth2 here?

it did work before but i had a different motherboard. I just changed my motherboard and cpu.
running A p8z77 v deluxe board now. the board has

Intel® 82579V, 1 x Gigabit LAN Controller(s)
Realtek® 8111F, 1 x Gigabit LAN Controller(s)
Dual Gigabit LAN controllers- 802.3az Energy Efficient Ethernet (EEE) appliance
Intel® LAN- Dual interconnect between the Integrated LAN controller and Physical Layer (PHY)

and has the wifi go module for wifi and bluetooth

  • Bluetooth V4.0
    Bluetooth V3.0+HS

In the board manual it says use the intel LAN (RJ-45) port. Recommended for single LAN usage. So im using my intel port, I also have two other hard drives installed in my tower with other operating systems using the intel port

linux-fjj3:/home/suse1 # cat /etc/sysconfig/network/ifcfg-eth2
BOOTPROTO='dhcp'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR=''
MTU=''
NAME='Intel Ethernet controller'
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'
linux-fjj3:/home/suse1 # 


thanks