Can't connect and iwlist scan/NetworkManager differ

I’ve been trying to get my network working for quite a while now, hoping that my connection would magically work with one of beta’s. This because I thought I had an intel wifi 5300 card… but it seems to be a 4965AGN after all… although I’m still not sure and the intel tool that should tell me so just crashes…

Anyways, my network card works 100% perfectly fine under vista as a 4965AGN, so I’ll just assume it is (even though where I bought the laptop it’s listed as 5300).

I’m currently running 11.3 Beta hoping the new kernel would get my wireless working…

Back on topic, NetworkManager returns me 3 networks each time but the problem is… my own isn’t among them. However when I run “iwlist scan” from the command line it returns me 7 networks including my own.

The information of my own network is as follows

Cell 05 - Address: 00:80:5A:4B:19:0C                                                                                                   
                    Frequency:2.462 GHz (Channel 11)
                    Quality=95/100  Signal level:-34 dBm  Noise level=-127 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra: Last beacon: 512ms ago

So my question is… how I do connect to this? (and later on, how do I connect to my college network using PEAP)

I tried connecting using Command line WPA | as my guide, but it ends up in a loop telling me my password could be wrong, though I’m sure it’s right, loop is like below

wpa_supplicant -Dwext -iwlan0 -c/home/Pascal/wpa.conf
Trying to associate with 00:80:5a:4b:19:0c (SSID='Bakhuis' freq=2462 MHz)
Associated with 00:80:5a:4b:19:0c
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
WPA: 4-Way Handshake failed - pre-shared key may be incorrect
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
ioctl[SIOCSIWENCODEEXT]: No such file or directory
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
ioctl[SIOCSIWENCODEEXT]: No such file or directory

I have 4965AGN (and it is listed in my notebook specifications).
And I don’t use built-in network manager.
I suppose your wireless card works according to the fact,
that you can see wireless networks. I think the problem is
finding good network manager.I wrote it allredy in the other thread,
so I just copy-paste, if you wouldn’t mind.

The only problem seem to be getting some network manager to work.

For me the default ‘Networked Manager’ was NOT working as I want , so I

  1. choosed in Yast -> Network Setting Traditional method with ifup
  2. left my wireless card unconfigured in Yast
  3. installed wicd
  4. started wicd daemon (you can also make it start automatically via Yast -> System Services)
  5. connected successfully to my wireless network using wicd GUI

Also there is wifi-radar wireless network manager
(It works better, than default manager, but sometimes just fails to connect,
and I never was able to connect with it to my WPA2 home wireless network)

As a monitor, to see whether network connection works or not i use knemo.

P.S. I used some wicd 1.4.2 version noarch.rpm
(which is only on my HDD now, cannot find it on the Internet),
but I think installing from source shouldn’t be difficult if you mind the depencies.
wicd - download

Hmmm… Have you tried editing your wireless connection in YAST and putting in the ESSID of your network? Maybe that would “kick” NetworkManager to connect to the right network…

I downloaded wicd, ran the commands

python configure
python install

(Few errors on the configure, but it stated it’s normal if you run it the first time)

I then rebooted since it stated in the readme to restart the dbus, but it doesn’t say how and I couldn’t find out how… so I went with the logic of an OS reboot restarts everything.

Now after a reboot when I execute wicd it returns

Traceback (most recent call last):
  File "/usr/lib/wicd/", line 46, in <module>
    import dbus
ImportError: No module named dbus

line 46 in /usr/lib/wicd/ simply states “import dbus”.
So I’m guessing I still need to reboot my dbus?

I think there is a bug open against this (in the openSUSE 11.1 Beta) and do remember reading something about this.

These might be related:

There are more wireless issues reported in bugzilla, so I’d say also check to see if you’re not dealing with a known issue.


They all seem unrelated.
I seem to have it working now by using ndiswrapper and the 64 bits XP drivers. Only problem is that I have to visit Yast / Network devices now… it just has to load… I can then press the abort button / just close the screen and my wireless works. Which is rather annoying since I don’t want to load up this screen every time.

Is there any way to write a shellscript or something to simulate whatever the yast netwerk device settings window is doing when it loads? and then it to the startup?

I did add it to /etc/init.d/network

Mmh I tried this as well

Loading Ndiswrapper at Boot (opensuse 10.3)

In some cases (USB wlan?) configuring the wireless interface with YaST, does not load the ndiswrapper module automatically in opensuse 10.3. To get you wlan card to work at boot time, you have to edit your network script in /etc/init.d/network (as described above).

Another method is to edit the config file /etc/sysconfig/kernel, by adding ndiswrapper into MODULES_LOADED_ON_BOOT section (e.g.: MODULES_LOADED_ON_BOOT=“ndiswrapper”).

Which didn’t help me one bit :P, the networkmanager doesn’t even see my wireless until I loaded the “Configure network settings” screen. As soon as it’s done loading my network is recognized and it automatically connects… which I what I want… apart from manually going to the “configure network settings” screen every reboot.