Can't configure usb network in YaST

(I may rant a bit here, since usb networking has always been a pain in SuSE, but this the the first time I’ve had to ask for help. Please forgive me.)
From /var/log/messages as I plug in the device:

kernel: usb 3-2: new full speed USB device using ohci_hcd and address 2
kernel: usb 3-2: configuration #1 chosen from 1 choice
kernel: usb 3-2: New USB device found, idVendor=057c, idProduct=3a00
kernel: usb 3-2: New USB device strings: Mfr=1, Product=2, kernel: usb 3-2: Product: USB DSL Device
kernel: usb 3-2: Manufacturer: AVM
kernel: eth1: register 'cdc_ether' at usb-0000:00:13.2-2, CDC Ethernet Device, 00:04:0e:20:13:12
kernel: usbcore: registered new interface driver cdc_ether
 ifup:     eth1
 ifup:               No configuration found for eth1

This is OK, since it isn’t configured yet.
I start YaST->Network Devices->Network Settings and see:

USB DSL Device  Not configured
RTL8111/8168B PCI Express Gigabit Ethernet controller DHCP

I select the DSL Device and click edit. This takes me to the address tab where I see:

Device Type: ARCnet

Is this right? But it can’t be changed.


Dynamic Address DHCP

I click ‘Next’ and ‘Finish’ and YaST seemingly completes with no errors. However, ‘network restart’ results in this appearing in /var/log/messages:

ifup:     eth1
syslog-ng[1929]: new configuration initialized
ifup:               No configuration found for eth1

Going back to YaST->Network Devices->Network Settings the DSL Device is listed as Not configured.

I’ve also set the eth0 interface to a static IP address (since the ultimate goal is to forward this interface to the USB. Worked fine for five years on my old hardware. Should work on this, too.) with the same result. The configuration for the USB on eth1 is never saved.

Can someone tell me how to set this up manually? And is this a but in YaST, or a bug in my brain?


I copied ifcfg-eth1 from my old machine and the network now works. YaST still has a bug, though.