Can't configure MySQL.

Following my [own wiki article](through socket ‘/var/run/mysql/mysql.sock’ (2)) I attempted to configure MySQL but when I run mysql_install_db --user=mysql and hit enter at the very first step I get

ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysql/mysql.sock' (2)

(openSUSE 11.2 milestone 1, x86_64)

You wouldn’t happen to be running MySQL 5.1 by any chance?

rpm -q mysql

If not, have you started the MySQL server with rcmysql start ?

Umm yes I am, 5.1.34-29.1 I shouldn’t be?

Going by the wiki article it doesn’t need to run at this stage yet, starting it is the next step.
So should I downgrade to 5.0?

The sock path in 5.1 changed - the easy way would be to downgrade to 5.0, 5.1 came out a bit raw anyway.

Alright, I’ll just downgrade then.
Just need it working, can’t say I care much about the version :slight_smile:

Thanks for the answer.

Why can’t it ever go smooth?
Downgraded to 5.0.67-16.1 and still getting the same error, even rebooted to no avail.

[edit]
I just scrolled up it isn’t entirely the same…

ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

Path changed, other than that it’s the same.

rcmysql status and then if it’s not running rcmysql start

Status was unused so I ran the start command.

mysql_install_db --user=mysql
still gave me Installation of system tables failed!
**
But ** /usr/bin/mysql_secure_installation
ran smoothly, so I guess it’s all good.

Thanks again.

By the way, to make it automatically start on system start; chkconfig mysql on

I’m a clicker usually set it to autostart under YaST > Configure Runlevels.
And now that I posted anyways, I can confirm mysql does run fine despite the warning earlier both the command line client and phpMyAdmin connecting fine :slight_smile:

Guess I’m in for a treat tomorrow, might have to install postgresql as well, and didn’t pull that off successfully yet… ever.