Can't compile ndiswrapper

I use a Netgear WNA3100 Network Adapter that needs a patched version of ndiswrapper to work. So far I successfully compiled ndiswrapper in both Ubuntu and Fedora, but it wont work on openSUSE 11.4. I installed all necessary software I need, at least I think so. I have installed the following before trying to build ndiswrapper

make gcc kernel-syms kernel-dev kernel-source ndiswrapper-kmp-desktop

Also tried installing linux-headers-uname -r as I did in Fedora, but in openSUSE it was not necessary.

Here is the errors I get. Google could not help me this time so hopefully someone at this forum can.

wahlgren@linux-ubyv:~/Downloads/ndiswrapper-1.56> make
make -C driver
make[1]: Entering directory `/home/wahlgren/Downloads/ndiswrapper-1.56/driver'
make -C /usr/src/linux- M=/home/wahlgren/Downloads/ndiswrapper-1.56/driver
make[2]: Entering directory `/usr/src/linux-'
make -C ../../../linux- O=/usr/src/linux- 
  CC [M]  /home/wahlgren/Downloads/ndiswrapper-1.56/driver/loader.o
/home/wahlgren/Downloads/ndiswrapper-1.56/driver/loader.c:834:2: error: unknown field ‘ioctl’ specified in initializer
/home/wahlgren/Downloads/ndiswrapper-1.56/driver/loader.c:834:2: warning: initialization from incompatible pointer type
make[5]: *** [/home/wahlgren/Downloads/ndiswrapper-1.56/driver/loader.o] Error 1
make[4]: *** [_module_/home/wahlgren/Downloads/ndiswrapper-1.56/driver] Error 2
make[3]: *** [sub-make] Error 2
make[2]: *** [all] Error 2
make[2]: Leaving directory `/usr/src/linux-'
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/home/wahlgren/Downloads/ndiswrapper-1.56/driver'
make: *** [all] Error 2

Found out it had to do with patches, but those patches I needed didn’t work with openSUSE. So guess I have to get another wireless adapter/card or go for another distro.

Problem solved! NetGear WNA3100 is not detected