Can't compile LookingGlass master branch

I’ve trying to compile LookingGlass on my Leap workstations (2 different PCs):

  • sadly I can’t. Previous releases (A12 for example) worked without a hitch. With the master branch now I got this after “make”:
 94%] Linking C executable looking-glass-client
/usr/lib64/gcc/x86_64-suse-linux/7/../../../../x86_64-suse-linux/bin/ld: /usr/lib64/gcc/x86_64-suse-linux/7/../../../../lib64/libbfd.a(plugin.o): undefined reference to symbol 'dlsym@@GLIBC_2.2.5'
/usr/lib64/gcc/x86_64-suse-linux/7/../../../../x86_64-suse-linux/bin/ld: /lib64/ error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make[2]: *** [CMakeFiles/looking-glass-client.dir/build.make:173: looking-glass-client] Błąd 1
make[1]: *** [CMakeFiles/Makefile2:82: CMakeFiles/looking-glass-client.dir/all] Błąd 2
make: *** [Makefile:130: all] Błąd 2

I’ve reached to maintainer and he suggested to install binutilus-devel package. I already have it installed:

Any suggestions what can I try to make it work?

Although development/compiling questions are often answered in this Forum, more difficult questions like this probably belong in the Development forums.
And, this specific question relates to KVM PCI Pass-through which is an extra complication.

From what you posted,
I can anticipate 2 likely sources for your error…

  1. The package dependency list is for Debian packages… Have you installed the corresponding RPM packages? If you’re not sure, you should post your dependencies inastall list.
  2. There might be a fixed path in the cmake script which would break the build. Would need to be fixed.


Looks like some Looking Glass packages have been built for openSUSE…


thank you for looking it up Tsu. I’ve looked at those - those seem to be packages for previous versions, not the current master.
And I’ve been able to build those. Sadly recently previous builds started to cause issues (worked nicely for over a year - I guess one of the recent updates broke those, currently I’m able to make it work around 1 in 5 attempts). So far the gdb output seem to point to problem with SDL from OpenSUSE repos (note - as I’m not a programmer I’m just forwarding suggestion from the dev).

I’m trying to find a culprit - and also trying to follow a suggestion to try current master branch (current master have extra dependency - binutils) . CMake step goes thorough, but during make I got the error quoted in the 1st post.
Any suggestion howto make it compile are greatly appreciated as this is way beyond my knowledge. I’ll also continue investigating why previous releases started to fail (currently dev asked me to check it with Valgrind).

Skimming your level1techs forum thread, both your thread hijacker and yourself seem to have a strong aversion to posting your installed packages, which I noted was one of the two most likely causes of error you should check first.

Please post.


there’s no ill will on my end tsu - but i simply don’t know what command I could use to provide those. As you can see when I’ve been asked to check whether binutils-devel is installed I did it and provided screenshot from Yast. Let me know what should I check / what command I should use and I’ll happily provide output :slight_smile: .
One extra note - the “hijacker” (not really - thread there is designed for troubleshooting for all folks :slight_smile: ) had issues with compiling A12 release, not master branch. On my end I haven’t encountered problems with it (other than that since recently those do not work correctly on SUSE - seem sdl problems).

tried A12 release with upgraded SDL2 libraries. I’ve taken 2.0.9 from Games experimental repo - and now LookingGlass A12 seems to be working without a hitch.
Suggests there indeed is a bug in SDL package (2.0.8) found in regular repository - should it be reported somewhere?

I’m still looking for getting master branch to compile - just for futureproofing :slight_smile: . But I’ll probably ask about that in development section as Tsu suggested.

Glad to hear you are making progress.
The YaST screenshot only displays your binutils and binutils-devel, does not list all your dependencies. If you decide to create a bug report, you will need to provide <complete> information about your compilation efforts which would include a complete list.

If you can either pinpoint exactly what is missing in a package or can provide a sufficiently detailed description of what you’ve done so that someone can replicate your steps and arrive at same results, you can submit a bug at


yeah, Tsu but my point is - how can I provide that information? I really do not know.
And how to make it relevant? If there was command that would list ALL the packages I have installed I guess that wouldn’t be useful as that would be insanely long list.

As stated above - I narrowed down issues with A12 release to SDL2 packages that are in OpenSUSE repos. It suggests there’s an issue with them. When it comes to master branch I can’t get it to compile (on 2 different machines) - followed the suggestion of the dev and checked whether binutils-devel is present on my system. It is. I literally have no clue what might be missing and what can I try next.